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Introduction

The CASEVision™ family of products from Silicon Graphics® provides a
wide spectrum of computer-aided software engineering (CASE) tools,
ranging from individual productivity tools to tools for managing teams of
programmers.

All tools in the CASEVision product line share a common environment. The
tools are UNIX®-based and run in the X Window System™ with an
OSF/Motif™ user interface. They use standard Motif elements such as the
File Browser (used to save and load files) and offer easily set X defaults.

The CASEVision environment also offers a comprehensive on-line help
system with context-sensitive access. You can ask for the working details of
any single feature within a tool, for overall information about a window or
tool, or you can browse through a hierarchy of help topics.

All CASEVision tools provide access to source code through a common text
editor called Source View. Source View provides a window displaying lines
of text in a source code file. It can display line numbers and special
annotations associated with a particular CASEVision tool., such as debugger
trap icons or performance analysis metrics. Source View also offers simple
text editing features and the ability to fork other text editors such as vi or
gnuemacs.

Many CASEVision tools provide graphical representations of code, such as
function call trees or class hierarchies. These have common features for
manipulating the presentation so that you can focus on the data of specific
interest or get a larger overview.
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Introduction

Using This Guide

This user’s guide to the CASEVision environment contains:

• Chapter 1, “Setting Color Schemes and Font Size”

• Chapter 2, “Using On-line Help”

• Chapter 3, “Using the File Browser and Keyboard Accelerators”

• Chapter 4, “Using Source View”

• Chapter 5, “Graphical Views in the CASEVision Environment”

Conventions

In text descriptions, button names, filenames, applications, variables,
directory pathnames, and new terms are shown in italics. Command syntax
descriptions, screen displays, and examples are shown in fixed-width

font . User entries and keyboard commands are shown in bold

fixed-width font .
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Chapter 1

1. Setting Color Schemes and Font Size

One of the advantages of working in the X Window System environment on
a Silicon Graphics workstation is the wide choice of screen colors you have
to work with. It can also be a disadvantage if you consider the number of
color choices combined with the 500 plus customizable resources available
in Motif. The CASEVision environment provides a number of predefined
color and font collections for the tool windows referred to as schemes. The
scheme approach e liminates the endless details involved with specifying
resources. By making the single choice of a scheme, you can easily change
the tones of all your CASEVision windows. You also have a choice of two
font sizes for text appearing in the windows. Together, these options help
make the CASEVision tools easy to view and the text within them easy to
read.

This chapter covers the following topics:

• “Available Color Schemes”

• “Setting Color Schemes”

• “Font Size”
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Available Color Schemes

The CASEVision schemes have been designed for specific purposes. They
take into account preference for light or dark text, color intensity, red-green
color-blind users, and monochrome displays. CASEVision offers twelve
different color schemes for CASEVision tool windows, as shown in
Table 1-1.

These color schemes are shown in Figure 1-1 through Figure 1-12.

Table 1-1 CASEVision Color Schemes

Scheme name Text /
Background

Comments

Leonardo Dark on light Low intensity colors

Lascaux Light on dark Silicon Graphics look, used as default scheme

Whistler Light on dark Darkest scheme

Turner Light on dark Bright, contemporary colors

Sargent Light on dark Conservative, darker colors

VanGogh Light on dark Purple-base

Titian Dark on light Same as Lascaux but with a peach cast

Gainsborough Light on dark Good for color-blindness, no red / green
contrasts

Rembrandt Light on dark Greens and browns

Willis Dark on light For black-and-white terminals, with fewer fonts

Monet Light on dark Pastels

Print Dark on light Gray-scale for printing black-and-white screen
captures
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Figure 1-1 Leonardo Color Scheme Example

Figure 1-2 Lascaux Color Scheme Example
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Figure 1-3 Whistler Color Scheme Example

Figure 1-4 Turner Color Scheme Example
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Figure 1-5 Sargent Color Scheme Example

Figure 1-6 VanGogh Color Scheme Example
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Figure 1-7 Titian Color Scheme Example

Figure 1-8 Gainsborough Color Scheme Example
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Figure 1-9 Rembrandt Color Scheme Example

Figure 1-10 Willis Color Scheme Example
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Figure 1-11 Monet Color Scheme Example

Figure 1-12 Print Color Scheme Example
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Setting Color Schemes

When you start any of the tools in a UNIX shell, you can choose one of these
color schemes by adding the option -scheme <color>  in the command line.
<color>  is the name of the color scheme you want to use. For example, to
start the Static Analyzer using the Whistler color scheme, you use the
command:

cvstatic -scheme Whistler

When you start a tool without specifying a color scheme, the tool appears in
the default color scheme, which is set initially to Lascaux. To set a different
default color scheme, add this line to your .Xdefaults file:

*scheme: <color>

where <color> is the name of the color scheme you want. The .Xdefaults file
is located in your home directory. If you don’t have an .Xdefaults file, you can
create one to hold the color scheme line. For example, the line

*scheme: Leonardo

in the .Xdefaults file sets the default color scheme to Leonardo. If you’re using
only .Xdefaults, then the next CASEVision tool you start will be in the new
color scheme. If you’re using xrdb, then you need to reload the database by
typing

xrdb -load -/.xdefaults

For more information on setting X defaults, consult X Window System User’s
Guide, OSF Motif Edition (Volume III) by Tim O’Reilly, Valerie Quercia, and
Linda Lamb-O’Reilly and Associates, ISBN 0-937175-61-7.

Font Size

CASEVision offers two font sizes for text displayed in its tools: large and
small. When you start a tool, CASEVision tests the resolution of the monitor
you’re using to see if it offers high or low resolution.

If you’re using a high-resolution screen, CASEVision defaults to a large font
size to make text easily readable. On the other hand, the small font enables
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you to see more text on the screen at one time. You can switch to small font
if you prefer by adding the following line to your .Xdefaults file:

*useSmallFonts: True

This causes all subsequent CASEVision tools to use the small font size. To
return to the large font size, either delete the line from .Xdefaults or change
True  to False .

If you’re using a low-resolution screen, CASEVision defaults to the small
font size because windows with the large font are too big for the screen. You
can’t override the default small font size if you have a low-resolution
monitor.
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Chapter 2

2. Using On-line Help

All applications in the CASEVision environment provide assistance through
the On-Line Help facility. On-Line Help information is organized into a
hierarchical tree made up of help cards. A help card provides information on
a specific topic, such as a feature in a window or a command. You read help
cards in the Help Viewer window. You can peruse the Help topics available in
the Help Browser window, arranged in the Help hierarchy, by alphabetical
index, or graphically.

This chapter covers the following topics:

• “Requesting Help”

• “Using the Help Viewer”

• “Using the Help Browser”

• “On-Line Help Tutorial”
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Using On-line Help

Requesting Help

If you need help in an application in the CASEVision, you have three options
for requesting it:

• Use the Help menu (located at the far right of the menu bar in
CASEVision tools)

• Click the Help button (in windows where there is no Help menu)

• Press the <F1> key while the cursor rests on the area of a CASEVision
window for which you want information

When you ask for help directly, the Help Viewer window appears displaying
text explaining a feature or overview of a tool. If you ask for the Help index,
the Help Browser window appears, showing the full structure of available
help so you can navigate easily through Help topics to the information you
need.

After requesting help about a subject, you can navigate up or down the
hierarchy to adjacent topics for additional information. Since the On-Line
Help utility is intended to complement paper documentation, you should
also refer to the appropriate user’s guide.

The Help Menu

The Help menu in a CASEVision tool has four commands, as shown in
Figure 2-1. The menu provides these options:

“On Version...”
provides general copyright and version number
information on the current tool.

“On Window...”
displays the Help Viewer with an overview of the current
window’s usage. Figure 2-2 shows the Help Viewer with
typical window information.

“On Context...”
lets you select a feature with the cursor and display the Help
Viewer describing that feature. An example is shown in
Figure 2-3. Note that “On Context...” cannot be applied to
menu items.

Figure 2-1
Help Menu in CASEVision
Environment
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Figure 2-2 The Help Viewer with Typical Window Information

Figure 2-3 The Help Viewer with Typical Context Information
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“Index...”
displays the Help Browser, which lets you browse a list
(partial or entire) of Help topics, alphabetically,
hierarchically, or graphically, and make a request. The Help
Browser appears in Figure 2-4.

The first selection, “On Version...”, doesn’t start On-Line Help but instead
opens a small dialog box that gives information about the program name
and version. The other three commands do start On-Line Help.

As a general rule, select “On Window...” if you are new to the use of this
window. It brings you into the Help system at the window overview level.
Use “On Context” if you have a general idea of the window’s purpose, but
are not familiar with a particular feature. Use “Index...” if you want to view
the list of topics prior to making your selection.

Figure 2-4 The Help Browser in Hierarchical Mode
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The Help Button

Certain CASEVision dialog boxes and windows (such as File Browsers or the
Help Viewer itself) have no menu bar and offer help through a Help button
instead. Clicking the Help button opens a Help Viewer with window-level
information displayed.

The <F1> Key

Like the “On Context” command of the Help menu, the <F1> key offers
context-sensitive help; in addition, it provides information about menu
commands. To use it, move the cursor over any feature for which you want
information; then press the <F1> key. A help Viewer opens (if none is already
open) with information about that feature. The <F1> key is an excellent way
to get information about menu items: click once on a menu to open it, then
move the cursor over the menu item you want, and press <F1> to see
information about it.

Using the Help Viewer

The Help Viewer window displays information in help cards, which appear
one per topic. A typical Help Viewer appears in Figure 2-5.



16

Using On-line Help

Figure 2-5 Typical Help Viewer

The Help Viewer has three major areas:

• Help card display area

• Topic list

• Help Viewer control area

The help card display area presents the information on the selected topic. If you
can’t see the full text of a card in the window, you can use the scroll bars to
reveal the missing text.

The topic list displays either the immediate subtopics below the current card
or the previous help cards you have accessed, depending on whether the List
subtopics button or List history button is toggled. You can access topics from
the list by double-clicking them.

Help card display area

Topic list

Help Viewer control area
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The Help Viewer control area provides these controls:

List subtopics
changes the topic list to display the subtopics of the current
Help topic. You can switch to one of these topics by
double-clicking.

List history
changes the topic list to display the previous help cards you
have accessed. You can then return to a prior topic by
double-clicking.

Active Viewer
toggles the current Help Viewer status between active and
inactive when you have more than one Help Viewer up at
the same time.

More general
displays the parent topic to the current help card.

Recent
re-displays the previous Help topic.

Browser
displays the Help Browser window.

Print
sends the text information displayed in the Viewer window
to your default line printer.

Help
provides information on how to use the On-Line Help
system.

Copy
displays a duplicate Help Viewer. This is a useful technique
for keeping an important help card visible as you browse
through other Help topics.

Close
closes the Help Viewer.

When the Help Viewer is displayed, pressing <F1> changes the Viewer to the
new topic selected.
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Using Multiple Help Viewers

You can open more than one Help Viewer by clicking the Copy button in a
Help Viewer window. This opens a copy of the current Help Viewer window
that displays the same Help topic. You can then look for new Help
information in one window while the other window displays the initial
information - a useful way to keep an important help card constantly visible
as you browse through other Help topics.

When you open multiple Help Viewers, only one Viewer at a time can be the
active Viewer. The active Viewer is the one that responds to outside requests
for a new topic such as pressing <F1> in another window. You can tell which
Viewer is active: the Active Viewer button next to the topic list is turned on,
and the controls at the bottom of the window are outlined in red. Inactive
Viewers have controls outlined in blue, and the Active Viewer button is
turned off. (Note: if you do not Lascaux, the default color scheme, these two
colors may be different.)

To change an inactive Viewer to the active Viewer, click its Active Viewer
button to turn it on. Simply moving to an inactive Viewer and changing
topics internally with its topic list won’t activate the Viewer.
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Using the Help Browser

If you want to browse through topics in On-Line Help, use the Help Browser.
You can open the Browser by choosing “Index...” from the Help menu in a
CASEVision tool or by clicking the Browser button in any Help Viewer
window. The Browser’s display area shows the hierarchy of Help topics
available for CASEVision, which you can look at in any one of three views:

• Topic Hierarchy shows the Help topics in outline form; higher level
topics appear closer to the left side of the display, subtopics are
indented to the right under their parent topics. See Figure 2-6.

• Topic Index lists Help topics in alphabetical order beneath each tool. See
Figure 2-7.

• Graphical presents Help topics in a branching tree as shown in
Figure 2-8. Each Help topic is a node in the tree, and each connection
between a topic and a subtopic is an arc.

To choose a view, click the appropriate button in the bottom left corner of the
Browser window. Use the vertical scroll bar to scroll up and down through
the topics in all three views. Use the horizontal scroll bar to scroll left and
right through the topic tree.

Each mode has a topic display area, a Help Browser control area (for
switching modes), and a display control area specific to the mode.

You can request a Help Card from the Help Browser by double-clicking it or
by selecting it and clicking the View button.(Note that there is no View button
in Graphical mode.) This displays the information in the active Viewer or
displays a new Viewer if none is available. The active/inactive status of any
concurrent Help Viewers is indicated in the Help Browser. The Help Browser
displays the active Viewer in red; any inactive Viewers are shown in blue.
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Figure 2-6 Help Browser Topic Hierarchy List

Figure 2-7 Help Browser Topic Index List

Topic display area

Current viewer topic

Hierarchy display control area

Help browser control area

Topic display area

Current viewer topic

Index display control area

Help browser control area

Top of scope
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Figure 2-8 Help Browser Graphical Display

Searching for a Topic

In either of the two text views (Topic Hierarchy or Topic Index), you can
search for a topic by entering a search string in the Search field below the
display area. The Search field uses an incremental search; as you enter
characters, the Browser searches the list of topics from the top to bottom to
match what you’ve typed so far. It selects the topic where it finds the match
and scrolls the display area to show the topic. Each time you press <Enter>

after you’ve typed search text, the Browser moves on to the next topic
containing the search text. To view the found topic, double-click it or click
the View button.

Setting Scope in Topic Hierarchy View

If you want to view only a restricted set of subtopics in the Topic Hierarchy
view, you can set the scope of the view: Click on the general topic you want
to view, then click the Set Scope button below the display area. The topic at

Topic display area

Graphical display control area

Help browser control area
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the top of the scope is displayed in purple, as shown in Figure 2-7. The
Browser restricts the scope of the hierarchy to the selected topic, its
subtopics, and subtopics below that. This feature is useful for viewing
information limited to a specific tool or window, for example.

To set the scope farther back up the topic hierarchy, click the Expand button;
The scope moves up to the parent topic of the highest level topic in the
display area and displays the subtopics of the parent topic.

Using Graphical View

The Browser’s graphical view of topics and graph controls (see Figure 2-8)
are used in other CASEVision applications. Because these are standard
controls common to the other CASEVision tools, two of the buttons (Multiple
Arcs and Realign) are not functional here, since they don’t apply to the topic
tree in the Browser. For more information, see Chapter 5, “Graphical Views
in the CASEVision Environment.”

On-Line Help Tutorial

This tutorial starts by getting help from the Help menu in any CASEVision
tool and takes you through a series of exercises highlighting the major
features of On-line Help.

1. Start any CASEVision tool and select “On Version...” from the Help
menu

A dialog box displays identifying the application, operating system,
and release information.

2. Click OK to close the Version dialog box.

3. Select “On Window...” from the Help menu.

The Help Viewer displays, containing a summary description of the
current window.

4. Select “On Context” from the Help menu, position the cursor (now in
the form of a question mark) over some feature in the window, and
click.
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The Help Viewer topic display switches to the feature you have
selected.

5. Select “Index...” from the Help menu.

The Help Browser window displays. This demonstrates how to access
Help Browser from the Help menu. Let’s close the Help Browser for
now and re-open later from the Help Viewer.

6. Click the Close button in Help Browser.

7. Click the Help button in the Help Viewer.

The Help Viewer displays the Help on Help topic, which is appropriate
for this demonstration. Figure 2-9.

Figure 2-9 Help Viewer Displaying Help on Help

8. Click List History.

The previous topics you accessed are listed in the topic list area at the
lower left of the Help Viewer. This is useful if you need to return to a
previously accessed topic. You can also click the Recent button to return
to a prior topic.
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9. Click List Subtopics.

The topics subordinate to the current help card display.

10. Double-click the topic called Requesting Help in the topic display.

The text for this topic displays in the Help Viewer. Its only subtopic,
Help Menu, appears in the topic display.

11. Click the Browser button

The Help Browser window displays in hierarchy mode with
Requesting Help in red because it is the active Viewer topic. See
Figure 2-10.

Figure 2-10 Help Browser with Requesting Help Active

12. Click the Graphical button in the Help Browser.
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The topic display changes to graphical mode with topics shown as
labeled rectangles in a hierarchy. You can experiment with the graph
controls to see the effects. Remember that Multiple Arcs and Realign, the
fourth and fifth buttons from the left, are not enabled in Help Browser.

13. Click the Copy button in Help Viewer.

A duplicate Help Viewer is created displaying the same topic.

14. Double-click any subtopic in the Help Viewer topic display.

The selected topic displays. This is a useful technique for keeping a
topic displayed while examining new topics. The blue-highlighted
Help Viewer is inactive; the red one is active.

15. Click the Close button in each of the open Help windows to end this
tutorial.
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Chapter 3

3. Using the File Browser and Keyboard
Accelerators

The CASEVision tools are designed to be conform with OSF/Motif
standards. They typically use the standard Motif File Browser to save and
load files. Command mnemonics and keyboard accelerators have been
designed into the tools to provide quick access to menu items.

This chapter covers:

• “Using Motif File Browsers”

• “Keyboard Shortcuts”
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Using Motif File Browsers

Most of the CASEVision commands that save or load files use the standard
Motif File Browser or a close variation (See Figure 3-1). You can use the Motif
File Browser to change directories, view directory contents, select files, and
enter filenames.

Figure 3-1 Motif File Browser

Note: The WorkShop debugger has a view called File Browser which is
different. It accesses source files for the current executable.

Viewing Directory Contents

To view the contents of a directory, you need to specify the directory, either
through a filter or by explicit selection from a list. The files list then shows
files found in the current directory with any filtering applied.

You enter filters in the file filter area at the top of the Browser. Initially, the
current directory displays, followed by a wildcard (*) to include all files in
the directory. You can modify the filter by moving the cursor in to the file

File filter area

Directories list

Files list

File selection field
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filter area, making the change, and pressing <Enter>  or clicking the Filter
button at the bottom of the Browser window. A new set of files displays. Use
other shell metacharacters to filter specific subsets of files in the directory.
You can also use the file filter area to change the current directory by
changing the pathname to a new directory.

The directories list below the file filter area lists the subdirectories of the
current directory. To move to a subdirectory, double-click the directory
name. To move up a directory, double-click the “.” entry, which is the second
name in the list.

As an alternative, you can type the pathname directly in the file selection field.
This is useful if you know the pathname and file, and prefer to avoid
navigation with the mouse.

Loading a File

Many CASEVision application windows provide a Load File dialog window
based on the standard Motif File Browser. To lad a file from the files list in
this window, double-click the filename. The File Browser closes and the file
loads. You can also load a file by clicking the filename to select it and then
clicking the OK button at the bottom of the Browser window.

If you prefer to type, move the pointer into the selection field, type in the
file’s full pathname, and then press <Enter>  or click the OK button. The
window closes and, if the file exists, the file loads.

Saving a File

The Save File dialog window is a variation of the standard Motif File
Browser. To save a file in this window, navigate to the directory where you
want to save the file, then move the cursor into the file selection area, and
enter the filename to be saved at the end of the pathname there. Press
<Enter>  or click the OK button. The File Browser window closes, and the file
is saved under the filename.

You can also save under an existing filename by finding a filename in the
Files list and double-clicking it. The File Browser window closes, and the file
is saved under the existing filename, overwriting any previous file contents.
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Exiting the File Browser

To exit the File Browser without completing the file request, click the Cancel
button.

Keyboard Shortcuts

The CASEVision environment provides keyboard shortcuts as alternatives
to selecting menu items with the mouse. The standard procedure for making
selections with the mouse is to click the menu title to display the menu and
then click the desired menu item. Alternatively, you can execute menu
commands from the keyboard using one of two methods: mnemonics or
keyboard accelerators (see Figure 3-2).

Figure 3-2 Command Mnemonics and Keyboard Accelerators

Mnemonics let you open a main menu by pressing the <Alt>  key and the
lowercase of the underlined letter in the menu title. You then select a
command or submenu by releasing the <Alt>  key and pressing the
lowercase of the letter that is underlined in that menu item. For example,
you can select “Iconify” from the Admin menu in Figure 3-2, by pressing

Menu mnemonics

Command mnemonics



Keyboard Shortcuts

31

<Alt>-m i . You can continue to use the selection process recursively
through submenus without pressing the <Alt>  key simultaneously.

Keyboard accelerators let you execute certain commands without opening the
menu through a combination of keys. These key combinations are displayed
in the menus next to the applicable commands. To execute these commands,
simultaneously press the lowercase of the letter and the <Alt>  or <Ctrl>  key
as defined. For example, to select the “Search...” command from the Source
menu in Figure 3-3, you would press <Ctrl>-s .

Figure 3-3 Source Menu in Workshop Debugger Main View
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Chapter 4

4. Using Source View

Source View is a simple text editor supplied in the CASEVision environment
that displays the lines of text in a source code file. You can start Source View
from most CASEVision tools by choosing the appropriate menu command,
usually “Source View.” In some tools, you can double-click icons
representing source code to start Source View. Source View displays the
source code, scrolled to the appropriate place.

This chapter covers these topics:

• “Source View Window and Menus”

• “Source View Usage”
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Source View Window and Menus

The basic Source View window is shown in Figure 4-1 with its two standard
menus displayed and major areas indicated.

Figure 4-1 The Source View Window

File menu

Display menu

Menu bar
Display area

Annotation column

Annotated scroll bar

File specification field Source status

Versioning submenu



Source View Window and Menus

35

All Source View windows have these components:

menu bar
always contains the File and Display menus.

display area
contains the source code to be edited.

annotation column
displays line numbers (if requested) and icons specific to
particular CASEVision tools.

annotated scroll bar
is different from a standard scroll bar in that it indicates all
occurrences of a target string during a search and lets you
scroll to an occurrence by clicking its indicator.

file specification field
displays the current file and lets you change files.

source status indicator
indicates Read Only, Editable, or Modified status.

The Source View menus and annotation margin icons vary depending on the
tool from which Source View is accessed. For example, the Source View
window executed from the CASEVision/WorkShop Debugger has margin
annotations for traps and a program counter. and two additional menus:
Traps and PC. The Source View window from Profiling View in the
WorkShop Performance Analyzer displays usage statistics in the annotation
margin.
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File Menu

The File menu (see Figure 4-2) provides these selections to deal with source
code files:

“Open...”
loads a source file.

“Save”
records changes made to the source file. If the file comes up
Read Only, you must first select the “Make Editable” item,
also from this menu.

“Save As...”
records changes made to the source file under a different
filename.

“Save As Text...”
records the information in the display area and annotation
margin (including line numbers and performance statistics
if displayed) as a text file.

“Open Separate...”
lets you select another file from a file browser and opens a
new Source View window containing that file.

“Insert File...”
inserts the text of a file within your current file. By default,
this selection is inactive (grayed-out) in the File menu when
the buffer is Read Only. “Insert File...” is enabled when you
click the “Make Editable” command.

“Clone”
opens a duplicate Source View window containing the same
file, in the same location as the original window.

“Fork Editor”
starts your default editor on the current file. The default
editor is determined by the editorCommand resource in the
app-defaults file. The value of this resource defaults to wsh

-c vi +%d, which means run vi in a wsh window and
scroll to the current line. If the editor lets you specify a
starting line, enter %d in the resource to indicate the new
line number.

Figure 4-2
File Menu
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“Recompile”
is functional only if you have installed
CASEVision/WorkShop. It starts the Build Manager, a
WorkShop tool that lets you compile the source code
associated with the current executable.

“Make Editable”/“Make Read Only”
toggles the source code displayed between writable and
read-only states so that you can edit your code. “Make
Editable” is the default selection because the source code is
initially Read Only.

“Search...”
searches for a literal or regular expression. Each instance of
the target is marked by a search target indicator in the scroll
trough area. Clicking an indicator with the middle mouse
button scrolls Main View to the point.

“Go To Line...”
lets you scroll to a position in the source code by specifying
a line number or moving a slider. “Go To Line...” brings up
a dialog box similar to the one shown in Figure 4-3.

Figure 4-3 Go To Line Dialog Box

You can enter a line number or use the slider at the top of
the box to select a line number. You do not have to display
line numbers to use this feature.

Slider

Line specification field



38

Using Source View

“Versioning”
provides access to the configuration management tool, if
you have designated one. The cvconfig script lets you
designate CASEVision/ClearCase from SGI, RCS or SCCS.
Simply type:

cvconfig [clearcase | rcs | sccs]

The “Versioning” submenu appears in Figure 4-4.

Selecting any of these options displays a shell in which you
can access the configuration management tool. The
selections in the submenu are:

“Versioning”:“CheckIn”
saves the source file and checks it into the database as a new
version.

“Versioning”:“CheckOut”
recalls the source file from the tool’s database if you have
the proper authority, locks it, and makes it editable.

“Versioning”:“UncheckOut”
cancels the checkout, with no changes registered.

“Close”
closes the Source View window.

Display Menu

The Display menu in Main View (see Figure 4-5) provides these selections to
annotate the source code displayed:

“Show Line Numbers”/“Hide Line Numbers”
displays or hides line numbers corresponding to the source
code to the left of the display area.

“Preferences...”
displays a dialog box (see Figure 4-6) that shows or hides
the icons from the other CASEVision tools: Parallel
Analyzer (Loops button), Performance Analyzer
(Performance button), and Tester (Test button).

Figure 4-4
”Versioning” Submenu

Figure 4-5
Display menu
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Figure 4-6 Display Preferences Dialog Box

Source View Usage

To start Source View, choose “Source View” from the Views menu (if your
current CASEVision tool does not have a Views menu, consult the
appropriate user guide to find out how to access Source View). In most
CASEVision graphical views, double-clicking a node (rectangle) displays a
Source View window containing the selected code.

Some alternative methods for starting Source View from the CASEVision
WorkShop tool are:

• In the Performance Analyzer, clicking the Source button in the main
window, double-clicking a node in Call Graph View, or double-clicking
a call stack in Heap View all display Source View.

• In the Static Analyzer, choosing “Edit Selected Item” from the Admin
menu, or double-clicking an element in the Static Analyzer’s main
display brings up Source View.

Opening a Different File

When you start the Source View window from a CASEVision tool, Source
View displays the source code selected from the parent tool. To access a
different source code file, choose “Open...” from the File menu and make a
selection from the File Browser.
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You can also open a new file using the file specification field in the bottom
left corner of the Source View window. Move the cursor into the area, type
the new file’s pathname, and press <Enter> . If you enter a filename that
doesn’t already exist, Source View creates a new file using that filename.

Viewing Source Code

The Source View window displays source code in its display area, the central
area of the window. Use the scroll bar at the right to scroll through the lines
of text. To see the full length of each line of code, drag any corner of the
window out to increase the window width. If you’re working with
exceptionally long lines of code, or want to keep the Source View window
small, you can add a horizontal scroll bar to the Source View window by
adding the line

*textEdit.scrollHorizontal: True

to your .Xdefaults file before you start Source View. Deleting the line from
.Xdefaults or changing True  to False removes the horizontal scroll bar the
next time you start Source View.

To view a specific line of code in Source View, choose “Go To Line...” from
the File menu to open the Go To Line dialog box shown in Figure 4-3.

You can enter the line number in either of two ways:

• Drag the slider in the top of the window to the desired line number.

• Move the cursor into the Go to line field and type the line number you
want.

Once you set the line number, either click the OK button or press <Enter>  to
close the window and jump to the line number in Source View’s display area.
If you click the Cancel button, you close the Go To Line dialog box without
scrolling the text in the display area.

Using the Annotation Column

Source View can display more than just the text of a source code file. It
displays additional information in its annotation margin, which you control
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through Display menu commands. If you choose “Show Line Numbers,”
you’ll see icons specific to the CASEVision tool. For example, Figure 4-7
shows a program counter at a stop trap, a stop trap, and a sample trap in a
WorkShop Debugger Source View window.

Figure 4-7 Icons in the WorkShop Debugger Source View Window

By default, the annotation margin automatically shows icons. To hide the
icons or the line numbers, choose either “Hide Icons” or “Hide Line
Numbers” from the Display menu.

Searching for Text

To search for text in a source code file, choose “Search” from the File menu,
which opens the Search dialog box (shown in Figure 4-8).

Program counter at stop trap

Stop trap

Sample trap
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Figure 4-8 The Search Dialog Box

The Search dialog box provides a Search field where you can enter a target
string. It also has a set of buttons that offers three search types:

Literal Case Sensitive
finds all text that literally matches the search text and treats
upper- and lowercase characters as different characters. For
example, it matches “new” with “new”, but not with
“New” or “NEW.”

Literal Case Insensitive
finds all text that matches the search text literally and
without regard to case. For example, it matches “new” with
“New”, “new”, or “NEw.”

Regular Expression
interprets the search text as a regular expression and finds
text to match the expression. Regular expressions use
special characters such as “*” and “[“ to construct wildcard
strings for matching a range of text. You can find
information about regular expression syntax in the man
pages for ed; you’ll find the same description in the On-Line
Help card for Regular Expression.

To search for text, move the cursor into the Search field and enter the search
text; then click the search option you want if it’s not already set. Press
<Enter>  or click the Apply button to start the search. Source View searches
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through the entire file for matching text and indicates matches by
highlighting the text where they occur. To show you where matches occur
throughout the file, Source View displays search target indicators along the
length of the scroll bar as shown in Figure 4-8. To scroll to a match, either
click the indicator with the middle mouse button or drag the scroll handle to
it. If a search is unsuccessful, no search target indicators appear on the scroll
bar.

Figure 4-9 Search Target Indicators

Each time you press <Enter>  or click Apply, Source View removes any
existing search highlighting and indicators and adds new highlighting and
indicators as the result of the new search. To clear highlights and indicators
without starting a new search, click the Reset button, which clears the search
text from the Search text area and removes highlights and indicators.

To close the Search window, click on either the Cancel or the Close button.
Cancel closes the window and removes any highlighting and indicators left
in the display area by the last search. Close closes the window and leaves
highlighting and indicators in place.

Search target highlight

Search target
indicators
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Editing Text

A source code file viewed in Source View has one of the two modifiable
statuses: Read Only or Editable. When the status is Read Only, you can’t edit
the source code file. When the status is Editable, you can edit text and make
changes to the source code file. The source status indicator, located below the
display area on the right side of the window, shows the status of the current
source code file. It also displays Modified if you’ve made changes to the
source code that haven’t yet been saved

Generally, when you start Source View from a CASEVision tool, it displays
the source code involved in the session, set to Read Only. To change the write
status, choose “Make Editable” from the File menu. To change a file from
Editable back to Read Only, choose “Make Read Only” from the File menu.

Editing text in an editable file follows typical text editing conventions. To
select a block of text, drag from the beginning to the end of the text you want.
To select a word, double-click the word. To select a line, triple-click the line.

Once you’ve selected text, you can delete it by pressing <Back Space> . If
you type new characters while text is selected, you replace the selected text
with the new text. To copy selected text to another location, move the cursor
to the new location and middle-click. As long as the original text is selected,
you can keep middle-clicking to insert copies of it into new locations.

To insert new text in the display area, click at the insertion point, then type
new text. You can press the <Back Space>  key to delete characters to the left
of the insertion point.

If you want to insert an entire file as new text, click on the point where you
want to insert, then choose “Insert File...” from the File menu. A file browser
opens, where you can choose the file you want to insert. When you click OK
to close the browser and load the file, Source View inserts the text of the file
at the insertion point in the existing file.
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Saving a Modified File

Once you’ve made changes to a source code file, you can save them using
any of three commands in the File menu:

“Save”
saves the modified file to the filename displayed in the file
specification field in the bottom left corner of the Source
View window.

“Save As...”
opens a File Browser which lets you enter a new filename
and save the modified file under that name.

“Save As Text...”
also opens a File Browser in which you can enter a new
filename and save the modified file under that name. The
difference between this command and “Save As...” is that
“Save As Text...” also saves line numbers if they’re
displayed and any text in the annotation margin of the
display area, such as Performance Analyzer statistics.

Using an Alternate Text Editor

If you’d rather edit a source code file using a text editor other than Source
View, choose “Fork Editor” from the File menu. By default, this command
opens a new shell that runs vi and works on the file in Source View. To set up
Source View so that it uses a different editor when you choose “Fork Editor,”
add a line to the .Xdefaults file:

*editorCommand: <editor>

where <editor> is the text editor you wish to start. The default is

*editorCommand: xwsh -e vi +%d

which opens an X shell, executes vi using the current file as its target, and
scrolls to the line number supplied after %d if there is one. You might try

*editorCommand: gnuemacs +%d

or even

*editorCommand: jot

if you want to edit using either gnuemacs or jot.
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Working with Multiple Source View Windows

Source View allows you to open other Source View windows by choosing
either “Clone” or “Open Separate...” in the File menu. “Clone” opens a
Source View window that displays the same file in the same location that
you’re viewing in the original window. “Open Separate...” opens a file
browser where you can choose another source code file, and then opens a
Source View window that displays the newly chosen file.

If you’ve started Source View from another CASEVision tool, such as the
WorkShop Debugger or Static Analyzer, then it may display traps or search
target indicators created by the parent tool. When you clone a Source View
window showing this additional information, the information also appears
in the cloned Source View window. Whenever you change a trap or work
with the program counter in one of the cloned Source View windows, the
trap and PC icons in the other Source View windows are updated to match.

Editing changes or viewpoint changes in one cloned Source View window
aren’t reflected, however, in other clones. When you scroll to a new location
or change the text in one window, those changes don’t appear in the other
windows. Source View does provide a safeguard, though, and announces
changes made to a file by one window with messages about the change that
appear in the cloned windows.

Quitting Source View

To quit Source View, choose “Close” from the File menu.
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5. Graphical Views in the CASEVision
Environment

Many tools in the CASEVision environment provide graphical views. The
CASEVision graphical view is a useful device for depicting relationships.
This appendix covers these topics:

• “General Graphical View Characteristics”

• “Manipulating the Display”

• “Filtering Nodes and Arcs”

General Graphical View Characteristics

The purpose of a graphical view is to provide an overview that shows
relationships between entities and a means of accessing the detail
information. In a graphical view, entities are shown as rectangles (or nodes)
and relationships as connecting arrows (or arcs). When entities represent
source code, double-clicking a node will bring up Source View with the
corresponding code available for editing.

A typical graphical view appears in Figure 5-1. Graphical views have a
display area with a row of controls underneath it. If the graph is larger than
the viewing area, scroll bars will be enabled.
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Figure 5-1 Typical Graphical View

Since an overwhelming amount of information can be displayed in a
graphical view, a number of methods are provided for simplifying the
display. They fall into two categories: those that manipulate the display
without changing the current contents and those that let you filter nodes and
arcs from the display.

Manipulating the Display

This section covers those methods that change the display without altering
the contents.

Graph Control Area

All graphical views have a control area containing a row of graph controls as
shown in Figure 5-2.

Graph display area

Graph control area

Tool-specific menu
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Figure 5-2 Graph Display Controls

Note: In some cases, the Multiple Arcs button may be disabled. This is
appropriate where there can only be one arc between nodes.

These graphical view controls are:

Zoom menu
shows the current scale of the graph. If clicked on, a pop-up
menu appears displaying other available scales. The scaling
range is between 15% and 300% of the normal (100%) size.

Zoom Out button
resets the scale of the graph to the next available smaller size
in the range.

Zoom In button
resets the scale of the graph to the next available larger size
in the range.

Note: If you reposition the nodes by dragging and then use
one of the Zoom buttons, the configuration will return to the
initial position.

Overview button
invokes the overview pop-up display, which shows a
scaled-down representation of the graph. The nodes appear
in the analogous places on the overview pop-up, and a
white outline may be used to position the main graph
relative to the pop-up. Alternatively, the main graph may be
repositioned with its scroll bars. See the following section.

Zoom menu

Zoom Out button

Zoom In button
Overview button

Multiple Arcs button

Realign button
Rotate button
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Multiple Arcs button
toggles between single and multiple arc mode. Multiple arc
mode is extremely useful for the “List Arcs” query, because
it indicates graphically how many of the paths between two
functions were actually used.

Realign button
redraws the graph, restoring the positions of any nodes that
were repositioned.

Rotate button
flips the orientation of the graph between horizontal
(calling nodes at the left) and vertical (calling nodes at the
top).

Note: If you reposition the nodes by dragging and then
change orientation, the nodes will return to the initial
positioning relative to each other.

Overview Window

The Overview window lets you view the entire graph at a reduced scale. To
display the Overview window, you click the overview button (see Figure 5-2).

Figure 5-4 shows a typical Overview window with the resulting graph. The
Overview window has a movable viewport that lets you select the portion
of the graph displayed in the main window. Special nodes and arcs are
highlighted for easy detection.

The Overview window has an Admin menu (see Figure 5-3) with these three
selections:

“Scale to Fit”
scales the graph to match the aspect ratio of the overview
window.

“Show Arcs”
displays or hides the arcs between the nodes.

“Close”
closes the Overview window.

Figure 5-3 Admin Menu in the
Overview Window
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Figure 5-4 Overview Window with Resulting Graph

Viewport
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Using the Mouse in a Graph

You can move an individual node in a graph by dragging it with the middle
mouse button. This can help reveal obscured arc annotations.

You can select multiple nodes by dragging a selection rectangle around
them. You can Ctrl-click to add a single node to the group. Shift-clicking a
node adds it to the group along with all the nodes that it calls. Once you have
selected a group of nodes, you can move them as a group with the middle
mouse button or perform other operations on them.

Selecting Nodes from outside the Graph

Often you can specify a node from a text view, search field, or dialog box and
it will be highlighted in the graph.

Filtering Nodes and Arcs

Another approach to simplifying a graph is to reduce the number of nodes
and arcs. Different tools have different filtering options. All graphs have two
types of node menus (accessed by holding the right mouse button) for
filtering nodes: the Node menu and the Selected Nodes menu. Both menus
are shown in Figure 5-5.
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Figure 5-5 Node Pop-up Menus

Node Menu

The Node menu lets you filter a single node. It is displayed by holding the
right mouse button down while the cursor is over the node. The name of the
selected node appears at the top of the menu. The Node menu selections are:

“Hide Node”
removes the selected node from the graph display.

“Collapse Subgraph”
removes the nodes called by the selected node (and
subsequently called nodes) from the graph display.

“Show Immediate Children”
displays the functions called by the selected node.

“Show Parents”
displays all the functions that call the selected node.

“Show All Children”
displays all the functions (descendants) called by the
selected node.

Node menu

Selected Nodes menu
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Selected Nodes Menu

The Selected Nodes menu lets you filter multiple nodes. You can select
multiple nodes by dragging a selection rectangle around them. You can also
Shift-click a node and it will be selected along with all the nodes that it calls.
Holding down the right mouse button anywhere in the graph displays the
Selected Nodes menu. The Selected Nodes menu items are:

“Hide”
removes the selected nodes from the graph display.

“Collapse”
removes the nodes called by the selected nodes (and
descendant nodes) from the graph display.

“Expand”
displays all the functions (descendants) called by the
selected node.
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