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Chapter 1

1. Introduction

The ImageVision tools are a suite of applications that let you view, enhance, arrange, and
obtain information on images, which can then be printed or used in other Silicon
Graphics applications. The ImageVision application tools are ImageView, ImageCopy,
ImageInfo, ImageFormats, Image Works, and ImageTcl.
Here are some of the ways you can use the ImageVision tools with other Silicon Graphics
applications:
•

Use the Capture tool to take a picture of an image, and then use the Image Works
and ImageView tools to enhance the image and arrange it with other images.

•

Customize an image using the ImageVision tools, then use the image in the Movie
Maker application to make your own movies.

•

Add a voice-over to an image using the Sound Editor application.

•

Print your image to use in hard-copy presentations.

This book contains the following additional chapters:
Chapter 2, “ImageView,” describes how to view images, save images to different file
formats, manipulate and compare images, arrange multiple images, and obtain
information on images.
Chapter 3, “ImageCopy, ImageInfo, and ImageFormats,” describes command-line
utilities available to you. These tools let you copy and change the format of image files,
obtain information about image files, and see a list of supported file formats.
Chapter 4, “Image Works,” describes how to manipulate images—blur, sharpen, stretch,
scale, and flip images—and save them to a file. Many of these image manipulations are
also available in the ImageView tool described in Chapter 2.
Chapter 5, “ImageTcl,” describes how to write your own scripts or programs,
incorporating the image-processing operations available in the ImageVision Library (IL).
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The icons for the ImageVision tools are located on the MediaTools page of the Icon
Catalog. To open the MediaTools page of the Icon Catalog, choose Media Tools from the
Find menu of the toolchest.

Conventions
This guide uses the following conventions:
•

References to other documents are in italics.

•

References to other chapters and sections within this guide are in quotation marks.

•

Names of buttons found in dialog boxes and panels are in italics.

•

“Clicking” refers to pressing and releasing the left mouse button, unless otherwise
specified.

•

“Dragging” refers to pressing and holding the left mouse button while moving the
mouse in the desired direction, unless otherwise specified.

•

The “+” character is used to indicate a sequence of keyboard keys to be pressed (for
example, Ctrl+A). While holding down the indicated command key, press the
indicated letter key.

Step-by-step instructions used to perform a task are shown as numbered sentences.
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2. ImageView

This chapter contains these sections:
•

“About ImageView”

•

“Opening Images”

•

“Enhancing the Appearance of an Image”

•

“Manipulating Geometric Aspects of an Image”

•

“Adjusting Images and Views”

•

“Scanning Through the History of Edits”

•

“Deleting an Image”

•

“Printing an Image, View, or Window”

•

“Saving an Image, View, or Window”

•

“Viewing Image Information”

•

“Customizing the ImageView Window”

About ImageView
ImageView lets you view images and manipulate the appearance of images. Multiple
images can be imported into the same window, allowing for comparison between images
or for the creation of image collages. ImageView also allows you to obtain various kinds
of information and technical data on images.
The ImageView window contains three main menus and a help menu:
File

Allows you to open images and to import multiple images into one
window, to print images and to save images into a different file format
if desired, and to close image files and quit ImageView.
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View

Allows you to arrange, compare, and delete images, to select all images,
to get information about images, and to resize the window.

Edit

Allows you to manipulate the appearance of images, to select how
images are displayed on the screen, to alter image transparency, and to
select specific components, sub-images, or frames of images.

The balance of the ImageView window is the image area and the tool bar. As you open
and import images, they appear in the image area. The tool bar gives you an alternate
way to manipulate images and open the control panels.
The imgview icon is on the Media Tools page of the Icon Catalog. To open ImageView,
choose Find > Media Tools from the toolchest, and double-click the imgview icon. You
can also type imgview in a shell window.

Opening Images
To open an image, choose File > Open and select the file. To open an additional image in
the same window, choose File > Import and select the file.
In certain file formats, such as PhotoCD, an image file can contain multiple sub-images.
You can specify which sub-image you wish to open by typing the filename followed by
a colon and the number of the sub-image (for example, Sunrise:3). Use the ImageInfo
tool to get a list of the sub-images in an image file. See “Getting Information About an
Image” and the imginfo(1) reference page for more information on that tool.

Enhancing the Appearance of an Image
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•

“Adjusting Image Sharpness”

•

“Adjusting Image Brightness, Haze, Contrast, or Saturation”

•

“Using Histogram-Based Scaling to Enhance an Image”

•

“Converting an Image to Its Photographic Negative”

•

“Using Transparency”

Adjusting Image Sharpness

Adjusting Image Sharpness
To adjust image sharpness, select the image, click the Enhance tab on the bottom of the
Process control panel, then make the adjustment using any or all of the following
methods:
•

Move the Sharpness wheel to the right to sharpen or to the left to blur the image.

•

Use the Sharpness up arrow to sharpen or the down arrow to blur the image.

•

Type a positive value in the Sharpness field to sharpen the image or a negative
value to blur the image.

•

Click the small box next to the Sharpness wheel to return the image to its original
state.

You can increase or decrease the effects of the Sharpness controls by changing the radius
of the kernel. The “kernel” is the group, or neighborhood, of pixels used in calculations
to sharpen or blur an image. See “Increasing or Decreasing the Effects of the Sharpness
Controls.”
You can also make the sharpening process faster and more efficient by making the kernel
separable. See “Making the Sharpening Process Faster and More Efficient.”

Increasing or Decreasing the Effects of the Sharpness Controls
You can increase or decrease the effects of the Sharpness controls by changing the radius
of the kernel. The “kernel” is the group, or neighborhood, of pixels used in calculations
to sharpen or blur an image. Note that using a larger kernel radius results in a more
time-consuming process.
To increase or decrease the kernel radius while sharpening or blurring an image, select
the image, click the Options tab on the bottom of the Process control panel, then make
the adjustment using any or all of the following methods:
•

Move the Radius wheel to the right to increase the radius or to the left to decrease
the radius.

•

Use the Radius up arrow to increase or the down arrow to decrease the radius.

•

Type a positive value in the Radius field to increase the radius or a negative value to
decrease the radius.

•

Click the small box next to the Radius wheel to return the radius to its original state.
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Use the Sharpness controls on the Enhance subpanel to sharpen or blur the image.

Making the Sharpening Process Faster and More Efficient
You can make the sharpening process faster and more efficient by making the kernel
separable. The “kernel” is the group, or neighborhood, of pixels used in calculations to
sharpen or blur an image. Making the kernel separable, however, trades accuracy for
efficiency. The kernel is always “separable” when blurring an image, so the Separable
option is relevant only when making images sharper.
To make the kernel separable when sharpening an image, select the image, click the
Options tab on the bottom of the Process panel, then click the Separable box to toggle it
on and off.
Use the Sharpness controls on the Enhance subpanel to sharpen the image.

Adjusting Image Brightness, Haze, Contrast, or Saturation
To adjust Brightness, Haze, Contrast, or Saturation, select the image, click the Enhance
tab on the bottom of the Process control panel, then make the adjustment using any or all
of the following methods:
•

Move the associated wheel to the right to increase the setting or to the left to
decrease the setting.

•

Use the up arrow to increase or the down arrow to decrease the setting.

•

Type a positive value in the associated field to increase the setting or a negative
value to decrease the setting.

•

Click the small box next to the associated wheel to return the setting to its original
state.

Using Histogram-Based Scaling to Enhance an Image
To enhance the selected image using histogram-based scaling, select the image, then
choose Edit > Histogram Scale in the Process control panel. The image redraws and the
Brightness and Haze settings on the Enhance subpanel adjust to display the new values.
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The Histogram Scale command removes the 5% of pixels with the highest component
intensities and the 5% of pixels with the lowest component intensities. The component
intensities of the remaining pixels are then linearly scaled to cover the full range of
component intensities.

Converting an Image to Its Photographic Negative
To invert the component values for each pixel of an image to create a photographic
negative, select the image, then choose Edit > Negate from the Process control panel.

Using Transparency
Transparency is most effective when you want to remove a solid background or an
undesired color from a GIF image:
1.

Click the Transparency button, shown in Figure 2-1.

Figure 2-1

Transparency Button

2. Move the crosshair cursor on top of a color in the image and click the left mouse
button. (For more precise color selection, choose View > Detail and use the Detail
panel to help you select the color.)
The red, green, and blue value of the pixel beneath the centerpoint of the cursor is
calculated, and all pixels matching that value become transparent.
If an area you want to make transparent contains multiple gradations of color (pixels
with varying RGB values), use the Define Transparency panel to better refine the color
selection. Choose Edit > Transparency to open the panel.

Using the Define Transparency Panel
Use the Define Transparency panel to refine color selection when there are multiple
colors or a range of colors that you want to make transparent.
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Selecting Multiple Colors for Transparency
To select multiple colors for transparency:
1.

Click on the image.
The image appears in the panel.

2. Click a square in the palette, then move the crosshair cursor on top of a color in the
image displayed to the right of the palette and click the left mouse button.
The red, green, and blue value of the pixel beneath the centerpoint of the cursor is
calculated, and all pixels matching that value become transparent. The color is also
stored in the palette.
3. Click another palette square and click the next color.
The color is stored in the palette.
To reset a color to its original state (no transparency), click on the palette square
associated with the color, then click the Reset current button.
Use Ctrl+Z and Ctrl+Shift Z to scan through or to undo and redo edits.

Selecting a Range of Colors for Transparency
To select a range of colors for transparency:
1.

Click on the image.
It appears in the panel.

2. Click a square in the palette then move the crosshair cursor on top of a color and
click the left mouse button.
The red, green, and blue value of the pixel beneath the centerpoint of the cursor is
calculated, and all pixels matching that value become transparent. The color is also
stored in the palette.
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3. With the same palette square selected, select a second color.
ImageView takes the range of RGB pixel values between the two you selected and
makes them transparent. It does this by calculating the mean between the two pixel
values, then determining the variance between the mean and the values. If the
variance is great, a greater number of pixel values are affected. If the variance is
small, a smaller number of pixel values are affected.
4. Continue to select colors until you attain the desired effect.
The High and Low Threshold sliders let you adjust the graduation between transparency
and opacity. To make the effect more graduated, move the High Threshold slider to the
right. To make the effect more severe, move the Low Threshold slider to the right.
Use Ctrl+Z and Ctrl+Shift Z to scan through or to undo and redo edits.

Manipulating Geometric Aspects of an Image
•

“Rotating an Image”

•

“Reflecting an Image”

•

“Zooming an Image”

•

“Choosing a Resampling Method”

Rotating an Image
Use the rotate button, shown in Figure 2-2, on the ImageView tool bar, or use the Geom
subpanel on the Process control panel to rotate an image.

Figure 2-2

Rotate Button

To use the button, click on it, then place the cursor on top of the image you want to rotate
and drag the mouse in a circular motion to the right or left.
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To use the Rotate control in the Process control panel, select the image, click the Geom
tab on the bottom of the Process panel, then use any or all of the following methods:
•

Move the Rotation dial pointer or click on a desired position on the Rotation dial to
rotate the image to the right or left.

•

Use the Rotation up arrow to rotate the image to the right or the down arrow to
rotate to the left.

•

Type a positive value in the Rotation field to rotate the image to the right or a
negative value to rotate to the left.

•

Click the small box above the Rotation dial to return the image to its original
position.

Note: If an image contains transparency, you may see a flashing effect while rotating the

image. You can eliminate this flashing effect by choosing Edit > Show Transparency.
Show Transparency is on by default. Choosing it removes the checkmark from the box
and turns transparency off. Choose it again to turn it back on.

Reflecting an Image
To flip the image horizontally or vertically, select the image, click the Geom tab on the
bottom of the Process panel, then click the Flip Horizontal or Flip Vertical box to toggle
the desired option on and off.

Zooming an Image
Use the Zoom button, shown in Figure 2-3, on the ImageView tool bar, or use the Geom
subpanel on the Process control panel to zoom an image.

Figure 2-3

Zoom Button

To use the button, click on it, then place the cursor on top of the image you want to zoom.
Drag the mouse away from the center point to increase magnification. Drag it towards
the center point to decrease magnification.
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To use the Zoom control in the Process control panel, select the image, click the Geom tab
on the bottom of the Process panel, click the Independent box if you want to adjust the
vertical and horizontal magnification separately, then use any or all of the following
methods:
•

Move the Horizontal or Vertical wheel to the right to increase the magnification or
to the left to decrease the magnification.

•

Use the Horizontal or Vertical up arrow to increase or the down arrow to decrease
the magnification.

•

Type a positive value in the Horizontal or Vertical field to increase the magnification
or a negative value to decrease the magnification.

•

Click the small box next to the Horizontal or Vertical wheel to return the
magnification to its original state.

Choosing a Resampling Method
To select the resampling method ImageView uses to alter the geometric aspects of an
image, click the Options tab on the bottom of the Process control panel, then select one
of the following resampling methods (Nearest is the default):
•

Nearest, standing for Nearest Neighbor, works quickly but produces lower-quality
results.

•

Bilinear uses more complex, time-consuming methods than Nearest Neighbor, but
produces higher-quality results.

•

Bicubic is more time-consuming than either Nearest Neighbor or Bilinear, but
produces the best results.
If you select the Bicubic resampling method, you can also select the specific Bicubic
Family, each of which produces a somewhat different effect: B-Spline, which is the
default option, produces smoother images. Catmul produces more sharpening.
Mitchell results in an effect between that of the other two.

•

The Minify method produces the best results if you are reducing the magnification
of an image. Again, however, it is a more time-consuming process.
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Adjusting Images and Views
•

“Understanding Images and Views”

•

“Selecting and Deselecting Views”

•

“Selecting a Frame Number, Component, or Subimage”

•

“Moving a View”

•

“Raising or Lowering an Image or View”

•

“Centering a View”

•

“Changing the Size and Shape of Views”

•

“Adjusting the Boundary Between Views”

•

“Comparing Images”

•

“Roaming Through an Image”

•

“Adjusting Screen Display Options”

•

“Resizing the ImageView Window”

Understanding Images and Views
At times only a part of an image is displayed in the window, appearing cropped. The
entire image is still present, though only a portion of the image is visible on the screen.
The portion of the image displayed in the window is considered a “view”—it is your
current view of the image.
You might think of the view as a movable and adjustable framed window placed on the
image. The portions of the image falling outside the frame are not visible on the screen.
However, you can move the frame over the image, or change the size of the frame, to
obtain a different view of the image.
The relationship of the “view” to the “image” in ImageView is shown in Figure 2-4.
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Figure 2-4

View of an Image

Note that selecting a view—that is, selecting the visible part of the image—also selects
the entire image (see “Selecting and Deselecting Views”). Similarly, moving a view
within the window also moves the image, except when you are specifically moving the
frame of the view relative to the image itself, in order to display a different part of the
image.

Selecting and Deselecting Views
To select or deselect a view:
•

To select a view, click within the view. When a view is selected, yellow dots appear
at points around its perimeter.

•

To select an additional view, press the Shift key and click inside the view.

•

To select all the views, choose Select All from the View menu.

•

To deselect a view that has been selected, click outside the view in a nonselected
area of the window, or press the Shift key and click inside the view.
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Selecting a Frame Number, Component, or Subimage
•

“Selecting a Frame Number”

•

“Selecting a Component”

•

“Selecting a Subimage”

Selecting a Frame Number
Some images contain a third, or “z”, dimension, such as volume or time, that is split into
“frames.” To select a frame number or to cycle through frames, select the image, choose
Edit > Select Frame, then in the Frame panel, use any or all of the following methods:
•

Move the Frame Number bar to the right to scan through the frames and select one.

•

Click the Auto box to automatically cycle along the “z” dimension of the image,
starting each cycle at the beginning of the axis.

•

Click the Auto and the Reverse boxes to automatically cycle along the “z”
dimension of the image and move forward and backward along the axis.

•

Use the slow/fast slider to change the rate of cycling along the “z” dimension.

Selecting a Component
Components are determined by the color model associated with an image. Generally,
though not always, the components of a model are colors. To select a component:
1.

Select the image.

2. Choose Edit > Select Frame.
3. In the Frame panel, click the Single box to select a single component rather than all
components.
4. Move or click on the Component slider to select a component.
The settings appearing on the Component control vary depending on the color
model of the selected image. For example, if the image you selected uses the RGB
color model, you can move the control to 0 (red), 1 (green), or 2 (blue).
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Selecting a Subimage
Some image files, such as TIFF, JFIF/JPEG, PhotoCD, and GIF, may contain multiple
images. To select a subimage or to cycle through subimages:
1.

Select the image.

2. Choose Edit > Select Frame.
3. In the Frame panel, do one of the following:
•

Move the Sub-Image bar to the right to scan through the images and select one.

•

Click the Auto box to automatically cycle through the subimages.

•

Click the Auto and the Reverse boxes to automatically cycle forward and
backward through the subimages.

Use the Info panel to get a list of the subimages in an image file. See “Viewing General
Information About an Image.”
For information on choosing a specific subimage when you first open or import an image
file, see “Opening Images.”

Moving a View
To move a view:
•

Click within the view and drag to the desired location.

•

To automatically move a view in a certain direction, hold down the Ctrl key and left
mouse button, and begin to drag the view. It continues to move until you release
either the mouse button or the Ctrl key.

If the view moves beyond the window borders, you can choose View > Center to retrieve
the image. If the image becomes deselected, choose View > Select All, then use the Center
command.
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Raising or Lowering an Image or View
When multiple images are present in one window, images may overlap, with higher
images partially or completely obscuring lower images. To raise or lower an image or
view, select the image or view and choose View > Raise or View > Lower.
You can also use the up and down arrow keys on your keyboard to raise or lower a
selected image or view.

Centering a View
To center a view, select the view, then choose View > Center. Using this command also
resizes the view so that the entire image is displayed.

Changing the Size and Shape of Views
To alter a view’s dimensions and change which portion of the image is displayed:
1.

Place the cursor on an edge or corner of the view.
The cursor changes shape to indicate its correct placement on the edge or corner.

2. Click the left mouse button and drag the cursor to move the edge or corner and
change the dimensions of the view.
If you hold down the Ctrl key while dragging an edge or corner, the opposite edge or
corner of the view also moves, in a mirroring fashion. This resizes the view without
shifting its center.
Note that you cannot move the edges of the view beyond the edges of the image itself.
You cannot drag the cursor beyond the image border.
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Adjusting the Boundary Between Views
To move the boundary between adjacent views:
1.

Select the views.

2. Position the cursor at the boundary between the views.
3. Hold down the Alt key, click with the left mouse button, and drag the boundary.
Note that you cannot move the edges of a view beyond the edges of its image. You cannot
drag the cursor beyond the image border.

Comparing Images
ImageView allows you to arrange views in a window for easy comparison. This is most
useful when you want to compare two images that were initially identical but had certain
aspects modified. For example, you could compare the left half of one image with the left
half of another image or the left half of one image with the right half of another image.
These sections describe how to use ImageView commands to compare images:
•

“Comparing the Same Area of Multiple Images”

•

“Comparing Different Areas of Multiple Images”

Comparing the Same Area of Multiple Images
To compare the same area of multiple images—for example, the left half of one image and
the left half of another image:
1.

Open an ImageView window containing only the images you want to compare.
(The compare command acts on all images in a window.)

2. If the images are partially obscured, choose View > Resize to bring the images into
full view.
3. Choose View > Compare > Same.
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ImageView produces a view of the left section of each image. To the extent possible, the
views produced are the same size and display the same section of the image. The views
are arranged in the window in as square a formation as possible. See Figure 2-5 for an
illustration of the Same command used in a window containing two initially identical
images, one of which has been modified.

Figure 2-5

Using the “Same” Command in a Window With Two Images

To shift the boundary between the views, move the cursor onto the boundary, press the
Alt key and the left mouse button, and drag the mouse.

Comparing Different Areas of Multiple Images
To compare adjacent areas of multiple images—for example, the left half of one image
and the right half of another image:
1.

Open an ImageView window containing only the images you want to compare.
(The compare command acts on all images in a window.)

2. If the images are partially obscured, choose View > Resize to bring the images into
full view.
3. Choose View > Compare > Aligned.
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ImageView produces a view of each image. To the extent possible, the views produced
are the same size and each view displays an adjacent section (area). ImageView arranges
these views so that adjacent views are placed next to each other, and all views are aligned
to the same origin. Views are arranged in as square a formation as possible.
See Figure 2-6 for an illustration of the Aligned command used in a window containing
two initially identical images, one of which has been modified.

Figure 2-6

Using the “Aligned” Command in a Window with Two Images

To shift the boundary between the views, move the cursor onto the boundary, press
Alt-left mouse button, and drag the mouse.

Roaming Through an Image
You can scroll through an image in various ways:
•

To scroll through an image without changing the dimensions or position of the
view, click inside the view with the middle mouse button, and drag the cursor. The
view remains stationary while the image shifts within it.

•

To automatically scroll in a certain direction, press the Ctrl key and the middle
mouse button, and begin to drag the image within the view. The image continues to
move until you release either the mouse button or the Ctrl key.
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•

To scroll through an image by shifting the position of the view, hold down the Alt
key and the left mouse button, and drag the view. The image remains stationary
while the view moves over it.

Adjusting Screen Display Options
Use the RGB Mode and Double Buffer options in the Options menu to affect how images
are displayed on the screen.
•

If RGB Mode is turned on, screen colors are stored directly in the ImageView
window. If RGB mode is off, colors are instead stored as index numbers, resulting in
more efficient image processing but some loss in color complexity.

•

If the Double Buffer option is turned on, procedures such as roaming through an
image are smoother. However, in some systems there is a loss in pixel depth.

The default settings for these options depend on the hardware capabilities of your
system. For some systems, changing the RGB Mode or Double Buffer option does not
result in a discernible difference in the image display.

Resizing the ImageView Window
Choose View > Resize to resize the window so it displays the full image. If you’re
viewing multiple images, the window resizes to display the full images, and each image
retains its position in the window.
If you drag the window border to resize the window, the image or images keep their
current positions and do not move as you change the size of the window. If you hold
down the Ctrl key while dragging an edge or corner, the opposite edge or corner of the
view also moves, in a mirroring fashion. This resizes the view without shifting its center.

Scanning Through the History of Edits
Use Ctrl+Z and Ctrl+Shift Z to scan back and forth through edits you make to images and
views. Choosing Edit > Undo and Edit > Redo is an alternative way to do this. You can
also use the Undo button, shown in Figure 2-7, to recursively undo edits.
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Deleting an Image

Figure 2-7

Undo Button

Deleting an Image
To delete an image, select it, then choose View > Delete. Alternatively, you can press the
Backspace key after selecting the image.

Printing an Image, View, or Window
To print an image, view, or window:
1.

If you want to print a specific image or view, select the image or view.

2. Choose File > Print...
3. In the Print dialog:
•

Choose Full Window to print the entire image area of the window, consisting of
all the views exactly as they appear in the window and any visible window
background.

•

Choose Full Image to print the entire selected image, even if only a cropped
portion of it is displayed in the view on the screen.

•

Choose Cropped Image to print the selected view—that is, to print only the part
of the image that is being displayed on the screen.

4. Click Print.
For more information on the difference between an image and a view (a “cropped
image”), see “Understanding Images and Views.”

Saving an Image, View, or Window
•

“Saving an Image, View, or Window Under the Current Filename”

•

“Saving an Image, View, or Window Under a New Filename or Format”
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Saving an Image, View, or Window Under the Current Filename
To save your work under the current filename:
1.

Select the image or view.

2. Choose File > Save...
3. In the Save dialog, choose one of the following:
•

Choose Full Image to save the entire selected image, even if only a cropped
portion of it is displayed in the window.

•

Choose Cropped Image to save the selected view.

•

Choose Full Window to save the entire image area of the window, consisting of
all the views exactly as they appear in the window and any visible window
background.

4. Click OK.
For more information on the difference between an image and a view (a “cropped
image”), see “Understanding Images and Views.”

Saving an Image, View, or Window Under a New Filename or Format
To save your work under a new filename or format:
1.

Select the image or view.

2. Choose File > Save As...
3. In the Save As... dialog, choose a file format from the Format popup menu:
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•

“Infer from file name” saves the image in the format inferred by the filename.
For example, if you enter a filename with a .gif suffix, the file is saved in GIF
format.

•

SGI format is used by applications on Silicon Graphics systems, including IRIS
Showcase.

•

TIFF format is the most common and useful file format.

Viewing Image Information

•

FIT format is not a standard, but is supported by the ImageVision Library (IL).

•

GIF, JFIF/JPEG, and PNG formats are useful for World Wide Web documents.
GIF does not have the color capability necessary for publishing or technical
uses. JFIF/JPEG format uses very little disk space at the expense of some
picture detail.

Any additional file formats available on your system also appear.
4. Click the Set... button to view or change any of the default file attributes.
The attributes vary depending on the type of format you selected from the Format
popup menu. Default settings are based on the current format of the file and the file
format to which you are saving.
5. Choose one of the following:
•

Choose Full Image to save the entire selected image, even if only a cropped
portion of it is displayed in the window.

•

Choose Cropped Image to save the selected view.

•

Choose Full Window to save the entire image area of the window, consisting of
all the views exactly as they appear in the window and any visible window
background.

6. Type in a filename for the new file.
7. Click OK.
If you have the IRIS Development Option, you can refer to the Image Format Library
(IFL) manual pages for additional information on the various file formats and attributes.
If you have access to the World Wide Web, you can refer to these IFL manual pages by
visiting the following site:
http://www.sgi.com/Technology/ImageVision/man/ILman.html

Viewing Image Information
•

“Viewing General Information About an Image”

•

“Viewing Close-Up Information About an Image”

•

“Viewing Distribution of Component Value Information About an Image”
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Viewing General Information About an Image
To obtain general information about an image, select the image, then click the button
shown in Figure 2-8. The Info window opens. (You can also choose Options > Info to
open the Info window.)

Figure 2-8

Info Button

If you did not alter the selected image, the window displays the filename, file format, and
file size. If you altered the image (magnified it, for example), the window displays the file
description, class name, and size.
The Info window may also list file attributes such as image size, page size, data type,
dimension order, color model, orientation, statistical range, and display range.
If you have the IRIS Development Option, see the Image Format Library (IFL) manual
pages—IFL(3)—for additional information on file attributes. You can also view these IFL
manual pages if you have access to the World Wide Web, by visiting the following site:
http://www.sgi.com/Technology/ImageVision/man/ILman.html

Viewing Close-Up Information About an Image
To view close-up information about an image, select the image, then click the button
shown in Figure 2-9. The Image Detail window opens. (You can also choose Options >
Detail to open the Detail window.) Position the mouse cursor on the image to see a
close-up view of the area under the cursor.

Figure 2-9

Detail Window Button

By default, the Detail window uses a magnification of 6X. To change the magnification,
click on the pop-up menu and select a new number.
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Viewing Distribution of Component Value Information About an Image

The Image Detail window lists the following information:
•

the position of the cursor in the source image

•

the value of each component of the color model at the current cursor position

•

the coordinates of the origin of the view with respect to the image

•

the size of the source view

All location and size information is given in pixels.

Viewing Distribution of Component Value Information About an Image
To see a histogram depicting the distribution of component values in an image, select the
image, then click the button shown in Figure 2-10. The Histogram window opens. (You
can also choose Options > Histogram to open the Histogram window.)

Figure 2-10

Histogram Button

The horizontal axis of the histogram represents component intensities or values, and the
vertical axis represents pixel counts.
•

“Understanding the Histogram”

•

“Using the Component Control”

•

“Obtaining Numerical Data”

•

“Adjusting the Vertical Scaling of the Histogram”
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Understanding the Histogram
The specific components of an image are determined by the color model associated with
the image. In many models, the components are colors. For example, the components of
the RGB color model are red, green, and blue; an image using the RGB color model is
composed of those three colors. You might think of an image as being made up of many
individual dots, called “pixels,” each of which “consists” of the components. In each
pixel, each component has a certain value or intensity; the combined values of the
components in the pixel determine the appearance of the pixel.
In this Histogram window, you select which component of the image you want analyzed.
ImageView then counts, for each possible value of that component, how many pixels in
the image have that component value. The horizontal axis of the histogram represents all
the different intensities or values of the component. Along the vertical axis are pixel
counts. Each bar (vertical line) in the histogram indicates the number of pixels in which
the selected component has a certain value. The histogram shows the distribution of
component values in the image.

Using the Component Control
Use the pictured Component control in the Histogram window to select the component
for which you want a histogram displayed. The settings of the Component control vary
depending on the color model of the selected image. For example, if the image you
selected uses the RGB color model, you can move the control to 0 (red), 1 (green), or 2
(blue).

Obtaining Numerical Data
Click on any bar (vertical line) in the histogram to select it. It turns red, and its
coordinates appear under the horizontal axis of the histogram. The component value
associated with the bar is displayed in front of the colon, and the pixel count is displayed
following the colon. Next to these coordinates, in parentheses, is the percentage of pixels
with this value, out of the total number of pixels in the image.
Click the small box showing a triangular peak to select the highest bar in the histogram.
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Customizing the ImageView Window

Adjusting the Vertical Scaling of the Histogram
Drag the wheel up or down to control the vertical scaling of the histogram. Click the
small box immediately above the dial to return the vertical scaling to its original position,
in which the highest peak of the histogram just fits within the window.

Customizing the ImageView Window
Use one of the following shell commands when opening ImageView to customize the
display window:
•

imgview -noBorders—Suppresses the normal window manager borders.

•

imgview -hideToolbar—Hides the tool bar.

•

imgview -usePopUp—Tells the tool to use a popup menu instead of the standard
menu bar.

•

imgview -compare img1 img2—Tells the tool to display all images on the command
line in a single window instead of in separate windows. The images will be stacked
one on top of the other with the last file specified on the command line appearing at
the top of the stack. This mode can be useful when comparing related images of the
same size for subtle differences (by wiping an image on top to reveal the image
below).

For information on other options, see the imgview(1) man page.

ImageView Window
•

“Image Display Area”

•

“ImageView Menus”

•

“Palette Buttons”

Image Display Area
The Image Area displays the images you import into ImageView. For information about
the display area, see “Understanding Images and Views.”
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ImageView Menus
•

“File Menu”

•

“View Menu”

•

“Edit Menu”

File Menu
Open... Command
The Open... command opens a file in the viewing area. If you want to open an additional
file, use the Import... command.

Import... Command
Use the Import... command when you want to open an additional file.

Save... Command
Use the Save... command to save an image, view, or window under the current filename.
See “Saving an Image, View, or Window Under the Current Filename.”

Save As... Command
Use the Save As... command when you want to save an image, view, or window under a
new filename or format. See “Saving an Image, View, or Window Under a New Filename
or Format.”

Print... Command
Use the Print... command to print an image, view, or window. See “Printing an Image,
View, or Window.”

View Menu

Close Command
Use the Close command to close the current Image View window.

Quit Command
Use the Quit command to close all open Image View windows.

View Menu
Center Command
Use the Center command to center a selected image. Using this command also resizes the
view so that the entire image is displayed.

Raise Command
When layering images in a view, use the Raise command to pop a selected image to the
top of the one above it.

Lower Command
When layering images in a view, use the Lower command to push a selected image
behind the one beneath it.

Compare Command
Use the Compare command to compare two images. This command is most useful when
you want to compare two images that were initially identical but had certain aspects
modified. See “Comparing Images.”
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Select All Command
Use the Select All command to select all images in a window.

Delete Command
Use the Delete command to delete a selected image from the view.

Detail... Command
Use the Detail... command to open the Detail window, which lets you see a detailed or
zoomed-in view of an image. Move the cursor across the image, and the area beneath the
cursor appears magnified in the Detail window.
You can also click the Detail button, shown in Figure 2-11, to open the Detail window.

Figure 2-11

Detail Button

Histogram... Command
Use the Histogram... command to open a histogram depicting the distribution of
component values in an image. See “Viewing Distribution of Component Value
Information About an Image” for more information.
You can also click the Histogram button, shown in Figure 2-12, to open the histogram.

Figure 2-12
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Histogram Button

Edit Menu

Info... Command
Use the Info... command to view general information about a selected image. See
“Viewing General Information About an Image.”
You can also click the Info button, shown in Figure 2-13, to open the Info panel.

Figure 2-13

Info Button

Resize Window Command
Use the Resize Window command to bring all images into full view.

RGB Mode Toggle
If RGB Mode is turned on, screen colors are stored directly in the ImageView window. If
RGB mode is off, colors are instead stored as index numbers, resulting in more efficient
image processing but some loss in color complexity.

Double Buffer Toggle
If the Double Buffer option is turned on, procedures such as roaming through an image
are smoother. However, in some systems there is a loss in pixel depth.

Edit Menu
Undo Command
Use the Undo command to undo the previous edit. You can also use Ctrl-z to undo an
edit, or click the Undo button, shown in Figure 2-14.
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Figure 2-14

Undo Button

Redo Command
Use the Redo command to redo an edit that you used the Undo command to undo. You
can also use Ctrl-Shift-z to redo an edit.

Process... Command
The Process... command opens the Process control panel. This panel lets you enhance the
appearance and adjust geometric aspects of selected images.
You can also click the Process button, shown in Figure 2-15, to open the Process panel.

Figure 2-15

Process Button

Select Frame... Command
The Select Frame... command opens the Frame panel, which lets you select a frame
number, component, or subimage. See “Selecting a Frame Number, Component, or
Subimage.”
You can also click the Frame button, shown in Figure 2-16, to open the Frame panel.

Figure 2-16
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Frame Button

Palette Buttons

Transparency... Command
The Transparency... command opens the Define Transparency panel, which lets you refine
color selection when applying transparency to an image. See “Using the Define
Transparency Panel.”

Show Transparency Toggle
If an image contains transparency, you may see a flashing effect while rotating the image.
You can eliminate this flashing effect by selecting Show Transparency to turn transparency
off. Select it again to turn it back on.

Auto Range Toggle
Clicking the Auto Range toggle on computes the histogram on the input image and uses
it to determine the overall minimum and maximum pixel values. These then replace the
existing minimum and maximum pixel values in the source image.
The result in most cases is a displayed image with its pixel values stretched to fit the
output display. This tool is useful if the source image pixel values occupied only the
lower range of available pixel values.

Background Color... Command
Use the Background Color... command to open a color palette that lets you set the color of
the window background.

Palette Buttons
•

“Selection Button”

•

“Rotate Button”

•

“Zoom Button”

•

“Transparency Button”

•

“Undo Button”
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•

“Process Panel Button”

•

“Frame Panel Button”

•

“Detail Panel Button”

•

“Histogram Viewer Button”

•

“Info Panel Button”

Selection Button
Use the Selection button to select or move an image. Click the button, then use the left
mouse button to select or move an image.

Figure 2-17

Selection Button

Rotate Button
Use the Rotate button to rotate an image. Click the button, then place the cursor on top of
the image you want to rotate and drag the mouse in a circular motion to the right or left.
You can also use the Rotate control on the Process panel. See “Rotating an Image.”

Figure 2-18

Rotate Button

Zoom Button
Use the Zoom button to zoom an image in or out. Click the button, then drag the mouse
away from the center point of the image to zoom in or drag it toward the center point to
zoom out. You can also use the Zoom control on the Process control panel. See “Zooming
an Image.”
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Palette Buttons

Figure 2-19

Zoom Button

Transparency Button
Use the Transparency button to make a color transparent. Click the button, then move the
crosshair cursor on top of a color in the image and click the left mouse button. (For more
precise color selection, choose View > Detail and use the Detail panel to help you select
the color.) The red, green, and blue value of the pixel beneath the centerpoint of the
cursor is calculated, and all pixels matching that value become transparent.
You can also use the Define Transparency panel to refine color selection. See “Define
Transparency Panel.”

Figure 2-20

Transparency Button

Undo Button
Clicking the Undo button undoes the previous edit. You can also use Ctrl+z to undo an
edit.

Figure 2-21

Undo Button

Process Panel Button
Clicking the Process button opens the Process control panel. This panel lets you enhance
the appearance and adjust geometric aspects of selected images.
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Figure 2-22

Process Panel Button

Frame Panel Button
Clicking the Frame Panel button opens the Frame panel, which lets you select a frame
number, component, or subimage. See “Selecting a Frame Number, Component, or
Subimage.”

Figure 2-23

Frame Panel Button

Detail Panel Button
Clicking the Detail button opens the Detail panel, which lets you see a detailed, or
zoomed-in, view of an image. After opening the panel, move the cursor across the image,
and the area beneath the cursor appears magnified in the Detail panel window.

Figure 2-24

Detail Panel Button

Histogram Viewer Button
Clicking the Histogram button opens a histogram depicting the distribution of
component values in an image. See “Viewing Distribution of Component Value
Information About an Image.”

Figure 2-25
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Histogram Viewer Button

Process Panel

Info Panel Button
Clicking the Info button opens the Info panel, which displays general information about
an image.

Figure 2-26

Info Panel Button

Process Panel
The Process control panel lets you enhance the appearance and adjust geometric aspects
of selected images. Click the Enhance, Geom, or Options tabs on the bottom of the panel to
display the corresponding subpanels.

Define Transparency Panel
When there are multiple colors or a range of colors in an image, the Define Transparency
panel lets you refine color selection when applying transparency. See “Using the Define
Transparency Panel” for information on using the panel.

Keyboard Shortcuts for ImageView
Many commands in ImageView have keyboard shortcuts:
Table 2-1

Shortcuts for Commands in ImageView

Command

Keyboard Shortcut Mnemonic

Open...

Ctrl+O

Save...

Ctrl+S

Print

Ctrl+P

Close

Ctrl+W
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Table 2-1 (continued)
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Shortcuts for Commands in ImageView

Command

Keyboard Shortcut Mnemonic

Center

Home

Raise

Up

Lower

Down

Compare Same

Ctrl+M

Compare Aligned

Ctrl+A

Select All

Ctrl+A

Delete

Del or Backspace

Detail...

Ctrl+D

Histogram...

Ctrl+H

Info...

Ctrl+I

Resize Window

Ctrl+R

Undo

Ctrl+Z

Redo

Ctrl Shift+Z

Process...

Ctrl+C

Select Frame...

Ctrl+F

Transparency...

Ctrl+T

Background Color

Ctrl+B

Click for Help

Shift+F1
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3. ImageCopy, ImageInfo, and ImageFormats

ImageCopy, ImageInfo, and ImageFormats are command-line tools available to you:
•

ImageCopy lets you copy and change the format of an image file.

•

ImageInfo lets you obtain information about an image.

•

ImageFormats displays a list of the file formats that are currently supported by the
ImageVision tools.

Copying an Image
ImageCopy allows you to copy image files and to convert image files into different
formats.
Note that similar procedures are also available in ImageView. See “Saving an Image,
View, or Window Under a New Filename or Format.”

Using the ImageCopy Icon
The imgcopy icon is on the MediaTools page of the Icon Catalog. To open the MediaTools
page, choose Media Tools from the Find menu of the desktop toolchest . To copy an
image file and change the file format, drag and drop the image file icon onto the imgcopy
icon. A dialog box appears from which you can choose one of three formats:
•

SGI format is used by applications on Silicon Graphics systems, including IRIS
Showcase.

•

TIFF format is the most common and useful file format.

•

FIT format is not a standard, but is supported by the ImageVision Library (IL).

When you select a format, ImageCopy copies the image file into a second file, which has
the selected format. The name of this second file is a combination of the original filename
and a new extension, reflecting the new format type.
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If you have the IRIS Development Option, see the Image Format Library (IFL) manual
pages for additional information on the various file formats. You can also view these IFL
manual pages if you have access to the World Wide Web, by visiting the following site:
http://www.sgi.com/Technology/ImageVision/man/ILman.html

Using the ImageCopy Command
To copy an image file and change the file format using the ImageCopy command, at the
shell prompt enter
imgcopy infile outfile.format

where infile is the name of the file to be copied and outfile.format is the name you want
the new file to be given. The outfile name should include an extension that indicates the
desired new format. For example, the name of an outfile that you wish to have in FIT
format might be tree.fit.
A number of file formats are available to you using this command, including SGI, TIFF,
FIT, GIF, JFIF/JPEG, PNG, PPM, and any additional file formats that are available on
your system.
•

SGI format is used by applications on Silicon Graphics systems, including IRIS
Showcase.

•

TIFF format is the most common and useful file format.

•

FIT format is not a standard, but is supported by the ImageVision Library (IL).

•

GIF, JFIF/JPEG, and PNG formats are useful for World Wide Web documents. GIF
does not have the color capability necessary for publishing or technical uses.
JFIF/JPEG format uses very little disk space at the expense of some picture detail.

If you have the IRIS Development Option, see the Image Format Library (IFL) manual
pages for additional information on the various file formats. You can also view these IFL
manual pages if you have access to the World Wide Web, by visiting the following site:
http://www.sgi.com/Technology/ImageVision/man/ILman.html
You can use the ImageCopy shell command for a number of additional procedures. See
the imgcopy(1) reference page for a list of the ImageCopy command-line options.
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Getting Information About an Image

Getting Information About an Image
ImageInfo displays information about a file. The imginfo icon is located on the
MediaTools page of the Icon Catalog.
To obtain information on an image file:
1.

Choose Media Tools from the Find menu of the desktop toolchest.
The MediaTools page of the Icon Catalog opens.

2. Drag and drop the image file icon onto the imginfo icon.
A dialog box appears.
3. Enter the pathname of the image about which you want information and press OK.
Another window appears describing the image properties.
ImageInfo displays the following information about a file: file format, image size in
pixels, page size, data type, dimension order, color model, minimum and maximum
pixel values, data compression, and image description.
•

Information on data compression is displayed only if the file is compressed.

•

For those files that contain subimages, the image description includes a list of the
subimages in the file.

See the imginfo(1) reference page for a list of the ImageInfo command-line options.
To use the shell to access ImageInfo, at the shell window prompt enter imginfo imgfile.

Obtaining a List of Available File Formats
ImageFormats displays a list of the file formats that are currently supported by the
ImageVision tools. More specifically, the list that ImageFormats displays represents all
the formats currently supported by the Image Format Library (IFL) and the tools that use
that library.
To access ImageFormats, at the shell prompt type imgformats and press Enter. A list of
supported formats is displayed. See imgformats(1) for a list of the ImageFormats
command-line options.
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4. Image Works

This chapter contains these sections:
•

“About Image Works”

•

“Opening Images in Image Works”

•

“Saving an Image in Image Works”

•

“Setting Preferences in Image Works”

•

“Editing Images in Image Works”

To open Image Works, choose Media Tools from the Find menu of the desktop toolchest.
The MediaTools page of the Icon Catalog opens. Double-click the imgworks icon.

About Image Works
Image Works lets you manipulate images—blur, sharpen, stretch, scale, and flip
images—and save them to a file. Image Works also lets you convert color images to black
and white or make photographic negatives.
Many of the procedures available in Image Works are also available in ImageView, as
described in Chapter 2, “ImageView.”
The Image Works window appears in Figure 4-1.

Figure 4-1

Image Works Window
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The Image Works window contains six main menus and a help menu:
File

Lets you open, save, and print images. You can also set sampling
preferences using the Set Preference menu.

Edit

Contains the undo and redo commands, and allows you to copy and
paste.

View

Contains commands that let you increase and decrease the size of the
image. Also allows you to see component distribution data displayed in
a histogram.

Transform

Contains commands that crop, scale, stretch, flip, or rotate an image.

Enhance

Contains commands that let you use effects such as blur and sharpen,
change the contrast and brightness, and change the color balance.

Effects

Allows you to turn an image into black and white, apply special effects
such as posterize and edges, and turn an image into a photographic
negative.

The balance of the Image Works window is the image area. When you open an image,
this is where it appears.

Opening Images in Image Works
You can open image files of various format types in Image Works. These include SGI,
TIFF, FIT, GIF, JFIF (JPEG compressed images), and PhotoCD.
To open an image in Image Works:
1.

Choose Open from the File menu.

2. Click the name of the file you want to open.
3. If you’re opening a PhotoCD file, choose an image size by clicking one of the sizes in
the “Open PhotoCD As” list.
4. Click the Accept button.
The image appears in the Image Works window.
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Saving an Image in Image Works

Opening a Specific SubImage
With some file formats, such as PhotoCD, a single file can contain multiple subimages.
You can open a specific subimage by typing the filename followed by a colon and the
number of the subimage (for example, Sunrise:3) in the File Name field of the Open
Image dialog box. Use the ImageInfo tool to get a list of subimages in the image file. See
“Getting Information About an Image” and the imginfo(1) reference page for more
information on using ImageInfo.

Saving an Image in Image Works
Use the Save command in the File menu to save your current work as is.
Use the Save As command in the File menu to save your work under a different filename.
You can also use the Save As command to save your work in a format different from that
of the original image file. When you choose the Save As command under the File menu,
a dialog box opens. Use the File Format field of the dialog box to select the format.
Available file formats are SGI, TIFF, FIT, GIF, and JFIF/JPEG.
•

SGI format is used by applications on Silicon Graphics systems, including IRIS
Showcase.

•

TIFF format is the most common and useful file format.

•

The FIT format is not a standard, but is supported by the ImageVision Library (IL).

•

GIF format is useful for online graphics presentation, such as World Wide Web
documents and multimedia authoring. It does not have the color capability
necessary for publishing or technical uses.

•

JFIF (JPEG compressed) format uses very little disk space at the expense of some
picture detail.

See the IFL manual pages on each of these file formats for additional information.
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TIFF, GIF, and JFIF formats have additional options you can set using the Save As dialog
box. To activate the relevant fields of the Save As dialog box for each file format, you
must first select the format in the File Format field. For information on the options
available, see:
•

“Saving an Image in TIFF Format”

•

“Saving an Image in GIF Format”

•

“Saving an Image in JFIF Format”

Saving an Image in TIFF Format
If you are saving an image in TIFF format, you can turn compression on or off by clicking
the Use Compression button in the Save As dialog box.
Turning compression on significantly reduces the amount of disk space needed to store
the image without reducing the quality of the image. However, if you plan to use these
images in PC or Macintosh files, you will encounter fewer compatibility problems if you
turn compression off.

Saving an Image in GIF Format
When saving an image in GIF format, the Set GIF Options button in the Save As dialog
box is activated. Click this button to open the GIF Options dialog box. You can also open
the GIF Options dialog box by choosing the Set GIF Options command from the File
menu. The GIF Options dialog box lets you choose certain options before saving the
image in GIF format.
Selecting the Number of Colors to Save

You can increase or decrease the number of colors saved in the image file by using the
Number of Colors to Save field of the GIF Options dialog box. You can choose 16, 64, 128,
or 256 in the Number of Colors to Save field. By default, Image Works uses a maximum
of 64 colors when saving a file in GIF format.
•

More colors give you a better quality image.
You may want to choose a high number in the Number of Colors to Save field to
accurately represent photographs or other highly realistic images. However, files
containing a large number of colors take up more disk space.
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•

Fewer colors help save disk space and network transmission time.
You may want to choose a smaller number of colors for diagrams, line drawings, or
other simple graphics.

If you are creating images for the World Wide Web, remember that your content is
viewable by a worldwide audience. Internet users view images using a wide range of
computer systems and software, with varying color graphics capabilities. To place fewer
demands on the viewer’s Web browsing hardware and software, choose the fewest
colors that provide acceptable quality for your images. If you place several images on one
page, use fewer colors in each image to help Web browsers faithfully show all the images.
Turning Dithering On or Off

Click the Use Dithering button of the GIF Options dialog box to turn this option on and
off. A check mark indicates that the option is turned on.
Dithering changes the pixels in an image to simulate “lost” colors. When using fewer
colors in an image, dithering may help improve its appearance. If you are saving a simple
image, such as a line drawing or diagram that uses fewer colors, you may have better
results if you turn dithering off.
By default, Image Works uses dithering when saving to GIF format.
Turning Interlacing On or Off

Click the Use Interlacing button of the GIF Options dialog box to turn this option on and
off. A check mark indicates that the option is turned on.
An interlaced image displays gradually. It starts out very rough, then progresses and
adds detail as it displays. If an image isn’t interlaced, the image doesn’t appear until the
complete image is ready to display. Both processes take the same amount of time.
Authors of World Wide Web pages use interlaced images to give you visual feedback
instead of a blank screen while you wait for an image to display.
By default, interlacing is turned on when saving to GIF format.
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Choosing a Transparency Color

When saving images to GIF format, you can select a solid color in the image and make it
transparent. This is useful when you want to eliminate the rectangular background of an
image and give the impression that the image is floating on the page.
To choose a transparency color when saving images in GIF format:
1.Click the Choose Transparency Color button in the GIF Options dialog box. The GIF
Transparency window appears.
2.Move your cursor across the image. The image appears magnified in the Pixel View in
the GIF Transparency window. Click when the color you wish to make transparent
appears within the small square in the center of the Pixel View.
The color disappears from the image.

Saving an Image in JFIF Format
When saving images in JFIF format, you can adjust the compression quality of the image
using the JFIF Options control pictured in the Save As dialog box. Drag the slider to the
left or the right to lower or raise the quality setting. By default, the compression is set to
high (100). At this quality setting, all detail is saved. Lowering the quality decreases the
amount of detail and decreases the size of the file.

Setting Preferences in Image Works
Choose Set Preferences from the File menu to select the resampling method for your
images.
The resampling method determines the procedure Images Works uses when you
manipulate it in certain ways, such as resizing, stretching, and rotating (see “Editing
Images in Image Works”). Nearest Neighbor works quickly, but produces lower-quality
results. Bilinear and Bicubic use more complex, time-consuming methods, but produce
higher-quality results. Bicubic is the most time-consuming of these methods and
produces the highest-quality results.
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Editing Images in Image Works
These sections tell you how to use Image Works:
•

“Blurring an Image”

•

“Sharpening an Image”

•

“Converting an Image to Black and White”

•

“Converting an Image to a Photographic Negative”

•

“Cropping an Image”

•

“Resizing an Image”

•

“Stretching an Image”

•

“Flipping an Image”

•

“Rotating an Image”

•

“Lightening and Darkening Pixels in an Image”

•

“Brightening or Darkening an Image”

•

“Adjusting the Amount of Contrast in an Image”

•

“Reducing the Number of Colors in an Image”

•

“Balancing the Color in an Image”

•

“Checking Color Distribution”

•

“Making Colors More Vivid”

•

“Highlighting Edges In an Image”

Many of the procedures described in these sections are also available in ImageView, as
described in Chapter 2, “ImageView.”

Blurring an Image
To blur an image:
1.

Choose Blur from the Enhance menu.

2. Drag the slider to change the degree of blur, or type a percentage in the field.
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3. Change the kernel size, if you wish to do so.
Generally, a high blur factor and large kernel size produce a very blurred image.
4. Click the Apply button to make your changes take effect. To return to the original
image, choose Undo from the Edit menu.
5. Click Reset to reset the blur scale.
Click Close to close the blur window.

Sharpening an Image
Sharpening an image makes the colors more crisp. To sharpen an image:
1.

Choose Sharpen from the Enhance menu.

2. Drag the slider to the right to sharpen the colors in the image, or type a percentage
in the field.
3. Change the kernel size, if you wish to do so.
Generally, a high sharpen factor and large kernel size produce a very sharp image.
4. Click Apply to make your changes take effect. To return to the original image, choose
Undo from the Edit menu.
5. Click Reset to reset the sharpen scale.
Click Close to close the Sharpen window.

Converting an Image to Black and White
To change a color image to black and white, choose the “Color to Grayscale” command
from the Effects menu. To return to the original image, choose Undo from the Edit menu.

Converting an Image to a Photographic Negative
To turn an image into a photographic negative, choose Negate from the Effects menu. To
return to the original image, choose Undo from the Edit menu.
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Cropping an Image
The Crop command lets you cut an image, just as you would cut a picture using scissors.
To crop an image:
1.

Choose Crop/Add Margin from the Transform menu.

2. Pull down Add from the Crop button to add a margin to your image.
A selection rectangle appears in the image. Size the image using the rectangle. You
can also fill in the fields with the amount you would like to crop the image, in
pixels.
For example, if you enter 15 in the “pixels left” field, you snip 15 pixels off the left
side of the image.
3. Click the Choose Color button to change the color of the crop area or margin.
4. Click Apply to initiate the changes. Choose Undo from the Edit menu to return to the
original image.
Click Close to close the window.

Resizing an Image
The Scale command lets you resize an image and maintain the correct proportions
(aspect ratio). To scale an image:
1.

Choose Scale from the Transform menu.

2. Type the percentage by which you want to scale the image in the Scale Factor field,
or type the desired size (in pixels).
The program figures out the percentage for you.
You can also resize by moving the handles on the corners of the image.
3. Click Apply to implement the changes. Choose Undo from the Edit menu to return
to the original image.
4. Click Reset to reset the scale.
Click Close to close the window.
See also “Setting Preferences in Image Works” for information on choosing the procedure
by which Image Works resizes an image.
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Stretching an Image
The Stretch command lets you resize an image without maintaining the aspect ratio. To
stretch an image:
1.

Choose Stretch from the Transform menu.

2. Type the percentage by which you want to stretch the image horizontally and
vertically in the appropriate fields, or type the desired size (in pixels).
The program figures out the percentage for you.
You can also stretch the handles on the corners of the image.
3. Click Apply to implement the changes. Choose Undo from the Edit menu to return
to the original image.
4. Click Reset to reset the scale.
Click Close to close the window.
See also “Setting Preferences in Image Works” for information on choosing the procedure
by which Image Works stretches an image.

Flipping an Image
You can flip an image upside down or sideways using the Flip Horizontal and Flip
Vertical commands in the Transform menu.

Rotating an Image
The Rotate command lets you rotate an image counterclockwise at any angle. To rotate
an image:
1.

Choose Rotate from the Transform menu.

2. In the Rotate Image field, type the degree by which you want to rotate the image.
3. Click the Choose Color button to change the color of the crop area or margin.
4. Click Apply to initiate the changes.
Choose Undo from the Edit menu to return to the original image and remove any
new color.
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Click Close to close the window.

Lightening and Darkening Pixels in an Image
The Threshold feature allows you to selectively lighten and darken pixels in your image.
For grayscale images, it forces all of the pixels to be either white or black. For color
images, it forces all of the pixels into primary colors (black, white, red, green, blue,
yellow, cyan, and magenta).
For example, in a black and white image, this means that you pick a gray level as a
threshold. Everything lighter than the threshold gray becomes white. Everything darker
than the threshold gray becomes black. Color images are handled just like black and
white. The difference is that the threshold operation is done three times, once each for
red, green, and blue.
Use Threshold on scanned line art to make edges crisper and remove background noise,
or on color images for special effects.
To “threshold” an image, follow these steps:
1.

Choose Threshold from the Effects menu. A dialog box appears.

2. To change the threshold level, drag the Threshold Level slider.
The threshold level determines how pixels are darkened and lightened in the image.
Generally, pixels darker than the threshold level become black. Pixels lighter than
the threshold level become white.
3. Click Apply to implement the changes.
Choose Undo from the Edit menu to return to the original image.
4. Click Reset to reset the scale.
Click Close to close the window.
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Brightening or Darkening an Image
To brighten or darken an image, follow these steps:
1.

Choose Brightness from the Enhance menu. A dialog box appears.

2. Drag the slider bar to the left to darken the image and to the right to lighten the
image.
3. Click Apply to implement the changes.
Choose Undo from the Edit menu to return to the original image.
4. Click Reset to reset the scale.
Click Close to close the window.

Adjusting the Amount of Contrast in an Image
To adjust the amount of contrast in an image:
1.

Choose Contrast from the Enhance menu. A dialog box appears.

2. Change the contrast of the dark areas by dragging the Shadows slider to the left,
towards “flatter,” to decrease the contrast, or to the right to darken the contrast.
3. Change the contrast of the light areas by dragging the Highlights slider to the left,
towards “flatter,” to decrease the contrast, or to the right to increase the contrast.
4. Click Apply to implement the changes.
Choose Undo from the Edit menu to return to the original image.
5. Click Reset to reset the scale.
Click Close to close the window.
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Reducing the Number of Colors in an Image
The Posterize feature reduces the number of colors in an image. Use this feature to create
special effects. To posterize an image:
1.

Choose Posterize from the Effects menu. A dialog box appears.
To choose the number of color levels, enter a number between 2 and 256 in the
Posterize Level field. A smaller number produces an image with fewer colors.

2. Click Apply to implement the changes.
Choose Undo from the Edit menu to return to the original image.
3. Click Reset to reset the scale.
Click Close to close the window.

Balancing the Color in an Image
To adjust the balance of color in an image, follow these steps:
1.

Choose Color Balance from the Enhance menu. A dialog box appears.

2. Balance the color.
■

To raise and lower the red, green, and blue colors, drag the appropriate sliders.

■

To decrease the amount of color, drag towards “less.”

■

To increase the amount of color, drag towards “more.”

3. Click Apply to implement the changes. Choose Undo from the Edit menu to return
to the original image.
4. Click Reset to reset the scale.
Click Close to close the window.

Checking Color Distribution
A histogram graphically depicts the distribution of color in an image. Choose Show
Histogram from the View menu. For a color image, three graphs are displayed,
illustrating the red, green, and blue components of the image. For a grayscale image, one
graph is displayed, illustrating the gray levels of the image.
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Very dark images have higher peaks towards the left of the histogram graph. Very light
images have higher peaks towards the right of the histogram graph.
To understand the relationship between an image and its histogram, leave it open while
using the Negate, Color To Grayscale, Brightness, Contrast, Threshold, Posterize,
Equalize, Color Saturation, Find Edges, and Color Balance features. Each time you
change the image, the histogram automatically updates.
When you finish viewing the histogram, click the Close button to close the histogram
view.

Making Colors More Vivid
Choose Color Saturation from the Enhance menu. Adjust the levels in the dialog box to
make the colors more or less vivid.

Highlighting Edges In an Image
Choose Find Edges from the Effects menu. There are four methods that can be used to
find and enhance edges: Roberts, Sobel, Laplace1, and Laplace2.
These choices perform 2D orthogonal convolutions on the edges of an image to change
the edge effects.
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5. ImageTcl

ImageTcl is a powerful tool that allows you to:
•

Write your own scripts or application programs
For example, you may regularly need to convert image files to a particular size.
Using ImageTcl, you can write your own script or program to perform this
conversion.

•

Make use of image-processing operations not available to you through the other
ImageVision application tools, such as ImageView
ImageTcl allows you to make use of any of the numerous image-processing
operations available in the ImageVision Library (IL) package. Opening an image,
rotating an image, and changing the color model of an image might all be
considered examples of basic operations on the image.
An application tool such as ImageView makes many of these operations easily
accessible (see Chapter 2, “ImageView”). However, you can use ImageTcl to access
operations that are in the ImageVision package but are not available to you through
application tools such as ImageView.

ImageTcl may be particularly helpful for users who have some programming
background. You can use ImageTcl in two ways:
•

You can work interactively in the shell window by invoking ImageTcl and entering
commands (see “Examples of Using ImageTcl Interactively”).

•

You can create files containing scripts or programs that are executed using ImageTcl
(see “Examples of ImageTcl Scripts or Programs”).
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The ImageTcl tool is built using Tcl, a publicly available scripting language. Whether you
are typing ImageTcl commands interactively or writing programs to be executed by
ImageTcl, you must use the Tcl language. To obtain more information on Tcl, you may
want to refer to the following book: Ousterhout, John K., Tcl and the Tk Toolkit,
Addison-Wesley Publishing Company, 1994.

Obtaining Information and Command Names for Operations
If you have the IRIS Development Option, see the ImageVision Library/Image Format
Library (IL/IFL) manual pages for information on each of the operations available in the
ImageVision Library package. You can also view these manual pages if you have access
to the World Wide Web, by visiting the following site:
http://www.sgi.com/Technology/ImageVision/man/ILman.html
Each of these manual pages describes an operation and indicates the operation’s
command name, to use in writing scripts or when working interactively. For successful
operation of ImageTcl, either type the command name entirely in lowercase or type it
exactly as it is shown in the manual page, noting the case of each letter.

Examples of Using ImageTcl Interactively
For demonstration purposes, this section contains instructions on using ImageTcl to
perform some simple operations. In this series of examples, you are working
interactively in the shell window. (A word of caution: A string of letters used frequently
in these commands—“img”—is easily mistaken to be “ing,” leading to errors.)
1.

To invoke ImageTcl, enter imgtcl at the prompt in the shell window.
The imgtcl prompt appears in the shell window.

2. To select an image file for processing, enter
ilfileimgopen file filename

where filename is the name of the file you wish to open. The word “file” displays,
and then the imgtcl prompt appears again.
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3. To display the image, at the prompt enter
file

The ImageTcl Viewer window opens, displaying the image.
The ImageTcl Viewer operates similarly to the ImageView window. For information
that is useful in understanding the ImageTcl Viewer, refer to Chapter 2,
“ImageView.”
4. Close the window by double-clicking the button located to the left of the window
name, or quit the viewer by choosing Quit from the File menu.
The ImageTcl Viewer window closes, and the ImageTcl prompt appears again in the
shell window.
5. To process the file by applying a compass filter to it, enter
ilcompassimg compass file

The word “compass” displays, and then the ImageTcl prompt appears again.
6. To display the filtered image in the ImageTcl Viewer window, enter
compass

The ImageTcl window opens, displaying the filtered image.
7. Close the window by double-clicking the button located to the left of the window
name, or quit the viewer by choosing Quit from the File menu.
The ImageTcl Viewer window closes, and the ImageTcl prompt appears again.
8. To exit the ImageTcl interpreter and return to your usual shell window prompt,
enter
exit
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Examples of ImageTcl Scripts or Programs
This section contains instructions enabling you to see examples of files containing scripts
or programs—sequences of commands—that can be executed using ImageTcl.
1.

At the standard prompt in your shell window, enter
cd /usr/share/src/imgtcl

2. To see the three sample files listed in directory, enter
ls

3. To display the contents of any of these files, enter
more filename

where filename is the name of the file you wish displayed.
In order to have access to these script file examples, the imagetools.sw.gifts subsystem
must have been installed on your system. If you used the default installation of
ImageVision Tools, Version 3.1, this subsytem is installed on your system.

For Additional Information
For additional information on ImageTcl, see the imgtcl(1) reference page.
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