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About This Guide

The NetWorker for IRIX User’s Guide documents the Silicon Graphics®
implementation of Legato NetWorker® from Legato Systems, Inc.
NetWorker for IRIX is adapted from the Legato™ 4.0.2 release of NetWorker.
This guide was prepared in conjunction with Release 4.0.2 of NetWorker for
IRIX and IRIX Release 5.2.
The NetWorker for IRIX User’s Guide contains instructions on using
NetWorker’s backup and recover software from a client workstation. It also
shows you how to back up files and directories to the NetWorker server on
an as-needed basis using the Backup window, and how to browse the online
index to recover files using the Recover window.

Audience
Those who will benefit most from this manual are users and system
administrators who use NetWorker to back up and recover data from a client
workstation.

Conventions
This manual uses conventions to make information easy to access and
understand. The following list describes the conventions:
•

Command names are displayed in italics. For example:
To start NetWorker, use the networker command.

xiii
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•

Examples of what you type are displayed in bold fixed-width typeface.
For example:
atlas% /usr/etc/networker &

•

Names of buttons are displayed in italics. For example:
Press the Cancel button to close the Help window.

•

Important pieces of information and cautionary notes that prevent you
from making a mistake are marked with the tag “Note.” For example:
Note: Remember that if you select a server other than the server that
performs your scheduled backups, you must recover your files from that
♦
server.

•

Tips or suggestions that you do not have to follow but are hints for
using NetWorker are marked with the tag “Tip.” For example:
Tip: Keep the Main window open during every backup or recovery to

monitor the progress of the session.
•

♦

Directory pathnames, machine names, and new terms are displayed in
italic typeface. For example:
Place the NetWorker programs in the directory /usr/etc.
When you use NetWorker to back up your files, you are saving them to
backup volumes on the NetWorker server.

Other Documentation
For information on server configuration and administration, refer to the
NetWorker for IRIX Administrator’s Guide.
To get information about a specific release of NetWorker for IRIX, see the
NetWorker for IRIX Release Notes.
If you would like more technical information about the NetWorker
commands, see the online reference pages after you have installed
NetWorker.

xiv

Product Support

Both the NetWorker for IRIX User’s Guide and NetWorker for IRIX
Administrator’s Guide are available online, as InSight manuals. To view the
manuals, use insight(1) and install the subsystems
networker4.books.NetWorker_UG and networker4.books.NetWorker_AG.

Product Support
Silicon Graphics offers a comprehensive product support and maintenance
program for IRIS products. For information about using support services for
this product, refer to the Release Notes that accompany it.

xv

Chapter 1

1.

Introduction to NetWorker

NetWorker for IRIX is an easy-to-use network backup and recover product.
Every user knows about accidental file loss and hard disk crashes. With
NetWorker, you can easily protect your valuable files from loss by
performing backups on an as-needed basis in addition to the automatic
backups scheduled by your system administrator. And NetWorker allows
straightforward recovery, which lets you find and retrieve lost files easily
and quickly.
NetWorker allows fast file recovery, which means you do not have to waste
time re-creating lost files. Just scroll through the window of previously
backed-up files to find the files that were lost. NetWorker even shows you
multiple versions of a file that were backed up over time and lets you select
the ones you want to recover. NetWorker provides access to these powerful
features through an intuitive graphical user interface.

Overview
The NetWorker server is a machine with a backup device that automatically
backs up systems on a network. Once your system administrator installs
NetWorker and configures the NetWorker server to recognize your system
as a NetWorker client, your files will automatically be backed up to the
NetWorker server. However, you can request NetWorker to back up
important files at any time on an as-needed basis.
When you use NetWorker to back up your files, you are saving them to a
backup volume on the NetWorker server. The NetWorker server keeps an
online index of the backed-up files for you to browse when you want to
recover a single file or a complete directory.

1

Chapter 1: Introduction to NetWorker

After the NetWorker client software is installed and enabled on your system,
the system administrator will configure the NetWorker server so that you
can use the backup and recover services.

Installing NetWorker Software on Clients
Follow the procedure in this section to install Networker client software.
Because licenses for NetWorker clients are not installed on the clients, no
enabling of the client software is required.
1.

On the client, become root and give the inst(1M) command:
% /bin/su Password:
# inst

2.

Specify the location of the NetWorker software distribution and get a
list of the subsystems, for example:
Inst> from /CDROM/dist
Inst> list

For additional information on inst, see the IRIS Software Installation
Guide.
3.

Make subsystem selections in inst. Use Table 1-1 to guide you in
selecting subsystems. Subsystems not listed in Table 1-1 should not be
installed on clients. For example, to install the required software,
references pages, release notes, and the InSight versions of the
NetWorker manuals on an IRIX 5.2 client, give these commands:
Inst>
Inst>
Inst>
Inst>

keep *
install networker4.*.client_5
install networker4.man.relnotes
install networker4.books.*

For additional information on these subsystems, see the NetWorker for
IRIX Release Notes.
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Table 1-1

Subsystems for NetWorker Clients

Subsystem

Description

Required/Optional

networker4.sw.client_4

NetWorker client
software

Required (install on
systems running IRIX
4.0.x only)

networker4.sw.client_5

NetWorker client
software

Required (install on
systems running IRIX
5.x only)

networker4.man.client_4

Reference pages for
NetWorker client
software

Optional (install on
systems running IRIX
4.0.x only)

networker4.man.client_5

Reference pages for
NetWorker client
software

Optional (install on
systems running IRIX
5.x only)

networker4.books.NetWorker_UG

The InSight version of
the NetWorker for IRIX
User’s Guide, viewable
with insight(1)

Optional on systems
running IRIX 5.x;
cannot be installed on
systems running IRIX
4.0.x

networker4.books.NetWorker_AG

The InSight version of
this guide

Optional on systems
running IRIX 5.x;
cannot be installed on
systems running IRIX
4.0.x

4.

Perform the installation and exit inst:
Inst> go
Inst> quit

5.

Check to see if the hostname alias nsrhost has been set to your
NetWorker server:
jupiter% /usr/etc/ping -c1 nsrhost
PING mars.engr.xyz.com (192.48.155.20): 56 data bytes
...
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In the command, the -c is followed by a one. The first line of output
should contain the name of the NetWorker server.
If the output doesn’t contain the name of the NetWorker server, the
networker command won’t automatically connect you to your server;
you’ll have to use the “Change Server” command on the File pull-down
menu to specify your server.
To set the hostname alias nsrhost to your NetWorker server, follow the
directions in the section “Configuring Clients to Recognize the Server”
in Chapter 2 of the NetWorker for IRIX Administrator’s Guide or ask your
system administrator to help you.
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2.

Getting Started

In this section you will back up and recover files using NetWorker for IRIX.
This chapter assumes that NetWorker client software has been installed and
enabled on your system (see the section “Installing NetWorker Software on
Clients” in Chapter 1) and that your system administrator has configured
the NetWorker server to recognize your system as a client (see the section
“Configuring a Server’s Clients” in Chapter 5 of the NetWorker for IRIX
Administrator’s Guide).

Starting NetWorker
To invoke NetWorker, first change to your home directory or a local
filesystem:
% cd your_home_directory

Then enter the networker command at a shell prompt, followed by an
ampersand (&) to run NetWorker in the background:
% /usr/etc/networker &

Tip: You can invoke NetWorker from any directory. The files in the directory

you invoke NetWorker from are immediately available for backup.

♦

The NetWorker main window is shown in Figure 2-1.
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Figure 2-1

NetWorker Main Window

NetWorker uses windows, pull-down menus, and dialog boxes to guide you
in backing up and recovering files.
Note: The Administration pull-down menu is active only for authorized

NetWorker administrators. For information on NetWorker system
administration, see the NetWorker for IRIX Administrator’s Guide or contact
your system administrator.
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♦

Starting NetWorker

The Operation pull-down menu contains the “Backup,” “Recover,” and
“Volumes” commands. Use this menu to back up and recover your files. Use
the “Volumes” command to display all the backup tapes tracked by
NetWorker. The “Volumes” command is explained in more detail in
Chapter 4, “Backing Up and Recovering Files.”
The Operation pull-down menu is shown in Figure 2-2.

Figure 2-2

Operation Pull-Down Menu

Tip: The grayed-out commands in the Operation pull-down menu are

available only to the system administrator.

♦

The File pull-down menu contains the “Change Server,” “Change Polling,”
and “Exit” commands. The “Change Server” command allows you to
change your NetWorker backup server. Chapter 4 describes in detail how to
change your backup server in the section “Changing the NetWorker Server.”
Use the “Exit” command to quit out of the NetWorker program.
The File pull-down menu is shown in Figure 2-3.

Figure 2-3

File Pull-Down Menu
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The “Change Polling” command allows you to change the polling interval.
Polling controls how often, in seconds, the data in the main window is
updated. When the system is heavily loaded, you might want the main
window updated less frequently.
To change the polling interval:
1.

Select “Change Polling” from the File pull-down menu in the main
window. The Change Polling dialog box appears, as shown in
Figure 2-4.

Figure 2-4

Change Polling Dialog Box

2.

Use the mouse to slide the Polling interval bar to the right or left to
select the desired polling interval. Notice that the number of interval
seconds is displayed as you slide the bar.

3.

Press Ok to apply the change.

Using Help
You can learn about NetWorker by using the Help windows. You can obtain
online help on any menu item or window component. The Help pull-down
menu, shown in Figure 2-5, provides you with help on the main window, a
list of help topics to browse, directions on using help, and information on the
version of NetWorker you are using.

Figure 2-5
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Help Pull-Down Menu

Using Help

Select the Topic command from the Help pull-down menu to open the
Topics Help window, shown in Figure 2-6.

Figure 2-6

Topics Help Window

To see more information about a topic, select the title from the Topics
scrolling list. The help text for the selected topic appears in the top window.
The Topics scrolling list remains available in the bottom window for
selecting other topics.
For example, selecting the topic Backup produces the window shown in
Figure 2-7.
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Figure 2-7

Backup Help Window

To return to the main window, press the Cancel button.

Using NetWorker Windows
NetWorker displays your files and directories using icons and windows.
NetWorker windows provide an easy-to-use X Window System™ graphical
user interface. This section shows you how to use NetWorker windows.
Open the Backup window by selecting “Backup” from the Operation
pull-down menu, as shown in Figure 2-8.
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Figure 2-8

Operation Pull-Down Menu

Position the cursor on the Operation pull-down menu and press either the
left or right mouse button (depending upon how your system is configured).
When the pull-down menu appears, highlight “Backup” to open the Backup
window. The Backup window appears, as shown in Figure 2-9.

Menu bar
Selection
panel
Mount point icon

Directory icon

Highlighted directory
File icon

Directory display
Figure 2-9

File display

Annotated Backup Window
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The following sections describe the components of the Backup window.

Menu Bar
The menu bar contains the File, View, and the Help pull-down menus.
To use the File, View, or Help pull-down menus, position the cursor over the
desired menu and hold down the right (or left) mouse button to display the
pull-down menus. By X Window System convention, the first command in
the menu is always be chosen by default.
Tip: The left and right mouse button actions used in this manual are the

X Window System defaults. If you have problems using the mouse, your
mouse buttons may have been re-programmed. See your system
administrator for help.

♦

Online Help
To use online help, select the Help pull-down menu of the window in
question to read the online help message. You can obtain help on the current
window, menu item, or dialog box.

Selection Panel
The selection panel in the Backup window indicates the current server and
client. The Selection field indicates the full pathname of the current file or
directory and allows you to enter text to select any pathname you choose.

Directory and File Display Areas
The window is divided into two display areas: a directory display on the
left-hand side and a file display on the right-hand side. The size of the file
display can be adjusted horizontally to make it easier to see your files. The
entire window can be adjusted vertically. The display areas contain icons
that represent the files and directories in your filesystem.
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Icons
The icons you see in the window are described below. Use the checkbox next
to each icon to mark and unmark files and directories for backup or recovery.
Folder icons, shown in Figure 2-10, represent directories.

Figure 2-10 Directory Icon

An open folder, shown in Figure 2-11, indicates that the tree structure of the
directory, if one exists, appears in the directory display.

Figure 2-11 Directory Structure Icons

A highlighted open folder, shown in Figure 2-12, indicates that the tree
structure of the directory, if one exists, appears in the directory display. It is
the current selection.

Figure 2-12 Directory Structure Icons for a Selected Directory

A gray checkbox for a directory indicates that a subdirectory has been
marked for backup or recovery.
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A highlighted folder, shown in Figure 2-13, indicates the current selection.
The folder contents appear in the file display. A highlighted folder is selected
for menu actions.

Figure 2-13 Current Selection Icon

The icon in Figure 2-14 represents mount points.

Figure 2-14 Mount Point Icon

Sheet icons, shown in Figure 2-15, represent files.

Figure 2-15 File Icon

A highlighted file, shown in Figure 2-16, is selected for menu actions.

Figure 2-16 Highlighted File Icon

The icon in Figure 2-17 represents symbolic links.

Figure 2-17 Symbolic Link Icon
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The icon in Figure 2-18, represents block devices.

Figure 2-18 Block Device Icon

The icon in Figure 2-19, represents character devices.

Figure 2-19 Character Device Icon

The cursor changes to a clock, shown in Figure 2-20, when NetWorker is
performing a task.

Figure 2-20 Clock Icon

Window Controls
By selecting the scroll bar or the triangular endpoints of a scroll bar or by
dragging the slider, you can navigate vertically or horizontally in the
directory and file displays.

Quick Tour
This “Quick Tour” shows you how to back up your current directory and
how to recover a file using NetWorker. Follow the instructions in this section
to become familiar with the product. Chapter 3 and Chapter 4 have more
detailed information on how to use it.
Use the instructions in the section “Starting NetWorker” to display the
NetWorker main window, as shown in Figure 2-21.
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Figure 2-21 NetWorker Main Window

Backing up Your Directory
To demonstrate NetWorker functionality, you will first back up a directory
to the NetWorker server. The Backup window lets you browse the filesystem
to examine your directories. Then you can mark files for backup.
To learn about NetWorker, you will mark an entire directory for backup.
Then you will unmark a file within that directory. Finally, you will start the
backup.
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Opening the Backup Window

Open the Backup window by selecting the “Backup” command from the
Operation pull-down menu, as shown in Figure 2-22.

Figure 2-22 “Backup” on the Operation Pull-Down Menu

The Backup window appears, as shown in Figure 2-23.

Figure 2-23 Backup Window
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The Selection field displays the pathname of the directory from which you
invoked NetWorker. The directory display shows you a graphical
representation of the path, with the current directory highlighted. The file
display shows you the contents of the current directory.
Expanding the Current Directory

First, expand the current directory one level to find a lower-level directory
to mark for backup. Select “Expand One Level” from the View pull-down
menu, as shown in Figure 2-24.

Figure 2-24 ”Expand One Level” on the View Menu of the Backup Window

The directory display shows the expanded directory, as shown in
Figure 2-25.
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Figure 2-25 Directory Display in the Backup Window

Marking a Directory

To mark a directory for backup, use the mouse to select the checkbox next to
the folder that represents the directory that you want to back up, as shown
in Figure 2-26.

Figure 2-26 Directory Marked for Backup

Notice that a checkmark (✓) appears in the checkbox. Highlight the folder to
display its files. In the file display, notice that the files contained in the
marked directory are also marked, as shown in Figure 2-27.
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Figure 2-27 File Display in the Backup Window

When you mark a directory, its nested files and subdirectories are marked as
well. The checkboxes of the parent directories turn gray to indicate that a
subdirectory has been marked. Mount points within a marked directory are
not marked, since you can only mark files within one filesystem at a time.
Tip: You can also mark a directory by highlighting it and selecting “Mark”

from the File pull-down menu. The effect is the same as selecting the
checkbox.

♦

Unmarking a File

You can exclude a file from the backup by unmarking it. In the file display,
select the checkmark next to a file to unmark it. The checkmark disappears
and the file is excluded from the backup. In Figure 2-28, the first eight files
are excluded from the backup.
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Figure 2-28 Included and Excluded Files in the File Display of the Backup Window

Tip: You can also unmark a file by highlighting it and selecting “Unmark”

from the File menu. The effect is the same as selecting the checkmark.

♦

Starting the Backup

After you have finished marking files, you are ready to start the backup.
Select “Start Backup” from the File menu, as shown in Figure 2-29, to start
the backup.

Figure 2-29 ”Start Backup” on the File Menu of the Backup Window
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Before the backup starts, the Backup Options dialog box appears, as shown
in Figure 2-30.

Figure 2-30 Backup Options Dialog Box

In the Backup Options dialog box, you tell NetWorker whether you want to
compress your files during the backup. Compress the files for this backup.
Notice that “Yes” is highlighted after the question “Do you want to
compress this backup?” This means it is the default choice, so press the Ok
button to continue the backup with file compression.
Note: You can also exclude patterns in the Backup Options dialog box. For

information on excluding patterns, see Chapter 4, “Backing Up and
Recovering Files.”

♦

The Backup Status window appears, as shown in Figure 2-31, where you can
monitor the progress of your backup.
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Figure 2-31 Backup Status Window

Tip: If you do not see any files scrolling in the display, or if you see an error

message, contact your system administrator. The server may be busy
recovering, or it may have a configuration problem. Or, the backup volume
may not be mounted in the device. You can check the main window as
described in the next section to see if the backup volume is mounted.
♦
When your backup is complete, you will see a message similar to this in the
Backup Status window:
Backup Completion Time: Wed Jun 23 11:20:03 1993

NetWorker backed up the files you marked to the volume mounted in the
server device. It also created an index on the NetWorker server for your
client machine. Any file that you back up in the future will have an entry in
this index, so that you can find it quickly.
Select the Cancel button to close the Backup Status window.
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Close the Backup window by selecting “Exit” from the File menu, as shown
in Figure 2-32.

Figure 2-32 “Exit” on the File Menu of the Backup Window

Checking for Media Requests in the Main Window

If the scrolling list of your files does not appear in the Backup Status
window, or if you see an error message during the backup, you can use the
main window to confirm that the backup volume is mounted by checking
the Pending display.
The Pending display of the main window shows media requests for backup
volumes, which are required for a backup or recover to proceed.
The main window is shown in Figure 2-33.
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Pending
display
Figure 2-33 Pending Display on the NetWorker Main Window

Notice the following message in the Pending display:
media waiting: backup to pool `Default` waiting for 1
writable backup tape

This message indicates that the backup volume is unmounted. If there is no
message in the Pending display, then the backup volume is mounted and
you can proceed with the backup.
To avoid this media alert, it is recommended that you contact your system
administrator to mount a backup volume before starting a backup.
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Note: The backup volume must be mounted before a backup will complete.

For information on mounting backup volumes, refer to the NetWorker for
IRIX Administrator’s Guide.

♦

Recovering a File
The index that is created on the NetWorker server when you back up files is
displayed in the Recover window. The index looks similar to the filesystem
that is pictured in the Backup window.
To recover a file, you browse the index for a directory and mark a file within
that directory. Then you start the recovery.
Opening the Recover Window

Open the Recover window by selecting “Recover” from the Operation
pull-down menu, as shown in Figure 2-34.

Figure 2-34 “Recover” on the Operation Pull-Down Menu

The Recover window appears, as shown in Figure 2-35.
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Figure 2-35 Recover Window

Tip: Remember that in the Recover window you are looking at the index for

your files on the NetWorker server, not the filesystem on your system that is
in the Backup window. The Recover window shows the entries for those files
that have been backed up and are available for recovery. The entries are
organized exactly like the actual filesystem, so it is easy for you to navigate
around the directories.
♦
Browsing the Index

You can browse the index to locate a file that you want to recover.
1.

Notice that the current directory is highlighted.

2.

Select “Expand One Level” from the View pull-down menu. The
subdirectories are displayed in a tree structure in the directory display,
as shown in Figure 2-36.
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Figure 2-36 ”Expand One Level” on the View Pull-Down Menu of the Recover
Window

Tip: Selecting a closed directory folder twice also expands it one level,

as shown in Figure 2-37.

♦

Figure 2-37 Expanding a Directory One Level
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3.

Highlight the directory folder that contains the desired file by selecting
it. The file display shows the most recently backed-up version of the
files contained in the directory.

4.

Mark the files you wish to recover by selecting their checkboxes in the
file display, as shown in Figure 2-38.

Quick Tour

Figure 2-38 Marking Files to Recover in the Recover Window
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Starting the Recovery

So far you have browsed the index and marked files for recovery. You are
now ready to start the recovery.
1.

Select “Start Recover” from the File menu. The Conflict Resolution
dialog box appears, as shown in Figure 2-39, before the recovery starts.

Figure 2-39 Conflict Resolution Dialog Box

With the Conflict Resolution dialog box, you tell NetWorker what to do
if a naming conflict is encountered during recovery. A naming conflict
occurs when the file you are recovering has the same name as a file in
the current directory.
2.

Select “No” so that NetWorker does not prompt you for each naming
conflict.

3.

“Rename the recover file” is now highlighted as the default selection. It
places a .R extension after the name of the recovered file when a
naming conflict occurs with an existing file.

4.

Press Ok to close the Conflict Resolution dialog box and continue the
recovery.
The Recover Status window appears, as shown in Figure 2-40. You can
monitor the progress of the recovery in the Recover Status window.
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Figure 2-40 Recover Status Window

The Recover Status window provides information about your recovery,
including the name(s) of the backup volumes (Volumes needed:) that
are needed and their location, the directory that the files are being
recovered into, and the number of files being recovered.
You may cancel the recovery by pressing the Cancel button in the
Recover Status window.
The following message appears when the recovery is complete:
Received 5 files from NSR server `atlas`

To confirm its recovery, you can look for your file in the filesystem by
listing the contents of the directory in an IRIX shell. The recovered file
has a .R file extension because you told NetWorker to rename the file in
the Conflict Resolution dialog box.
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Quick Tour Review
During the quick tour of NetWorker, you learned how to:
•

Use the NetWorker graphical user interface

•

Use the Backup window to back up your directory to the NetWorker
server

•

Monitor the status of your backup

•

Use the Recover window to browse the index for your backed-up files

•

Mark a file for a recovery in the Recover window

•

Recover a file

•

Resolve a naming conflict during recovery

•

Monitor the status of the recovery

The quick tour is meant to familiarize you with the NetWorker Backup and
Recover windows. Chapter 3 and Chapter 4 provide detailed information on
performing backups and recovers.
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3.

Browsing Filesystems

The NetWorker graphical user interface allows you to browse your
filesystems, including directories, subdirectories, and nested files. Since the
filesystem is represented by icons on the screen, it is easy to select files and
directories for backup. When recovering files, the index of saved files is
displayed graphically like the filesystem, making it convenient to select files
for recovery.
NetWorker browsing features allow you to view directories, mark and
unmark files, search for files, view file details, and change the current
directory. The following instructions for browsing filesystems apply to both
the Backup and Recover windows.

Viewing Your Directories
Use the View menu to select the level at which you wish to browse the
directories in the filesystem in the Backup window or browse the index of
directories in the Recover window.
Note: This section describes the features common to both windows that are
used for viewing directories. The features specific to a window are described
in Chapter 4, “Backing Up and Recovering Files.”
♦

You can expand a directory to one level to view its subdirectories or you can
view all levels of a directory by expanding a branch. This makes it easy to
find files that are deeply embedded in your filesystem.
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Expanding to One Level
Choosing the “Expand One Level” command, as shown in Figure 3-1, opens
a directory to display the subdirectories one level below. The subdirectories
are graphically displayed as a tree structure in the directory display. You can
scroll in the directory display to find the subdirectory that contains the
desired file.

Figure 3-1

“Expand One Level” in the View Menu of the Backup Window

To expand a directory to one level:
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1.

Highlight a directory folder in the directory display.

2.

Select “Expand One Level” from the View pull-down menu. The
highlighted directory folder expands, as shown in Figure 3-2.

Viewing Your Directories

Figure 3-2

Backup Window with an Expanded Directory

Expanding a Branch
The “Expand Branch” command, shown in Figure 3-3, lets you view all the
levels of subdirectories in a directory. Large directories may take a few
minutes to expand.

Figure 3-3

Expand One Branch on the View Menu of the Backup Window

35

Chapter 3: Browsing Filesystems

To expand a directory to view the branch:
1.

Highlight a directory in the directory display.

2.

Select “Expand Branch” from the View pull-down menu. The
highlighted directory expands, as shown in Figure 3-4.

Figure 3-4
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Backup Window with an Expanded Branch

Viewing Your Directories

Collapsing a Branch
The “Collapse Branch” command, shown in Figure 3-5, closes all
subdirectories and returns you to the level of the highlighted directory.

Figure 3-5

”Collapse Branch” on the View Menu of the Backup Window

To collapse a branch:
1.

Highlight an expanded directory in the directory display.

2.

Select “Collapse Branch” from the View pull-down menu, as shown in
Figure 3-6.

Figure 3-6

Backup Window After Using “Collapse Branch”
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Marking and Unmarking Files
You choose files and directories for backup and recovery by marking them.
The icons have a checkbox beside them that displays a checkmark when the
file is marked. You can mark or unmark files and directories by using either
the File pull-down menu or the checkbox.
To mark a file or directory using the File menu:
1.

Highlight a file or directory icon by selecting it with the mouse.

2.

Select “Mark” from the File pull-down menu, as shown in Figure 3-7.

Figure 3-7

“Mark” and “Unmark” on the File Menu of the Backup Window

This places a checkmark in the checkbox beside the highlighted icon to
mark it for backup or recovery.
3.

If you decide that a file should not be included in the backup or
recovery, highlight the icon and select “Unmark” from the File
pull-down menu to remove the checkmark.

To mark a file using the checkbox:
1.

Use the mouse to select the checkbox next to the file. This places a
checkmark in the checkbox.

2.

Select the checkmark to unmark the file, as shown in Figure 3-8.

Figure 3-8
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Unmarking a File

Viewing File Details

Tip: When you mark a directory, all its subdirectories and nested files

are also marked. The checkboxes of the parent directories turn gray to
indicate that some or all of the directory contents are marked for backup
or recovery.
♦

Viewing File Details
NetWorker lets you choose to view the file details or only the file names in
the file display. “File Names” is the default selection. “File Names” lists the
files in alphabetical order with only the filenames displayed. “File Details”
displays the filename, number of blocks, permissions, number of links and
where they point (only applies to symbolic links), owner, group, size, and
date last modified for each file.
Backup File Details and Recover File Details are identical except for one
difference. Recover File Details provides the backup time for each file to
identify different backup versions of the same file.
Use the View pull-down menu to select either the “File Names” or “File
Details” in the file display. This is a toggle selection. When you are in File
Names mode, the menu selection changes to “File Details.” When you are in
File Details mode, the menu selection changes to “File Names.”
To display the file details:
1.

Select “File Details” from the View pull-down menu, as shown in
Figure 3-9.

Figure 3-9

2.

“File Details” on the View Menu of the Recover Window

Adjust the size of the window to display the full File Details.
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The Recover File Details display is pictured in Figure 3-10. Notice the
backup time listed beside each icon.

Figure 3-10 File Details Display on the Recover Window

Searching for Files
If you know the name or partial name of a file or directory, you can use the
Search window to locate it in the filesystem or index. To search for files, you
specify the filename or partial filename you are looking for and the directory
name where you wish to begin the search. NetWorker begins searching in
that directory and then searches through its subdirectories and nested files.
To search for files or directories by name:
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1.

Use the File menu to open the Search dialog box.

2.

Enter the name of the file or directory in the Search for field, as shown
in Figure 3-11. You can use standard IRIX shell pattern characters when
specifying partial filenames.

Changing a Selection

Figure 3-11 Search Dialog Box

3.

In the “Begin search in” field, enter a valid pathname of the directory
where you wish to begin the search. NetWorker searches through that
directory and all nested subdirectories.

4.

Press the Ok button. The pathname of the first match appears in the
Selection field and is also highlighted in the file display.

5.

Press the Continue button to highlight the next match. You can continue
the search until the last match is found.

Changing a Selection
The NetWorker windows display the full pathname of the current directory
in the Selection field. If you know the path of a directory or file, you can go
directly to it by entering the full pathname in the Selection field, as shown in
Figure 3-12.

Figure 3-12 Selection Field of NetWorker Windows

To change the current selection:
1.

Enter the full pathname in the Selection field.

2.

Press the <Enter> key.

Both the directory and file displays change to show the new selection.

41

Chapter 3: Browsing Filesystems

Exiting from a Window
The “Exit” command is in the File menu of every window. “Exit” closes the
current window without backing up or recovering files and returns you to
the main window.
Select “Exit” from the File menu, as shown in Figure 3-13, to close the
window.

Figure 3-13 “Exit” on the File Menu
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4.

Backing Up and Recovering Files

This chapter describes the NetWorker main, Backup, and Recover windows.
It includes the backup and recover functions that are unique to each of the
windows. For information on using the functions that are common to the
windows, such as viewing and marking files, see Chapter 3, “Browsing
Filesystems.” For a quick tour of the NetWorker Backup and Recover
windows, see Chapter 2, “Getting Started.”

Monitoring Your Backup and Recovery
The NetWorker main window monitors your backups and recovers. (It also
provides pull-down menus for selecting the Backup and Recover windows.)
The main window provides valuable online information about server status,
backup device status, client sessions, and pending requests.
The main window appears when you invoke NetWorker.
Tip: Keep the main window open during every backup or recover to

monitor the progress of the session.

♦

The NetWorker main window is shown in Figure 4-1.
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Menu
bar
Server
status
display

Devices
display

Sessions
display

Messages
display

Resize
button

Pending
display
Figure 4-1

NetWorker Main Window

The main window has a menu bar and five displays:
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•

Menu bar – contains the File, Operation, Administration, and Help
pull-down menus.

•

Server status display – tells you how long the current server has been
online, the number of backups and recovers the server has completed
since it has been online, and the amount of data contained in the
backups and recovers.

•

Devices display – shows you the backup devices known to the server
and which volume, if any, is mounted in the device.

Backing Up Files

•

Sessions display – provides current information on which clients are
backing up, browsing, or recovering files.

•

Messages display – provides a history of the NetWorker server activity.

•

Pending display – shows messages that may require operator attention.

A scroll bar appears to the right of the display area when there is more
information to see. Use the resize buttons for resizing the display areas.

Backing Up Files
This section assumes you have already marked your files for backup. If you
need to know how to view directories, mark files, search for files, or view file
details, see Chapter 3, “Browsing Filesystems.”

Changing the NetWorker Server
NetWorker clients are included in a scheduled backup determined by your
system administrator.
Generally only one NetWorker server is required to back up all the systems
on a network. If you have more than one NetWorker server on the network,
you may have a choice of servers.
However, you must be listed as a client on the NetWorker server you choose
for your backups. Check with your system administrator if you wish to back
up to a server other than the server chosen for your scheduled backups.
You may need to back up a file to a different server due to network
difficulties or because your backup server is down.
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To change NetWorker servers, follow these steps:
1.

Select “Change Server” from the File pull-down menu, as shown in
Figure 4-2.

Figure 4-2

“Change Server” on the File Menu

The Change Server dialog box appears, as shown in Figure 4-3.

Figure 4-3
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Change Server Dialog Box

2.

Press the Update Server List button to update the list of NetWorker
servers on the network.

3.

Highlight the hostname of a server, or enter a valid hostname in the
Server field.

4.

Press Ok to choose the new server.

Backing Up Files

Starting a Backup
Before starting a backup, complete the following steps:
•

Mark the files that need to be backed up.

•

Choose the NetWorker server (if necessary).

When these steps are complete, you may start the backup.
Select “Start Backup” from the File menu, as shown in Figure 4-4, to start the
backup.

Figure 4-4

“Start Backup” on the File Menu of the Backup Window

Choosing the Backup Options
NetWorker displays the Backup Options dialog box before starting the
backup. Backup Options gives you the option to compress files and exclude
patterns before the backup starts.
Compressing Files

To choose whether or not to compress the files you back up, answer the
question “Do you want to compress this backup?” in the Backup Options
dialog box, as shown in Figure 4-5. Notice that “Yes” is already highlighted
as the default selection. NetWorker requires that you choose whether or not
you want to compress your files in the Backup Options dialog box, before
you can back them up.
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Figure 4-5

Backup Options Dialog Box

To continue the backup with file compression, select “Yes” (the default
selection). To continue the backup without file compression, select “No.”
Tip: It is a good idea to compress all your backups to save space on the

backup volumes and to reduce network traffic. However, backups may be
slower due to compression.
♦
If you do not need to exclude patterns from your backup, press Ok to
continue the backup with your file compression choice.
Excluding Patterns

Before starting a backup, you can exclude patterns in the Backup Options
dialog box. To exclude patterns, you specify alphanumeric patterns that
occur in the names of the files that you want to exclude from the backup.
Any number of patterns may be specified using IRIX shell pattern
characters.
Excluding patterns is an optional shortcut for eliminating similar files from
the backup.
Notice that “No” is highlighted as the default answer to the question “Do
you want to exclude any patterns from this backup?” If you do not wish to
exclude any patterns of filenames from the backup, select Ok to continue the
backup with only your file compression choice.
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To exclude patterns from the backup:
1.

Select “Yes” to answer the question “Do you want to exclude any
patterns from this backup?” This activates the exclude patterns portion
of the Backup Options dialog box.

2.

Enter the first pattern to be excluded in the Pattern field.

3.

Press Add to add the pattern to the pattern list, as shown in Figure 4-6.

Figure 4-6

4.

Backup Options Dialog Box

You may enter any number of patterns and add them to the pattern list.
If you wish to change a pattern, select it in the pattern list. The selected
pattern appears in the Pattern field. Enter the new pattern and press
Change. The new pattern replaces the old pattern in the pattern list.

5.

To delete a pattern, select it in the pattern list and press Delete.

6.

Press Ok to continue the backup with the excluded patterns.

Monitoring the Backup Status
After you press Ok to complete the Backup Options dialog box, the Backup
Status window appears, as shown in Figure 4-7. Use the Backup Status
window to monitor the progress of the backup.
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Figure 4-7

Backup Status Window

The Backup Status window provides the Backup start time and the Backup
completion time. The names of the files and directories scroll across the
Backup Status window as the backup proceeds. The save message at the
bottom of the window gives you information about the backup including the
full pathname of the directory and the number of kilobytes and files being
saved.
You can cancel the backup by pressing the Cancel button.
The following message appears in the Backup Status window when the
backup is complete:
Backup completion time: Wed Jun 23 11:20:03 1993
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Using the Volume Management Window
You can verify that NetWorker has successfully backed up your files in the
Volume Management window by selecting the “Volumes” command in the
Operation pull-down menu. You can determine exactly to which volumes
your files have been backed up. All of the volumes known to the NetWorker
server are listed in the Volumes scrolling list, and the contents are listed in
the Save Sets scrolling list, as shown in Figure 4-8.

Figure 4-8

Volume Management Window

When you select the name of a volume in the Volumes list, the Save Sets list
displays the contents of that volume. In the example above, the directory
/usr/src/sco has been backed up on the volume atlas.001.
Note: The information listed in the Volume Management window is useful

to the system administrator for managing NetWorker backup volumes.

♦
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Recovering Files
This section assumes you have already marked your files for recovery in the
Recover window. If you need to know how to view directories, mark files,
search for files, or view file details, see Chapter 3, “Browsing Filesystems.”
The files listed in the Recover window are entries for the files that were
backed up by NetWorker. When NetWorker backs up a file, it creates an
entry for the file in the online index. You may then select a file that is listed
in the index for recovery. Powerful NetWorker recover functions allow you
to browse the index for previous backups, select various versions of the file
to recover, view your marked files, relocate files upon recovery, and recover
files from another authorized system. An “authorized system” is a client
from which you have permission to recover data.

Choosing the Recover Server
Normally you recover files from the NetWorker backup server chosen for
you by your system administrator. If you have backed up files to a different
server, you must also recover those files from that server. If you changed
servers in the Backup window, select the same server in the Recover
window.
The Change Server dialog box lists all the NetWorker servers on the
network. You can only recover files from a server that lists your system as a
client.
To choose a recover server:
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1.

If it is not already open, select “Recover” from the Operation pull-down
menu to display the Recover window.

2.

Select the File pull-down menu and then choose the “Change Server”
command. The Change Server dialog box appears, as shown in
Figure 4-9.

Recovering Files

Figure 4-9

Change Server Dialog Box

Press the Update Server List button to update the list of NetWorker
servers on the network. Choose the server that has the files you need to
recover. The Server field changes to reflect the current selection. The
directory and file displays are refreshed to show the index for the
current server.
3.

Press the Ok button after you have selected a server.

Choosing the Recover Client
If you need to recover files from a client other than the system you are
currently using (for example because the client’s disk was damaged and
they are being restored onto a different system), use the “Change Client”
command in the File pull-down menu. The “Change Client” command
opens a dialog box that lists all of the NetWorker clients. Check with your
system administrator if you wish to recover files other than your own. You
may not be authorized to recover files for other client systems.
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To choose a recover client:
1.

Choose the “Change Client” command from the File pull-down menu
in the Recover window. The Change Client dialog box appears, as
shown in Figure 4-10.

Figure 4-10 Change Client Dialog Box

2.

You can update the list of NetWorker clients by pressing the Update
Client List button.

3.

Choose a client from which you are authorized to recover files. The
Client field changes to reflect the current selection.
When you recover this client’s files, they will be restored on the system
you are currently using.

Selecting File Versions
The Versions window lists all the versions of a file or directory that have
been backed up by the backup server. It also lists the locations of the
versions. Use “Versions” to view the backup history of a file and to mark a
version for recovery.
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Versions of a directory may be listed in the Versions window, but directories
cannot be marked for recovery in this window. Only versions of files may be
marked for recovery in the Versions window.
The Versions window provides the following information about each
version: number of blocks, mode, permissions, number of links, owner,
group, size in bytes, last modified time, and filename.
It also provides the backup time and location of the version. The backup time
is used to identify different versions of a file.
The location includes the name of the backup volume; the device where the
volume is mounted, if any; or the location of the backup volume (for
example, an off-site storage place). If no device is listed, it means that the
backup volume must be mounted before recovery of the file is possible.
The information in the Versions window is retrieved from the index that is
created by NetWorker when you perform a backup.
To view the backup history of a file or directory:
1.

Open the Recover window and highlight a file or directory in the file
display.

2.

Select “Versions” from the View pull-down menu, as shown in
Figure 4-11.

Figure 4-11 “Versions” on the View Menu of the Recover Window

NetWorker retrieves the most recent ten versions of the highlighted file
or directory from the index and lists them by backup time, beginning
with the most recent, as shown in Figure 4-12. Use the scroll bar to view
the backup history.
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Figure 4-12 Backup History in the Versions Window

3.

Press More to retrieve ten more versions from the index. The More
button turns to gray when all versions have been retrieved.
Note: Remember, you cannot mark directories for recovery in the
Versions window. Use the “Change browse time” command in the File
pull-down menu to mark a past version of a directory for recovery.

To select a version of a file for recovery:
1.

Select the checkbox of the version that you want to recover.

2.

Select Ok to place the checkmarked versions in the file display.
Tip: When you mark a past version of a file in the Versions window, this

version appears in the Recover window file display with the same name
as the recent version. You will then have more than one version of a file
in the file display. If you are confused as to which version to mark, use
♦
“File Details” to display the backup times.
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Changing the Browse Time
The Browse Time field displays the current date unless you change it to a
date in the past. The currently selected browse time is indicated in the
Browse Time field in the Recover window, as shown in Figure 4-13.

Figure 4-13 Browse Time in the Recover Window

In the Recover window you are viewing the index entries for previously
backed-up files. Changing the browse time displays the index entries for
files backed up at that time.
Tip: If files were not backed up at the time entered in the Browse Time field,

NetWorker displays files that were backed up closest to the selected browse
time.
♦
Changing the browse time lets you view your files as of some time in the
past. This is useful if you do not remember the name or location of the files
you want to recover, but you remember they existed at some time in the past.
“Change browse time” also helps you find files that have been deleted and
thus do not appear in the Versions window. You can recover deleted files by
changing the browse time to locate past versions of the files in the index.
Tip: You can mark directories for recovery in the Recover window by using

the “Change browse time” command rather than the “Versions”
command.

♦
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To change the browse time to recover a past version of a file:
1.

Open the Recover window and select “Change browse time” from the
File menu, as shown in Figure 4-14.

Figure 4-14 ”Change browse time” on the File Menu of the Recover Window

2.

The Change Browse Time dialog box appears, as shown in Figure 4-15.
The Prev, Today, and Next buttons control the month shown in the
calendar. When the desired month is displayed, select the browse time
by selecting a day in the calendar.

Figure 4-15 Change Browse Time Dialog Box
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3.

You can also enter the date and time in the Browse time field and press
<Enter> to change the browse time.

4.

Press Ok to display the files that were backed up at the new browse
time. The Browse time field in the Recover window changes to reflect
the new browse time. Both the file display and the directory display of
the Recover window show the files that were backed up at that time.
You may now mark past versions of files for recovery.

Note: Any files or directories that you have marked for recovery prior to
changing the browse time remain marked.

♦

Showing Marked Files
You can list the files you have marked for recovery by selecting “Show
Marked.” Use “Show Marked” to check which files you have marked for
recovery before performing the actual recover. The Files Marked for
Recovery window lists the pathnames and backup time of files that you have
marked for recovery.
To show the files that you have marked for recovery:
1.

Select “Show Marked” from the View menu of the Recover window, as
shown in Figure 4-16.

Figure 4-16 “Show Marked” on the View Menu of the Recover Window

The Files Marked for Recovery window appears, as shown in
Figure 4-17, listing the pathnames and backup time of all marked files.
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Figure 4-17 Files Marked for Recovery Window

2.

Press Cancel to close the window.

Relocating Files
Use the optional “Relocate” command to place your files in a directory other
than the original one before you start a recovery. “Relocate” first creates the
directory, if it does not already exist, and then stores the recovered files in the
new directory. You may also relocate files to an existing directory by entering
the complete pathname.
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To relocate recovered files into a new or existing directory:
1.

Open the Recover window and select “Relocate” from the File menu, as
shown in Figure 4-18.

Figure 4-18 “Relocate” on the File Menu of the Recover Window

2.

Enter the name of the directory where the recovered files will be stored
in the “Relocate to” field, as shown in Figure 4-19. You can relocate files
to a new directory or to an existing directory. Be sure to include the
complete pathname.

Figure 4-19 Relocate Window

3.

Press Ok to relocate files into the new directory.
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Starting a Recovery
Before starting a recovery, complete the following steps:
•

Choose a server and an authorized client, if necessary.

•

Mark files and directories for recovery.

•

Select a past version of a file by name and location, if desired.

•

Select a past version of a file by browse time, if desired.

•

Show your marked files, if desired.

•

Relocate recovered files to a new directory, if desired.

Usually, you can complete a recovery in two steps: mark the files and start
the recovery.
To start a recovery, select “Start Recover” from the File pull-down menu in
the Recover window, as shown in Figure 4-20.

Figure 4-20 “Start Recover” on the File Menu of the Recover Window

Before actually starting the recover process, NetWorker prompts you for
instructions on how to resolve naming conflicts by displaying the Conflict
Resolution dialog box.
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Renaming or Overwriting Recovered Files

With the Conflict Resolution dialog box, you tell NetWorker whether to
rename recovered files or overwrite existing files when a naming conflict
occurs. A conflict occurs when a file you are recovering already exists or has
the same name as one in the current directory. The Conflict Resolution dialog
box has two questions for you to answer concerning conflicts between
recover files and existing files.
1.

To resolve the conflict, first answer the question, “Do you want to be
prompted when conflict occurs?” Selecting “No” specifies a global
resolution for renaming or overwriting files, as shown in Figure 4-21.

Figure 4-21 Conflict Resolution Dialog Box

2.

If you select “Yes” (the default selection) NetWorker prompts you for
instructions in the Filename Conflict dialog box every time it
encounters a conflict between a recovered file and an existing file. For
each instance, you tell NetWorker whether to rename the recovered file,
discard the recovered file, or overwrite the existing file. This allows you
to resolve conflicts on a file-by-file basis.
The Filename Conflict dialog box is shown in Figure 4-22.
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Figure 4-22 Filename Conflict Dialog Box

3.

If you select “No,” then you must answer the question “When conflict
occurs, NetWorker should?” shown in Figure 4-23. Answering this
question allows you to resolve conflicts on a global basis per recover
session without being prompted for each individual file.

Figure 4-23 Conflict Resolution Dialog Box

Select one of the following to resolve conflicts:
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•

Rename the recover file – When a conflict occurs, NetWorker
renames the recover file with a .R extension. If the .R file exists,
NetWorker adds another .R.

•

Discard the recover file – NetWorker discards the recover file. The
existing file remains current.

•

Overwrite the existing file – NetWorker replaces the existing file
with the recovered file. The existing file is lost and the recovered
file becomes current.

Recovering Files

4.

After completing the Conflict Resolution dialog box, select Ok to
continue the recovery.

Monitoring the Recover Status

After the Conflict Resolution dialog box closes, the Recover Status window,
shown in Figure 4-24, reappears as the recovery continues.

Figure 4-24 Recover Status Window

The Recover Status window provides you with the following information
about your recover session:
•

The name of the required backup volume and its location.
Volumes needed:
.001 at /dev/nrStp0

•

The pathnames of the files being recovered and the pathname of the
directory where they will be stored.
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/home/titania/Rebecca/pubs/ is being recovered into its
original location

If you specified a directory in the Relocate dialog box, it appears after
“...is being recovered into...”
If you chose to rename the recover files, the new filenames are listed.
•

The number of files it is recovering.
Requesting X files, this may take a while...

As the recovery proceeds, the pathnames of the files scroll across the
Recover Status window.
•

When the recovery is complete, the following message appears:
Received X files from...

Press Cancel to cancel the recovery.
Press Cancel to close the Recover Status window.
Chapter 4 has given you a thorough overview about how to back up and
recover your NetWorker files. You have learned how to:
•

Back up files

•

Monitor the backup status

•

Use the Volume Management window

•

Recover files

•

Monitor the recover status

For more information about configuring the NetWorker server, refer to the
NetWorker for IRIX Administrator‘s Guide or ask your system administrator.
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A.

Error Messages

NetWorker provides user-friendly error messages that have
easy-to-understand explanations. This appendix provides you with further
information and solutions to assist you with your backups and recovers.

Error Messages for Backup
NetWorker displays an error message if a backup cannot be successfully
completed. NetWorker backup error messages are shown below:
Nothing marked for backup

Problem:

Starting backup without marking any files.

Solution:

Mark at least one file before starting the backup.

Unable to start backup

Problem:

Error starting the backup (could not execute the Save
command).

Solution:

Contact the system administrator. There is a problem either
with the NetWorker software or with the configuration (for
example, an incorrect path name).

Your system is not a registered client.

Problem:

The server you have chosen to do your backups does not
have your system configured as a NetWorker client.

Solution:

Contact the system administrator. Your system needs to be
added to the server‘s list of recognized clients.
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Error Messages for Recover
An error message is displayed when NetWorker is unable to recover a file.
NetWorker recover error messages are shown below:
There are files marked for recovery.
Continue to ignore the marked files,
Cancel to stay with this client.

Problem:

Changing clients when files are marked.

Solution:

You have the option to continue changing clients. In this
case, the marked files will not be recovered. Or you can
cancel to stay with the current client and retain your marked
files.

Only 10 KBytes available in directory. The estimated recover
size of 10 KBytes will not fit on this filesystem.
Proceed with recover command at this time? [n]
No disk space available in directory. The estimated recover
size of 10 KBytes will not fit on this filesystem.
Proceed with recover command at this time? [n]

Problem:

There is not enough free space in the filesystem to recover
the requested files.

Solution:

Reduce the number of kilobytes in the recovery by reducing
the number of marked files. Relocate the recovery into
another directory with more space. If you are recovering
over existing directories, you may be able to proceed with
the recovery since files will be overwritten.

Invalid time format

Problem:

The time specified in the change browse time field was
invalid.

Solution:

Enter the browse time using a valid format. See the
getdate(3) reference page for information about valid
formats.

Nothing in index at this time

Problem:
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There are no entries in the index for the browse time that
was specified. No backups were performed at that time.

Error Messages for Both Backup and Recover

Solution:

Enter another browse time close to this one until you find
the index entries you are looking for.

Unable to relocate to /usr/tmp/root

Problem:

NetWorker was unable to relocate to the specified path.

Solution:

Enter a valid pathname in the Relocate dialog box and start
the recovery again. You must have write permission for the
directory you wish to use.

Error Messages for Both Backup and Recover
Some of NetWorker‘s error messages are the same for both a backup or
recover that is unsuccessful. The error messages used for both backups and
recovers are shown below:
You cannot mark files from different filesystems. directory is
on a different filesystem from files you have already
marked. You must either Backup or Recover the files you have
marked or unmark them before you can mark this file.

Problem:

NetWorker does not allow you to mark files across
filesystems.

Solution:

Complete the backup or recovery for one filesystem at a
time.

There are files marked for backup or recovery.
Continue to ignore the marked files or
Cancel to stay with server.

Problem:

You cannot change servers after you have marked files.

Solution:

You have the option to continue changing servers. If you
change servers, the marked files will not be backed up or
recovered. You can cancel to stay with the current server
and retain your marked files.

Bad start path

Problem:

Specifying an invalid starting path for a search.

Solution:

Enter a valid pathname as a starting point in the search
dialog box.
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No match

Problem:

Nothing matched on this search command.

Solution:

Enter a different pattern or a different starting path.

Bad search pattern

Problem:

The search pattern specified is not valid.

Solution:

You may use the IRIX shell pattern characters to specify a
search pattern.

Unable to expand path
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Problem:

The path specified in the selection field does not correspond
to anything in the index or filesystem.

Solution:

Enter a valid pathname in the selection field.

Appendix B

B.

Commands for Backup and Recovery

In addition to a graphical user interface, NetWorker has backup and recover
commands similar to IRIX commands. These commands are entered from an
IRIX shell. To use the NetWorker commands from an IRIX shell, the
NetWorker software must be installed on the NetWorker server, and your
system must be configured as a NetWorker client by the system
administrator.

Table of Backup and Recover Commands
Use the save command to back up data. The recover commands are listed
below. You can use these after entering recover at the system prompt.
Table B-1

recover Commands

Command

Description

?

Display list of recover program
commands.

add filename

Add filename to the recover list.

cd dir

Change directory to dir.

changetime

Change the browse time of online index.

delete filename

Delete filename from the recover list.

dest

Verify destination directory for
recovered files.

force

Overwrite existing files.

help

Display list of recover program
commands.
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Table B-1 (continued)

72

recover Commands

Command

Description

list

List the files in the recover list.

ls -F filename

List filename with file type information.

ls -l filename

List filename using long format.

ls filename

List filename.

noforce

Do not overwrite existing files.

nsrwatch

Monitor NetWorker server activity.

pwd

Display name of current directory.

quit

Exit the recover program.

recover

Start the recover program when entered
at the system prompt; start the recovery
when entered at the recover> prompt.

recover -c client_name

Browse the index and recover files for
the specified client.

relocate dir

Specify new directory location for
recovered files.

save pathname

Starts a backup of the current directory,
or enter pathname.

verbose

Toggle verbose or quiet mode for recover
status messages.

versions filename

Display backup history of file filename.
filename can be either a file or a directory.

volumes filename

List volumes needed to recover marked
files. filename can be either a file or a
directory.

Appendix C

C.

Requirements for NetWorker Clients

For Silicon Graphics NetWorker clients to use the NetWorker server to back
up and recover files, clients must
•

be running IRIX 4.0.x or IRIX 5.x

•

have NetWorker client software installed (see the section “Installing
NetWorker Software on Clients” in Chapter 1)

•

be running the nsrexecd(1M) daemon (it is started automatically by inst
at installation time)

•

recognize the NetWorker server (see the section “Installing NetWorker
Software on Clients” in Chapter 1)

•

be recognized by the NetWorker server (the Clients window of the
networker(1M) command running on the server must list the client)

Individual licenses for NetWorker clients are not installed on the clients;
only the NetWorker server requires licenses.
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back up (v.)
To store the directories and files on your workstation onto tape or another
storage medium.
backup (n.)
A copy of the directories and files on your workstation on a tape or another
storage medium.
backup volume
Any type of storage media that your server can back up to: magnetic tape,
floppy disk, or optical disk.
collapse
Changing the view to display only the top level of a highlighted directory in
a window.
index
A database on the NetWorker server that contains an entry for every file
backed up.
expand
Changing the view to display all the levels of a directory in a window.
media device
The device that is attached to the NetWorker server for transferring and
recovering data that has been saved.
NetWorker client
All the systems on a network that back up and recover their data using
NetWorker.
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NetWorker server
The system that backs up all the other systems on a network according to a
schedule and maintains an online index of everything it backs up.
recover
To replace a lost file with a copy of it from the NetWorker server.
selection
The name of the volume, directory, or file highlighted in any window.
tree structure
A view that displays the contents in a window in a hierarchical form.
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Index

A
Administration pull-down menu, 6
authorized system, 52

B
backup
excluding files, 20
history, 54, 55
marking directories, 16, 19
marking files, 16
monitoring, 43
starting, 16, 47
unmarking files, 16
Backup command, 10
Backup completion message, 23, 50
Backup completion time, 50
backup device status, 43
Backup File Details, 39
backup media
location, 55
mounted, 55
Backup Options dialog box, 22, 47
Backup start time, 50
Backup Status window, 22
backup times, 40
Backup window, 11, 17
block device icons, 15
browse time, 57

browsing
filesystem, 16, 33
index, 26, 27
selecting level of, 33
button
More, 56
mouse, 12
Next, 58
Prev, 58
resize, 45
Today, 58
Update Server List, 46

C
calendar for Change browse time, 58
canceling
a backup, 50
a recover, 31, 66
Change browse time command, 58
Change Browse Time dialog box, 58
Change Client dialog box, 54
Change Polling command, 8
Change Polling dialog box, 8
Change Server command, 46
Change Server dialog box, 46
changing a selection, 41
changing the browse time, 57
changing the NetWorker server, 45
character device icons, 15
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Index

checkbox, 38
for marking files, 38
for unmarking files, 38
selecting, 19
versions, 56
choosing a recover client, 52
choosing a recover server, 52
Client pull-down menu, 53
client sessions, 45
clock cursor icon, 15
closing a window, 42
Collapse Branch command, 37
command
Backup, 10
Change browse time, 58
Change Polling, 8
Change Server, 46
Collapse Branch, 37
Expand Branch, 35
Expand One Level, 18, 34
File Details, 39
grayed out, 7
Mark, 20, 38
networker, 5
Recover, 26
Relocate, 61
save, 67
Search, 40
Show Marked, 59
Start Backup, 47
Start Recover, 30, 62
Topic, 9
Unmark, 21, 38
Volumes, 51
command table, 71
compressing files, 22, 47
Conflict Resolution dialog box, 30, 63
current directory, 41
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D
Devices display, 44
dialog box
Backup Options, 22, 47
Change Browse Time, 58
Change Client, 54
Change Polling, 8
Change Server, 46
Conflict Resolution, 30, 63
Filename Conflict, 63
Search, 40
directory display, 12, 18
display
Devices, 44
directory, 12, 53
file, 12, 53
Messages, 45
Pending, 24, 45
Server status, 44
Sessions, 45

E
error messages
backup, 67
backup and recover, 69
recover, 68
exiting from a window, 42
Expand Branch command, 35
Expand One Level command, 18, 27, 34
expanding directories, 18

F
field
Pattern, 49
Selection, 12, 41
Server, 46
file compression, 48
File Details command, 39
file display, 12
File pull-down menu, 7, 12
Filename Conflict dialog box, 63
files
compressing, 22
marking, 38
recovering deleted files, 57
searching for, 40
unmarking, 38
view past files, 57
Files Marked for Recovery window, 59
filesystem
marking files across, 69
sufficient space for recover, 68
folder icons, 13

H
Help button, 12
Help pull-down menu, 8
highlighted file icons, 14
highlighted folder icon, 14

I
icons
graphical, 13
index, 23, 26, 52
InSight manuals, xv, 3

installing software on clients, 2
invoking networker
pathname of directory, 18

M
Main window, 5, 16, 24, 44
Mark command, 20, 38
marking
directories, 16, 19, 38
files, 16, 38
files for recovery, 26
subdirectories, 20
media
unmounted, 25
volumes needed, 31
Menu bar (of Backup window), 12
Menu bar (of Main window), 44
Messages display, 45
monitoring
a backup, 22, 43, 49
a recover, 30, 65
recovers, 43
More button, 56
mount point icons, 14
mount points, 20
mouse buttons, 12

N
naming conflict, 30
NetWorker server
changing, 45
defined, 1
NetWorker version, xiii
nsrhost alias, 3
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Index

O

R

open folder icon, 13
Operation pull-down menu, 7

recover
files, deleted, 57
monitoring a, 43
preparing to, 52
Recover command, 26
recover commands
add, 71
cd, 71
changetime, 71
delete, 71
dest, 71
force, 71
help, 71
list, 72
ls, 72
noforce, 72
nsrwatch, 72
pwd, 72
quit, 72
recover, 72
relocate, 72
save, 72
verbose, 72
versions, 72
volumes, 72
Recover File Details, 39, 40
Recover Status window, 30, 65
Recover window, 52
reducing networker traffic, 48
reference pages, xiv
Release Notes, xiv
release number of NetWorker, xiii
Relocate command, 61
renaming or overwriting recovered files, 63
resize button, 45

P
Pattern field, 49
patterns
changing, 49
deleting, 49
excluding from a backup, 48, 49
Pending display, 24, 45
pending requests, 43
Polling interval bar, 8
product support, xv
pull-down menus
Administration, 6
Client, 53
File, 7, 12
Help, 8
how to use, 12
Operation, 7
Server, 52
View, 12, 18

Q
quick tour
backup, 15
recovery, 15
review, 32
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S
save command, 71
Save Sets scrolling list, 51
scrollbar, 15
scrolling list
Save Sets, 51
Topics, 9
Volumes, 51
Search command, 40
Search dialog box, 40
searching for files, 40
selecting versions of directories, 57
selecting versions of files, 54, 56
Selection field, 12, 41
server documentation, xiv
Server field, 46
Server pull-down menu, 52
Server status display, 44
Sessions display, 45
sheet icons, 14
shell pattern characters, 48
Show Marked command, 59
Start Backup command, 47
Start Recover command, 30, 62
starting
backup, 16
recovery, 30
subsystems for clients, 3
symbolic link icons, 14

T

Topics scrolling list, 9
tree structure, 27, 34

U
Unmark command, 21, 38
unmarking files, 16, 20, 38
Update Server List button, 46

V
version of NetWorker, xiii
Versions window, 54, 56, 57
View pull-down menu, 12, 18
viewing directories, 33
viewing files in the past, 57
Volumes command, 51
Volumes scrolling list, 51

W
windows
Backup, 11, 17
Backup Status, 22, 49
controls, 15
Files Marked for Recovery, 59
Main, 5, 16, 24, 44
Recover, 26, 52
Recover Status, 30, 65
Topics Help, 9
using NetWorker windows, 10
Versions, 54, 57

Topic command, 9
Topics Help window, 9
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