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Chapter 1

1.

Welcome to Indigo Magic MediaWarehouse

Welcome to Indigo Magic MediaWarehouse. This guide describes
MediaWarehouse and explains how to use it.

What Is MediaWarehouse?
MediaWarehouse is an easy-to-use desktop scrapbook that you can use to
store data objects on the desktop (see Figure 1-1). To copy a data object to
MediaWarehouse, just drag it to the warehouse and drop it there, or cut and
paste it. You can store objects such as an Inventor model or an audio clip.
MediaWarehouse is designed to make you more productive. Once you’ve
stored an object in MediaWarehouse, you can search for it by keyword or
data type, view it, and copy it from MediaWarehouse and paste it into other
applications.

Figure 1-1

Conceptual View of MediaWarehouse
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Contents of This Guide
As you continue reading this guide, you’ll learn the specifics about
MediaWarehouse. Topics covered include:
•

How to get started with MediaWarehouse and how to store and view
data objects. See Chapter 2, “Getting Started With MediaWarehouse.”

•

How to use MediaWarehouse menus, clipboard, and shelves. See
Chapter 3, “Using MediaWarehouse.”

•

How to tailor MediaWarehouse to suit your needs. See Chapter 4,
“Customizing MediaWarehouse.”

Using Online Documents
For task-oriented information on using MediaWarehouse, choose a topic
from the MediaWarehouse Help menu. For context-sensitive information on
a particular area or item in MediaWarehouse, choose “Click for Help” from
the Help menu, and then click on the area of interest.
To access online documentation, you can:
•

Choose “On-line Books” from the Help toolchest. The IRIS InSight
Document Library appears.
Once the Library is open, you can type a word or phrase and quickly
find and open the books that contain the information you need. See the
IRIS InSight online help for instructions.

•
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Type insight from a shell window or double-click the InSight icon.

Suggestions for Further Reading

Suggestions for Further Reading
Table 1-1 lists manuals from Silicon Graphics that contain information about
other topics and programs that may be of interest.
Table 1-1

Topics and Manuals

Topic

Manual

Clipboard and Data Exchange

Chapter 7, “Interapplication Data
Exchange,” Indigo Magic Desktop Integration
Guide

Data Conversion Service

Appendix G, “Using GoldenGate Data
Conversion Services,” Indigo Magic Desktop
Integration Guide

X Window System

X Toolkit Intrinsics Programming Manual
Xlib Programming Manual, Volume 1

These manuals are available online through IRIS InSight.

Conventions
Some style conventions make the information in this guide easy to access
and understand. The conventions are listed below.
•

Links to other sections and chapters in this guide appear in blue.
Links to applications, files, and reference pages appear in red.
Links to glossary definitions are underlined.

•

Names of menu choices and references to other sections and chapters in
this guide are in “quotation marks.”

•

Names of files and references to other documents appear in italics.
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Chapter 2

2.

Getting Started With MediaWarehouse

You can use MediaWarehouse to store and view data objects that you’ve
created with various applications. How can MediaWarehouse help you
become more productive? If you create objects with the Silicon Graphics
media and graphical tools, use MediaWarehouse to store the objects that you
access repeatedly. No need to open a separate application each time you
want to use an object; for easy access, you can store it in this small
warehouse. To edit the object, however, you must use the appropriate media
editing tool.
For example, you can store, view, and manipulate 3D models that you’ve
created with Inventor. MediaWarehouse has a built-in Inventor viewer, so
you can view and manipulate the 3D model in the warehouse the same way
that you view and manipulate it in SceneViewer or Annotator.
What else can you do with MediaWarehouse? Well, you can listen to audio
clips or view ImageVision images (IL formats).
For more information about MediaWarehouse, see the following topics:
•

“Starting MediaWarehouse”

•

“About the MediaWarehouse Window”

•

“Storing Data Objects on MediaWarehouse Shelves”

13
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Starting MediaWarehouse
You can start MediaWarehouse in one of several ways:
•

Type mediaw in a shell window.

•

Double-click the MediaWarehouse icon (see Figure 2-1).

Figure 2-1

•

MediaWarehouse Icon

Click the words MediaWarehouse.

Figure 2-2 shows the MediaWarehouse window.
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Starting MediaWarehouse

Figure 2-2

MediaWarehouse

Before continuing, let’s define a few terms:
•

The clipboard is a temporary storage place that’s used for data exchange.
When you select a data object to copy, cut, or paste, you place the object
on the X clipboard. An object on the clipboard typically remains there
until the next copy or cut operation. The clipboard is used by most
applications that have cut, copy, and paste menu items. For details on
the X clipboard and data exchange, see Chapter 7, “Interapplication
Data Exchange,” in the Indigo Magic Desktop Integration Guide.
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•

The terms import and export refer to the copying of objects. When you
copy an object to the warehouse, you import it. When you copy an
object from the warehouse to another application, you export it.

•

The term primary selection refers to a method of data exchange that’s
used by text-only applications that transfer data with single mouse
clicks.

•

The term string refers to any alphabetic, numeric, or special character.

About the MediaWarehouse Window
The components of the MediaWarehouse window, from the top to the
bottom of the screen, are listed in Table 2-1.
Table 2-1

MediaWarehouse Components

Component

Description

Main menu bar

Consists of the File, Edit, Shelf, and Help menus
(see “Using the Menus at the Top of the Screen”).

Viewer

Displays the selected data object
(see “MediaWarehouse Viewers”).

Shelves menu

Provides access to the shelves
(see “Using the Shelves Menu to Display Shelves”)

Storage shelves

Stores data objects
(see “Storing Data Objects on MediaWarehouse Shelves”
and “Using the MediaWarehouse Shelves”).

Types of Data Objects You Can Store
Once you’ve created a data object, you can store it in MediaWarehouse.
Some data objects you can store and view or play include:
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•

3D objects (Inventor 2.0, 2.1, and VRML)

•

HTML (hypertext markup language documents)

•

audio data (AIFF, AIFC, WAV, AU)

About the MediaWarehouse Window

•

IL images (IL formats)

•

X images (XPM, XBM)

•

text files

Figure 2-3 shows some of the objects that you can store in MediaWarehouse.

Figure 2-3

Some Objects You Can Store in MediaWarehouse

Note: MediaWarehouse can accept any type of object. Most applications,
however, can accept only certain types of objects. If you are unable to copy
an object from MediaWarehouse to an application, it may be because the
application doesn’t support the object’s type. Consult the application’s
documentation for supported types.

For information about the various ways you can copy data objects, see
“Moving Data Objects To and From MediaWarehouse.”

MediaWarehouse Viewers
MediaWarehouse has built-in viewers for many objects (see “Types of Data
Objects You Can Store” for the list). So, in addition to manipulating 3D
models, you can play audio files. Figure 2-4 shows the viewer displaying an
Inventor model, an X29 jet.
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Figure 2-4

An X29 Jet in the Viewer

Note: MediaWarehouse can display many types of objects, although only

those with installed viewers can be viewed inline. You can install new
viewers by adding some information to a warehouse file. For information
about adding viewers, see “Adding New Data Types.”

Storing Data Objects on MediaWarehouse Shelves
A MediaWarehouse shelf is a place for you to store data objects. This section
describes:
•

“Naming Shelves and Data Objects”

•

“Storing Objects Permanently”

•

“Linking Files and Directories”

When you add an object to MediaWarehouse, it is placed (in alphabetical
order) on a shelf. The object is represented on the shelf as an icon with a text
label.
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You can add, rename, and delete a shelf, as well as rename an object stored
on a shelf. For more information about shelves, see “Using the
MediaWarehouse Shelves.”
You may want to store all objects of one type on a shelf, such as all the
Inventor models you’ve created. Perhaps you name the shelf “_3Dmodels.”
Or, suppose you want to store objects related to a particular project on a
shelf—so you mix the types of objects on a shelf. The way you arrange and
store objects is up to you. Figure 2-5 shows a shelf with Inventor objects
stored on it.

Figure 2-5

A Shelf With the Same Type of Objects Stored on It

Naming Shelves and Data Objects
Names of shelves and objects must begin with an alphabetic character and
cannot contain punctuation characters or spaces. If you use a nonvalid
character, MediaWarehouse will create a valid name for you.
Also, shelf names must be unique (two shelves cannot have the same name),
and data objects on the same shelf must have unique names.
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Storing Objects Permanently
MediaWarehouse stores objects permanently, that is, when you exit
MediaWarehouse, the objects are saved permanently on the shelves (to disk).
However, objects don’t have to be permanently stored in MediaWarehouse;
they can be linked.

Linking Files and Directories
You can link one file or an entire directory, thus saving disk space. Only the
file’s name is saved in the MediaWarehouse database. When you link a file,
an “L” graphic appears to the left of its icon.
You can create links in the following ways:
•

Import a file by via the MediaWarehouse File menu or drag and drop its
icon from the desktop file manager (see “Linking a File”)

•

Drag and drop a directory from the desktop file manager (see “Linking
Directories”)

Linking Directories

The easiest way to create links is to link entire directories by using the
desktop file manager. To do this, select the directory icon in the desktop file
manager and drag and drop it to MediaWarehouse (for more information,
see “Using Drag and Drop”). A new shelf appears that contains links to each
of the files in the directory.
You can easily update linked directories. Just pull down the Shelf menu and
select “Refresh Shelf Links.” However, if you later rename (or delete) the file,
MediaWarehouse cannot access it.
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Linking a File

To link a single file:
1.

Pull down the File menu and select “Import Link.” The Import Link file
selection box appears from which you can select a file (see Figure 2-6).

2.

Select the file you wish to import and press OK.

Figure 2-6

Import File Selection Box

You can also link a single file by dragging and dropping it from the file
manager:
1.

Select the file you wish to link by pressing the middle mouse button.

1.

Drag the file into MediaWarehouse, press and hold the Shift-Control
keys, and release the mouse button.

Where to Go From Here
To learn about MediaWarehouse menus and different ways to copy objects
to and from the warehouse, see Chapter 3, “Using MediaWarehouse.” To
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learn about customizing and configuring MediaWarehouse, see Chapter 4,
“Customizing MediaWarehouse.”
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3.

Using MediaWarehouse

This chapter describes how to use the menus, move data objects, and use the
clipboard and shelves.
Specifically, this chapter explains:
•

“Using MediaWarehouse Menus”

•

“Moving Data Objects To and From MediaWarehouse”

•

“Using the MediaWarehouse Shelves”

•

“Renaming or Deleting Data Objects”

To start MediaWarehouse now, click the words MediaWarehouse. Figure 3-1
shows MediaWarehouse.
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Figure 3-1

MediaWarehouse Window

For information on other ways to start MediaWarehouse, see “Starting
MediaWarehouse.” For information on the types of data objects you can
store, see “Types of Data Objects You Can Store.”
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Using MediaWarehouse Menus
MediaWarehouse has a menu bar at the top of the screen (above the viewer)
and a Shelves option menu above the shelf storage area. For information
about these menus, see:
•

“Using the Menus at the Top of the Screen”

•

“Using the Shelves Menu to Display Shelves”

Using the Menus at the Top of the Screen
The MediaWarehouse menu bar, at the top of the screen, is shown in
Figure 3-2.

Figure 3-2

MediaWarehouse Menu Bar

To select an item from a menu, click the left mouse button on the menu, and
select the item of interest. MediaWarehouse menus are described below.
File Menu

Use the File menu to define preferences, import a file, import a linked file,
save the current state of MediaWarehouse, or exit the application. Figure 3-3
shows the File menu.
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Figure 3-3

The File Menu

For information about Preferences, see “Media Warehouse Preferences.” For
information about linking files, see “Linking Files and Directories.”
Edit Menu

Use the Edit menu to perform cut, copy, and paste operations, get
information about an object, and search for an object. For information about
copying and pasting, see “Moving Data Objects To and From
MediaWarehouse.”
Table 3-1 lists the Edit menu functions.
Table 3-1
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Edit Menu Functions

Menu Item

Description

Cut to Clipboard

Cuts (or deletes) the current selection to the clipboard.

Copy to Clipboard

Copies the current selection to the clipboard.

Paste from Clipboard

Pastes the current selection from the clipboard.

Copy to Primary
Selection

Copies the primary selection to the clipboard.

Paste from Primary
Selection

Pastes from the primary selection to the clipboard.

Using MediaWarehouse Menus

Table 3-1

Edit Menu Functions

Menu Item

Description

Object Info

Provides information about the current selection including
its type, name, and keyword(s) associated with it. You can
change the name of the object and keyword(s). Type the
new name and/or keywords, and press OK.

Delete Object

Deletes the object in the viewer.

Search

Searches for an object. Type the name of the object or
keyword(s), or both a name and keyword(s), and press OK.
If you use “and” in the keyword search, and you specify
both a name and some keywords, they all must match for
the search to be successful. If you use “or” in the keyword
search, you’ll get a match if the name or any of the
keywords matches.

Continue Search

Continues to search the warehouse database for the
specified object.

Figure 3-4 shows the Edit menu.

Figure 3-4

The Edit Menu
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Shelf Menu

Use the Shelf menu to add, rename, or delete a shelf. Table 3-2 lists Shelf
menu functions.
Table 3-2

Shelf Menu Functions

Menu Item

Description

New Shelf

Creates a new shelf named “new_shelf.”

Rename Current Shelf

Renames the current shelf. Type the new shelf name
and press OK.

Delete Current Shelf

Deletes the current shelf and its contents. Press OK to
delete the shelf.

Refresh Shelf Links

Updates a shelf created by linking a directory.

Figure 3-5 shows the Shelf menu.

Figure 3-5

28

The Shelf Menu

Using MediaWarehouse Menus

Help Menu

Use the Help menu for an overview of MediaWarehouse, for help on a
specific topic, for context-sensitive help, and product information. Figure 3-6
shows the Help menu.

Figure 3-6

The Help Menu

29

Chapter 3: Using MediaWarehouse

Keyboard Shortcuts

Many MediaWarehouse commands have a keyboard shortcut. Table 3-3 lists
the command shortcuts.
Table 3-3

Keyboard Shortcuts

Command

Keyboard Shortcut

Online help

F1

Click for help

Shift-F1

Close a dialog box

Escape

Save database

Control-S

Quit MediaWarehouse

Control-Q

Cut to clipboard

Control-X

Copy to clipboard

Control-C

Paste from clipboard

Control-V

Search

Control-R

Continue search

Control-N

Using the Shelves Menu to Display Shelves
You can display a shelf by using the Shelves menu, which is above the
storage shelf area. Just click the left mouse button on the Shelves menu and
select the desired shelf. Figure 3-7 shows the Shelves menu.

Figure 3-7
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Moving Data Objects To and From MediaWarehouse

You can also use the Shelf menu above the viewer to add, rename, or delete
a shelf (see “Shelf Menu” for information about this menu).

Moving Data Objects To and From MediaWarehouse
It’s easy to copy objects to and from MediaWarehouse (import and export
objects), and it’s easy to move objects from one shelf to another. Any X
application that supports drag and drop, cut and paste, and/or primary
selection transfer can serve as the source or destination of objects.
You can copy objects to and from MediaWarehouse by these methods:
•

“Using Drag and Drop”

•

“Using Cut and Paste”

•

“Using the Primary Selection”

Using Drag and Drop
You can drag and drop objects to and from MediaWarehouse just as you drag
and drop objects to and from many other applications.
To drag and drop an object into MediaWarehouse:
1.

Initiate the drag-and-drop action in the source application (typically by
pressing and holding the middle mouse button).

2.

Drag the object into the shelf area of the MediaWarehouse, and release
the mouse button.
The object, represented as an icon, is placed in alphabetical order on the
shelf. The object also appears in the viewer if its viewer is installed.

You can link a file by pressing and holding the Shift-Control keys as you
drop the file into MediaWarehouse. For more information, see “Linking Files
and Directories.”
Figure 3-8 shows an example of dragging and dropping an object.
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Figure 3-8

Dragging and Dropping an Object Into MediaWarehouse

To drag and drop an object from MediaWarehouse to an application (one
that supports drag and drop and the object’s type):
1.

Place the cursor over the object in the shelf area, and press and hold the
middle mouse button.

2.

Drag the object to the destination application, and release the mouse
button.

Using Cut and Paste
If your source application supports cut and paste, you can add a data object
to MediaWarehouse using that method.
To cut and paste an object into MediaWarehouse:
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1.

Initiate the “cut” or “copy” function (typically a menu item) in the
source application. This places the object on the X clipboard.

2.

Move the cursor to MediaWarehouse.

3.

Pull down the Edit menu and select “Paste from Clipboard.”

4.

A notifier appears asking you to select the import data type. Select the
appropriate type and press OK.

5.

A notifier appears asking you to type the name of the object and/or any
keyword(s). MediaWarehouse uses the name and keywords for
searching its database. Type the name and any keyword(s) you want
associated with the object and press OK.

6.

The object, represented as an icon, is placed in alphabetical order on the
shelf. The object also appears in the viewer, if its viewer is installed.
Figure 3-9 shows this procedure.

Figure 3-9

Cutting and Pasting an Object Into MediaWarehouse
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To cut and paste an object from MediaWarehouse to another application (one
that supports the clipboard and the object’s type):
1.

Select the object you want to copy by clicking on its icon in the shelf
area.

2.

Pull down the Edit menu and Select “Copy to Clipboard.”

3.

Move the cursor to the destination application, and paste it there.

Using the Primary Selection
You can use the primary selection entries on the Edit menu to copy
characters to and from MediaWarehouse.
To copy characters (such as text) to MediaWarehouse:
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1.

Place the cursor in the source application, window, or screen and select
the text by highlighting it (typically by pressing and holding the left
mouse button).

2.

Move the cursor to MediaWarehouse.

3.

Pull down the Edit menu and select “Paste from Primary Selection.”
The text appears in the viewer and an icon representing the object
appears on the shelf below. The icon is labeled with the first few
characters of the text you just pasted. Figure 3-10 shows this procedure.

Moving Data Objects To and From MediaWarehouse

Figure 3-10

Using Primary Selection to Copy Text to MediaWarehouse

To copy characters (such as text) from MediaWarehouse to another
application (one that supports primary-selection transfer):
1.

Select the object you want to copy by clicking on its icon in the shelf
area. The text appears in the viewer.

2.

Pull down the Edit menu and select “Copy to Primary Selection.”

3.

Move the cursor to the destination application, and press the middle
mouse button.
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Using the MediaWarehouse Shelves
When you copy a data object to MediaWarehouse and store it there, you
place the object on a shelf. You can add a new shelf, rename, and delete a
shelf, and move an object from one shelf to another. This section describes:
•

“Renaming Shelves”

•

“Creating Shelves”

•

“Deleting Shelves”

•

“Moving Data Objects Between Shelves”

Creating Shelves
You can add a new shelf by pulling down the Shelf menu and selecting
“New Shelf.” The new self is named “new_shelf” and is empty when it first
appears. To rename the shelf, see “Renaming Shelves.”

Renaming Shelves
You can rename a shelf by pulling down the Shelf menu and selecting
“Rename Current Shelf.” Just type the new shelf name and press OK.

Deleting Shelves
You can delete a shelf by pulling down the Shelf menu and selecting “Delete
Current Shelf.” You are asked if you want to delete the shelf, since the
deletion cannot be undone. To delete the shelf and its contents, press OK.

Moving Data Objects Between Shelves
To move an object from one shelf to another:
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1.

Select the object you wish to move by clicking on it. It appears in the
viewer.

2.

Pull down the Edit menu and select “Copy to Clipboard.”

Renaming or Deleting Data Objects

3.

Click the Shelves option menu and select the destination shelf.

4.

Pull down the Edit menu and select “Paste from Clipboard.”

5.

A notifier appears asking you to select the import data type. Select the
appropriate type. The object appears on its new shelf.

Renaming or Deleting Data Objects
You can rename or delete a data object on a shelf.

Renaming Data Objects
To rename an object:
1.

Move the cursor to the shelf area and select the object you want to
rename.

2.

Pull down the Edit menu and select “Object Info.”

3.

A notifier appears listing the type of object, and its name and keywords
(if any). Type the name of the object and any keywords you want
associated with the object and press OK. MediaWarehouse uses the
name and keywords for searching its database.

Deleting Data Objects
To delete an object:
1.

Move the cursor to the shelf area and select the object you want to
delete.

2.

Pull down the Edit menu and select “Delete Object.”

Where to Go From Here
To learn about tailoring MediaWarehouse for your particular environment,
see Chapter 4, “Customizing MediaWarehouse.”
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4.

Customizing MediaWarehouse

You can customize MediaWarehouse to suit your particular needs. For
example, you can add new viewers. Topics covered include:
•

“MediaWarehouse Reference Page”

•

“MediaWarehouse Command-Line Options”

•

“Media Warehouse Preferences”

•

“Adding New Data Types”

For information on starting MediaWarehouse, see Chapter 2, “Getting
Started With MediaWarehouse.” For information on using MediaWarehouse
menus, shelves, clipboard, and moving objects to and from
MediaWarehouse, see Chapter 3, “Using MediaWarehouse.”

MediaWarehouse Reference Page
The MediaWarehouse reference page, mediaw(1), has additional information
about MediaWarehouse. To view this page, click the word mediaw.

MediaWarehouse Command-Line Options
To start MediaWarehouse from the command line, type:
mediaw
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Table 4-1 lists the command-line option you can use with MediaWarehouse.
Table 4-1

MediaWarehouse Command-Line Options

Option

Description

–dbdir directory

Specifies the directory that MediaWarehouse uses for its
database files. The default is $(HOME)/.mediaw.

In addition, MediaWarehouse accepts all of the standard X Toolkit
command-line options. See the mediaw(1) reference page and the section
titled “Command-Line Options” in Chapter 3 of X Toolkit Intrinsics
Programming Manual for information about these options.

Media Warehouse Preferences
You can configure MediaWarehouse preferences. Pull down the File menu
and select “Preferences.” Two tab panels appear:
•

“Import Targets”

•

“New Objects”

Import Targets
The “Import Targets” panel displays the most recently received targets, and
allows you to set up preferred and ignored targets. Figure 4-1 shows the
“Import Targets” panel.

40

Media Warehouse Preferences

Figure 4-1

Import Targets Panel

In some cases, an application is able to export data in one of several data
types to the MediaWarehouse. By default, the MediaWarehouse displays a
dialog asking you which data type to use. You can change this setting with
the “Import Targets Configuration” panel.
The “Last Received Targets” rectangle at the top of the panel lists the most
recently received targets. The panel does not list icons that you drag and
drop from the desktop.
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You can drag and drop a target type (using the middle mouse button) to the
“Preferred Targets” or “Targets to Ignore” list.
The two rectangles at the bottom of the panel allow you to specify which
target types to use or ignore. If an import type appears on the “Preferred”
list, it is selected (items at the top of the list have precedence). The default
order of prefered targets appears when you first open the “Import Targets”
panel.
If the imported type does not appear on the list, the default selection dialog
box appears, and the “Targets to Ignore” are not shown.

New Objects
The “New Objects” panel allows you to set up the way you name imported
objects. By default, MediaWarehouse tries to determine the name of a data
object by examining its data.
Figure 4-2 shows the “New Objects” panel.
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Figure 4-2

New Objects Panel
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Table 4-2 lists the New Objects panel functions.
Table 4-2

New Objects Functions

Function

Description

When unknown

Tries to determine the name of a data object by examining the
data. If MediaWarehouse can’t determine a name, it prompts
you to specify a name and keyword(s).

Always

Always prompts you for a name.

Never

Determines a default name without prompting you.

To change the setting, click the left mouse button in the appropriate
diamond. Press OK to save your preferences. Press Cancel to ignore any
changes and reset the preferences to the last saved values.

Adding New Data Types
By default, MediaWarehouse can import and export data objects of any data
type. Currently, MediaWarehouse provides viewers and type-specific icons
for many data types. You can, however, add additional icons and viewers.
Configure new icons and viewers in the /usr/lib/mediaw/mediawrc file. The
mediawrc file specifies icons and viewers for numerous data types. To view
this file, click the word mediawrc.
The information that follows describes:
•

“Adding Icons”

•

“Adding Viewers”

Adding Icons
To add an icon for a new data type, just specify the icon in the mediawrc file.
Use this format:
target_type.iconPanelType: icon_type
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The target_type is the X Window System ICCCM selection target type
used by X application to identify this data type. You can usually find this
value in your application’s documentation.
The icon_type is the name of a File Typing Rules (FTR) file type. The icon
associated with that file type will be displayed. For instructions on adding
new FTR rules, see the ftr(1) reference page.
For example, by default, MediaWarehouse uses the following specification
to associate the AsciiTextFile icon with the STRING target type:
STRING.iconPanelType: AsciiTextFile

Adding Viewers
To add a viewer for a new data type, just specify the viewer in the mediawrc
file. Use this format:
target_type.viewer: viewer_DSO_name

The target_type is the target type. The viewer_DSO_name is the name of the
DSO containing the viewer procedures.
The DSO should provide these functions:
extern “C” {
void *create(Widget);
void view(void* handle,
Atom type, void* data, unsigned long length);
void hide(void* handle);
void destroy(void* handle);
};

For information about DSOs, see the DSO(5) reference page.
The create function should create the viewer using the specified widget as
its parent and return a handle to the viewer. The handle is passed as the first
argument to the other three functions.
The view function maps and views the data. It is called with an X atom
representing the selection target type, a pointer to the data, and the length of
the data.
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The hide and destroy functions are optional. If provided, they are called
when the viewer is unmapped and destroyed, respectively.
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