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Introduction to This Guide

This help system describes Site Manager, a World Wide Web site
management tool that provides revision control, link validation, and
hyperbolic link viewing for your Web sites.

What This Guide Contains
This guide contains the following chapters:
•

Chapter 1, “Getting Started With Site Manager”

•

Chapter 2, “Site Manager Tutorial”

•

Chapter 3, “Using Site Manager”

•

Chapter 4, “Site Manager Reference”

What You Should Know Before Reading This Guide
This guide assumes that you’re familiar with the Netscape® Navigator,
HTML, UNIX®, and the Silicon Graphics® desktop.
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Introduction to This Guide

Conventions Used in This Guide
Below are the typographical and graphic conventions used in this guide:

x

•

Bold—Functions, option flags, and classes.

•

Italics—Filenames, button names, variables, emphasis, glossary terms,
and IRIX commands.

•

Regular—Menu and window names, data types, keywords, and text.

•

Fixed-width—Code examples and command syntax.

•

Bold fixed-width—User input.

Chapter 1

1.Getting Started With Site Manager

Site Manager is a Web site management tool that provides you with tools for Web-page
source revision control, link and HTML validation, VRML validation, server log file
analysis, and 3D site visualization. See the following topics to get up and running with
Site Manager as quickly as possible:
•

“About the Site Manager Windows”

•

“Finding Your Way Around the Site View”

•

“About the Link View”

In addition to the online help, you can also find information about the Site Manager in
the following documents:
•

Release notes

•

Man pages, which include sitemgr(1), sitestat.cgi(1), smdbf.cgi(1), sitemgr.cgi(1),
and smcmd(1)

About the Site Manager Windows
Site Manager consists of the Site View and the Link View.
You perform most of your operations through the Site View, including link validation,
checking Web pages in and out of the source control area, and previewing your files.
Take a look at Figure 1-1 to see the Site View.
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Figure 1-1

Site View

The Link View (Figure 1-2) displays the hyperlinked structure of your Web site, which is
how a visitor to your site will experience it. This may look quite different from the
directory structure of the server’s filesystem that you see in the Site View.
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Figure 1-2

Link View

You can navigate through the three-dimensional Link View and choose which Web pages
and links to display. The color of the nodes that represent Web documents tells you their
file type, and the color of the links shows whether they’re coming into or going out of a
document. (The node colors change when you use the statistics visualization
functionality; see “Statistics Visualization” for more information.)
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The Link View shows the site in a special kind of 3D space called “hyperbolic space,”
where the documents and links move so that you can see the context surrounding the
document that’s the current focus of your attention. Figure 1-2 shows the Link View
looking onto a small Web site.

Finding Your Way Around the Site View
The Site View of Site Manager is divided into three areas:
•

The site control area contains the controls for selecting and updating a site (see “Site
Controls” for more information).

•

The Site Display Pane in the top half of the window shows a modified directory
view of the files in your site (see “Site Display Pane”).

•

The Site Action Pane in the bottom half of the window lets you view information
about the site itself (or particular files on the site) and perform actions on the site or
files on the site (see “Site Action Pane” ).

You can resize the panes by clicking and dragging the pane divider button, located to the
bottom and right of the site display pane. You’ll know you’re in the right spot when your
cursor changes from an arrow to a cross.

Site Display Pane
The top half of the Site View contains the site display pane. This pane shows you
information about your Web site, including a list of the files and directories. The display
pane is where you select files to be moved, renamed, checked in and out, and so on. You
can use the controls to the left of the pane to change the size of the information displayed
and increase or decrease the level of directory depth shown.
See “Site Display Pane” for details on all the items in the site display pane.

Site Action Pane
The Site Action pane is a tabbed deck that provides you with quick access to five panels:
“Preview Panel,” “Revision Info Panel,” “Link Info Panel,” “Validate Panel,” and
“Statistics Panel.” To select a panel, click the appropriate tab.
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Select a file and click a tab to perform that panel’s function. For example, when you select
a file and click the Link Info tab, Site Manager retrieves the incoming and outgoing link
information associated with that file.
Tip: You can also double-click a file to perform the current panel’s function.

See “Site Action Pane” for details on all the items in the Site Action pane.

About the Link View
The Link View (see Figure 1-2), available by choosing Views > Link View of Site, displays
the structure of your Web site from a visitor’s point of view. Web users move from one
document to another through hyperlinks. Their possible paths may have little in
common with the directory structure of the files that you can see in the traditional
two-dimensional layout in the Site View.
The Link View displays nodes and links. Web documents such as HTML pages, images,
MPEGs, or VRML files are the nodes (shown as cubes). Each of these documents can be
found in the directory structure shown in the Site View. Links are a visual representation
of the hyperlinks between documents. They are drawn as colored lines in the Link View
and do not directly appear in the Site View.
Link View allows you to navigate in 3D hyperbolic space. Nodes near the center of the
sphere look big but are drawn smaller and smaller as they move out towards the surface
of the sphere. This distortion allows you to see much more of your site at one time than
you could see in the traditional 2D directory browser in the Site View.
Link View starts up with what it considers the root node of the Web site at the center of
the sphere. Descendents of the root node are displayed to the right.
Note: The default root node in the Link View is the entire site—for example

"http://hyper.foo.com"—as specified in the Server/Location text box in the “Site
Manager Initialization and Update Dialogs.” You can choose to see the hyperlink
structure of your site starting from a specific document by selecting that node in the Link
View and choosing Selected > Set As Root Node in the Link View menu.
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2.Site Manager Tutorial

Follow one of the links below to see the Site Manager tutorial that interests you:
•

“Typical Site Manager Tasks”

•

“Link View Tutorial”

Typical Site Manager Tasks
Want to get up, running, and using Site Manager as quickly as possible? Try following
the tutorial below in the Site View. (If you want to perform a specific task, try selecting it
from the Help menu. To view a list of all the help topics available, choose Help > Index.)
For a description of the different parts of the interface, see the “Site View” help topic.
1.

Select a site. In the Web Site Location text field, enter the WWW site you want to
administer (such as http://www.foo.com), or a portion of a WWW site (such as
http://www.foo.com/my_directory) and press Enter or click the Load Web Site
button. (This site must have the proper Site Manager server software installed. See
“Setting Up Your Site Manager Server.”) The resulting view of the site will look
similar to a standard desktop directory view.
Note: If you have a configuration that uses separate servers running on the same

system but uses different port numbers, make sure you enter the exact server
instance (port number included) into the Web Site Location text field.
2. Select the Web pages in the site display area on which you want perform certain
functions. See “Selecting Files and Directories.”
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3. Preview a file using the built-in browser. A tabbed deck appears at the bottom of
the Site View.
■

If the Preview tab is on top of the tabbed deck, double-click a file to preview it.

■

If the Preview tab is not on top of the tabbed deck, select a file, then click the
Preview tab. The file appears in the Preview window.

You can select a different browser by clicking the Preview/Use Browser checkbox in
the Preview panel.
4. Use the action buttons at the bottom of the site display pane or the items in the
Selected menu to manipulate files on the site. (Press the right mouse button to see
the list available through the Selected menu.)
5. Edit or check out a file by selecting it and clicking Edit or Check Out (or by choosing
them from the menu). You will be prompted for a location to place the file on your
local machine; this is known as your work area. In general, it’s best to establish one
area on your machine for this purpose. You can designate this default area by
choosing Options > Preferences. The default location is $HOME/sitemgr_wa.
Note: By default, Site Manager launches Cosmo Create to edit HTML files.

6. Check a file in to the site after editing. Select the file by clicking it, and then click
the Check In... action button (or choose Selected > Check In in the menu bar). You are
prompted for certain information, the file is uploaded to the designated site at the
designated location, and the lock is removed.
7. Create a new file.
■

Select a directory in which you want to create the new file.

■

Choose Selected > New Document > From Existing Local File or Create Copy
from Template. See “Checking in New Files” for details.

8. Publish a file. Drag it from your desktop directory view into one of the directories
in the site display area.
9. Remove a file. Select the file and click the Remove button. You are prompted for
verification of the removal from the site.
10. Validate files on your site. Select the file(s) you wish to validate and click the
Validate button. In the Validate panel, you can also drag a file (or set of files) from
the view of the site into the Validation drop pocket; this triggers the validation.
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Link View Tutorial

11. View a 3D representation of your site’s hyperlink structure. Choose Views > Link
View of Site... in the menu bar. You will see a visual representation of the hyperlink
structure of your site in 3D hyperbolic space. Note that the Site View and the Link
View present your site data in two very different formats and that you can interact
with one view and see the results in both views. For example, notice that when you
select a document in the Link View, it also becomes selected in the Site View and
vice versa.
12. Perform statistical analysis of the traffic on your site. Web servers keep track of
traffic at the site through various log files. You can view the information contained
in the log files by clicking the Statistics tab. Click Color in Linkview to see the nodes
color-coded according to site traffic, or click Animate in Linkview to see a dynamic
hit-by-hit animation. See “Generating and Viewing Statistics About Your Web Site”
for more information.
For further getting started information, see “Finding Your Way Around the Site View”
and “About the Link View.”

Link View Tutorial
Try any or all of these tasks to familiarize yourself with Link View:
•

Select a node by clicking it. Use the left mouse button to click a node. Notice that
the whole structure moves so that the node you selected ends up at the center of the
sphere. Your selected node is now large, while the node that was at the center has
moved outward and looks smaller. You can also see that the Site View has changed
so that the new node is selected and moved to the center of the display pane.
Selecting a node in the Site View similarly updates the Link View—the node
becomes selected and moves to the center of the Link View.

•

Show different types of links. By default, only the “main” link to each node is
drawn. Most Web sites are so interlinked that it would be hard to see anything if all
the links were drawn at once. You can show the other incoming or outgoing links
for a particular node by choosing Selected > Indirect Links > Outgoing or Incoming
> Show. Some nodes might not have any other links besides the main one, while
others may be very richly connected. Nodes like a logo image are likely to have
large numbers of incoming links, while a table of contents or index document is
likely to have many outgoing links.
You can also hide links by choosing Selected > Indirect Links > Outgoing or
Incoming > Hide. Experiment with showing and hiding links to reveal the overall
structure of your Web site.
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•

Perform other Site Manager functions. The following functions are also available
through the Selected menu: preview, revision info, link info, and validate. The
results of these actions appear in the Site View.

For details about all the controls available in the Link View, see the “Link View” reference
help card.
Note: If you are running Site Manager remotely (in other words, if you logged in to a

remote system and launched Site Manager), Link View performance will be extremely
slow. Because the Link View requires interactive 3D graphics, it will run much faster
when launched from your local system.
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3.Using Site Manager

This chapter tells you how to use Site Manager to check files in and out, preview Web
pages, view links, and perform other tasks. Follow the appropriate link to your area of
interest:
•

“Administering Site Manager”

•

“Using the Site View”

•

“Using the Link View”

•

“Troubleshooting and Advanced Tips”

Administering Site Manager
This section covers the following topics:
•

“Setting Up Your Site Manager Server”

•

“Initializing the Site Database”

•

“Updating the Site Database”

•

“About Version Control”

Setting Up Your Site Manager Server
Site Manager is designed to let a number of users access Web site files on a system that
acts as the Site Manager server. Usually, a system administrator configures this server.
Learn about:
•

“Preparing Your Server”

•

“Installing and Finding Software on the Server”

•

“Customizing Server Files”
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•

“Partitioning a Large Site”

•

“Configuring a Secure Server”

Once the Site Manager server software is installed, use the client software to initialize the
database on the Site Manager server. See “Initializing the Site Database” and “Updating
the Site Database” for details.
Preparing Your Server

Before you install the server software on your system, you should read the following
sections.
Must read:

•

“Installing and Finding Software on the Server”

•

“Configuring a Secure Server”

Security is very important and effects the installation and usage of Site Manager.
Nice to read:

•

“Partitioning a Large Site”

•

“Customizing Server Files”

Site Manager works well with sites sized up to 25,000-30,000 documents (“documents”
refers to servable objects in the document root). If your site is unusually large, make sure
you read about partitioning.
If you plan to use templates for HTML or other document types, you will want to read
about how you can customize server files.
Other reference:
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•

The Site Manager release notes contain useful information about administering
your Site Manager server.

•

The man pages list command-line options for Site Manager. See sitemgr(1),
sitestat.cgi(1), smdbf.cgi(1), sitemgr.cgi(1), and smcmd(1). A description of the CGI
processes appears in “Installing and Finding Software on the Server.”

Administering Site Manager

Installing and Finding Software on the Server

This section covers just the software you need to run Site Manager on your server. The
system you use as the Site Manager server should be the system that also acts as the Web
site server. Software pre-requisites include:
•

Web server software like Netscape FastTrack Personal Server or Apache.

•

RCS if you want to use version control with Site Manager.

•

Perl if you want to use Site Manager’s printing, link-checking and HTML/VRML
validation features.

Minimally, you need the following subsystems on the Site Manager server:
•

SiteMgr Base Software (sitemgr.sw.base)

•

SiteMgr Server Extensions (sitemgr.sw.server)

The client software makes it easy to perform some administrative tasks (like initializing
and updating the database), so you should also install:
•

SiteMgr Client Software (sitemgr.sw.client)

You may want to install the other subsystems. See the Site Manager release notes for a
full list.
The server extensions are three CGI scripts, located in /usr/sitemgr/bin:
•

sitemgr.cgi handles requests from the Site Manager client

•

sitestat.cgi retrieves statistical data

•

smdbf.cgi creates and maintains the database

For security purposes, you can tag the CGI scripts with a different password. See the
section on Security and SiteMgr in Chapter 2 of the release notes for details.
These CGI processes are also symbolically linked in /var/www/cgi-bin/. If your Web server
software uses a different pathname, you’ll need to add the following symbolic links:
# cd <default_HTTP_server_CGI_directory>
# ln -s /usr/sitemgr/bin/sitemgr.cgi

.

# ln -s /usr/sitemgr/bin/sitestat.cgi .
# ln -s /usr/sitemgr/bin/smdbf.cgi

.
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The FastTrack server uses /var/www/cgi-bin, so you won’t need to make symbolic links if
you are using this server.
Also in /usr/sitemgr/bin , you’ll find the following utilities:
•

smcmd—You can use this command-line client program for certain adminstrative
tasks. For example, you could create a script to automatically publish sets of
documents to your Web site. See the smcmd(1) man page for details.

•

html2ps—Site Manager uses this to print documents displayed in the Preview
window.

•

smgeturl—html2ps uses this utility to include graphics for printing.

•

vrmllint—Site Manager uses this to check links in VRML files. If you have another
version of vrmllint installed in /usr/local/bin/, Site Manager will use that version
instead.
Note: vrmllint only works with VRML 1.0.

•

weblint—Site Manager uses this to check links in HTML files. If you have another
version of weblint installed in /usr/local/bin/, Site Manager will use that version
instead.

•

webping—Site Manager uses this when it validates external site links.

Customizing Server Files

You can find Site Manager document template files in /docroot/.sitemgr/, where docroot is
the pathname of the top-level directory that Site Manager recognizes as your Web site.
For example, /var/www/htdocs/. See “Creating and Editing Document Templates.”
Partitioning a Large Site

If your site contains over 25,000 servable objects (HTML, VRML, images, media, and so
on), Site Manager may stall during initialization of its database.
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To partition your site:
1.

Plan a logical way to use existing directories or to add new ones. For example, a
marketing Web site might have a hierarchy of directories organized by product.
Each of these directories will be the new top-level for a Site Manager database.

2. Initialize a database for each new top-level directory. See “Initializing the Site
Database.”
3. If you want, set up new security access for these directories.
Configuring a Secure Server

We strongly recommend that you provide a secure server environment for Site Manager.
Why? Because after a client initializes the database (see “Initializing the Site Database”),
anyone with Web access to the Site Manager http server can write to your site. You
should configure your server’s authorization features so that password protection and
domain restrictions apply.
For instructions on setting up a secure server for Site Manager, see the section on
“Security and SiteMgr” in Chapter 2 of the release notes. Also see the paragraph on file
permissions in “Important Notes for the Site Administrator.” For additional information,
refer to your httpd server documentation.
Note: If you are using FastTrack server version 2.0P for IRIX 6.5, see “Important Notes

for the Site Administrator” for compatibility issues.

Initializing the Site Database
The Site Manager server (the system hosting the Web site) uses a database to track all the
requests made by you and other people in your workgroup. The first time you use Site
Manager, you need to initialize the database so that the server recognizes you as a user
and can keep track of your workflow (getting files, updating files, using version control,
and so on).
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To initialize the site database:
1.

Enter the server name in the Web Site Location text field and press Enter or click
the Load Web Site button. You see the “Site Manager Initialization and Update
Dialogs,” shown in Figure 3-1.
You can build a database that is a subset of the document root’s available
documents; just enter the URL for the subdirectory that you want to be an
independent database in the Server location text field. For example, if the root of the
entire site is http://www.fiddle.com, but you want BigDeal to have its own
“sub-site,” enter http://www.fiddle.com/BigDeal in the text field. If you decide
to set up sub-sites, also see “General Tips.”
Note: If the dialog doesn’t appear, verify that the Site Manager server software is

installed on the Web server system.

Figure 3-1
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Server Setup Dialog
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2. If the setup information is correct, click Initialize Database. If not, change the setup
information to the correct values, then click Initialize Database. (See “Site Manager
Initialization and Update Dialogs” to learn what information each text field
requires.)
3. Click OK in the SiteMgr Information dialog box that appears.
Note: By default, version control is enabled. If your site does not have a version control

system in place, you may wish to disable version control. For a full discussion of the
issues, see “About Version Control.”
The Site Manager database configuration takes a few minutes. When it is completed, Site
Manager sends you an e-mail confirmation. Until that message is received, you cannot
use Site Manager to interact with your site. If you try to load your Web site during
initialization, a dialog prompts you to wait and displays how many documents have
been processed so far.

Updating the Site Database
It is important to update your site database if you or the system administrator has
manually updated files (that is, not used Site Manager to change or remove files) on the
server that hosts the Web site.
To update the database manually, choose Views > Update Site Information, verify that
the information displayed in the dialog is correct, and click Update Database. For more
information, see “Site Manager Initialization and Update Dialogs.”
See also “Initializing the Site Database.” This topic describes the site database in more
detail.

About Version Control
Site Manager is configured to work with the RCS version control system for file checkin,
checkout, locking, and so on. To enable or disable version control in Site Manager, you
must click the Version Control checkbox in the “Site Manager Initialization and Update
Dialogs.” (It is selected by default.)
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If you enable version control in Site Manager during the database initialization process,
RCS files are read, utilized, and created (if no version control files exist for the HTML,
VRML, graphics, and other files on your site). Enabling version control allows you to
keep track of the history of your files, provides locking capabilities so that users don’t
overwrite each other’s files, allows you to check out older versions of files, and compares
new to old versions of files (often referred to as a “diff”).
If you have RCS on your server and elect to use Site Manager’s version control tools:
•

Existing version control locks are displayed (using a lock icon) in Site Manager.

•

A lock created through Site Manager causes an RCS-style lock on the Site Manager
server; HTML, VRML, text, and other files are tracked and locked via RCS, while
others are soft-locked via the database.

•

Users can view source history logs (which contain version numbers, checkin
comments, and so on), perform diffs, and get earlier revision of documents in the
“Revision Info Panel.”

•

Some button labels in the Site View are different; see “Action Buttons” for more
details.

Note: If you decide to use Site Manager’s version control tools, you need to install RCS.

On IRIX 6.2 systems, you can install the subsystem eoe.sw.rcs from your IRIX 6.2 part 1
of 2 CD. On IRIX 6.3 or 6.4 systems, you can install eoe.sw.rcs from your IRIX 6.3 or 6.4
CD. On IRIX 6.5, eoe.sw.rcs is on the IRIX Foundation 1 CD.
If you elect not to enable version control in Site Manager:
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•

Existing RCS locks of all type are completely ignored (you can overwrite files and so
on) and are not displayed in Site Manager, regardless of the existence of a potential
RCS-style lock from another tool.

•

RCS history files are not used or examined in any way. You cannot view any RCS
logs, perform diffs or get earlier revisions of documents in the Revision Info Panel.

•

You are not alerted if a document is locked by another tool or user.

•

Some button labels in the Site View change when you don’t use source control; see
“Action Buttons” for more details.

Using the Site View

Disabling version control in Site Manager has a couple of advantages: it makes creating
and updating the database quicker and more efficient, and it doesn’t put RCS files in your
directories when you may not want them. Users of Site Manager who have extremely
small sites, have no desire to track the revision history of their documents, or are their
site’s only publisher may not require version control.

Using the Site View
Site Manager helps you control the rampaging, wild, out-of-control party that is Web site
administration. Need to validate links? Check files into and out of your source control
area? Edit and preview your Web pages? All this, and so much more, is available to you
through Site Manager.

Accessing and Displaying Web Site Information
Site Manager has two views, the Site View and the Link View. The top half of the Site
View contains the Site Display pane. This pane shows you all the information about your
Web site, including a list of the files and directories. The Display pane is where you select
files to be moved, renamed, checked in and out, and so on.
Note: Site Manager does note display empty directories or directories that contain only

version control information.
Setting the Web Site Location

A Web site must be Site Manager enabled before you can access it through Site Manager
(see “Setting Up Your Site Manager Server” for details). Once a site is enabled, you just
need to point Site Manager to it to access and manipulate its database of information.
Follow these steps:
1.

Enter the URL of the Web site in the Web Site Location text field.

2. Press Enter or click the Load Web Site button.
A directory view of the site appears in the “Site Display Pane.” Also in the directory
view:
•

A small, red circle icon appears next to any document with broken links.

•

A small lock icon appears next to documents that are locked using version control.
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If you want to access a Site Manager-enabled server outside your local network firewall,
you need to run Site Manager from the command line with the -web option. Enter the
following command:
% /usr/sbin/sitemgr -web

Displaying Your Work Area

To display the contents of your work area (the directory where the files you have checked
out of the source tree are placed while you work on them), choose Session > Show
Workarea. Site Manager launches a Directory View display of your work area.
Tip: Suppose you checked out a file and now want to find it quickly in your work area.

Select that file in the Site View (if it’s not already selected), and choose Selected > Find in
Workarea.
To define your work area, choose Options > Preferences. If you haven’t defined a work
area, Site Manager creates one for you in $HOME/sitemgr_wa.
Note: Empty directories, or directories that contain only version control information, are

not displayed in Site Manager. You won’t be able to check these items out and display
them in your work area.
Updating the View

If you have multiple people making changes to a particular site and suspect that authors
have published new documents, or if you want to point Site Manager at a different Web
site, you must update your site view:
1.

Enter the URL of the site in the Web Site Location text field. If you have accessed
the site in the past, you can use the Site Selection button (see “Site Controls”) to
choose the site from the list of sites you have accessed. (If you are updating your
current site rather than accessing a new one, you can skip this step.)

2. Click the Load Web Site button.
The new information is displayed in the Site Display area.
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Using the Site View Controls

The Site View contains four controls that affect how the list of files is displayed. These
controls include the thumb wheel and buttons to the left of the directory view area. (For
more information on the controls, see “Site Controls.”) You can manipulate the site
directory view in the following ways:
•

Size: You can adjust the size of the files, folders, and their accompanying
information by clicking and dragging the thumb wheel. To return to the default
size, click the small, square button immediately below the thumbwheel.

•

Expansion: You can expand or collapse the directory hierarchy. By default, Site
View shows only the top level of directories and files. The down arrow opens all the
directories to reveal all the files beneath them. The up arrow collapses the directory
hierarchy and shows only the top level of directories and files. You can also
double-click a directory to collapse or expand it.

Generating and Viewing Statistics About Your Web Site

To generate and view statistics about your Web site, click the Statistics tab in the Action
pane. You can also choose Selected > Statistics from the menu bar.
By default, the statistics are generated from the access logs for your Web site. You can also
view statistics based on the Error, Agent, or Referrer logs (see “Log File Descriptions” ).
Just choose the appropriate menu button item, and the statistics are automatically
updated in the Action pane. (See “Statistics Panel” for more information on those
buttons.)
You can choose to graphically view the statistics. The Link View window can display
this information as a dynamic animation or as a single, aggregate overview.
To see a visual playback of your logs:
1.

Click the Statistics tab in Site View.

2. Click Animate in Linkview.
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3. Choose your animation preferences in the Stats Play dialog that appears.
View follows traffic moves each node that is “hit” in the statistics animation to the
center of the sphere, so you can see where activity is occurring. This is useful if you
have a large site where you might not be able to see all the nodes hit during the
animation. If you don’t select this option, you have manual control over your
viewpoint, which is useful if you want to focus your attention on a particular part of
your site. (Manual control means that you can click nodes as the animation plays, or
drag the sphere to see a different section up close.) You can toggle this option on or
off at any time during the animation playback.
Persistent trails retains the link path highlighting between nodes that occurs during
the statistics playback. Turn this option on if you want to see a visual trail of activity
once the animation is complete.
4. Click Play.
The animation shows traffic to your site by color coding both nodes and links. At
the beginning of the animation, all nodes are gray. When a document is hit, its node
briefly flashes yellow before becoming redder. If the traffic came from another
document within your site, you will also see the originating node and the path
between that source and the destination node flash yellow, like a laser beam. If you
want these trails to remain yellow, make sure you choose Persistent trails (see step 3).
Also see “Statistics Visualization.”
To see a static, graphical representation of your logs:
1.

Click the Statistics tab in Site View.

2. Click Color in Linkview.
This shows an overview of the log data where each node is colored according to the
number of hits it received. Nodes with many hits are red, and those with few hits
are gray. This coloring shows the combined hits over a period of time.
To revert to the original Link View color scheme, click the Reset Color button.
For more information on how the Link View changes when you use it to display
statistics, see “Statistics Visualization.”
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Printing a List of the Site Contents

The Site Manager print function allows you to print a directory listing of the site. To print:
1.

Choose Session > Print.

2. Select what you want to print from the menu choices. You can print either the
visible site outline (what is currently being displayed) or the entire site outline,
which prints an expanded list of all directories including their files and
sub-directories.
3. Designate the appropriate printer in the dialog.
See also “Printing a File.”
Printing a File

If you want to print one of your Web pages:
1.

In the Site View, select the file you want to print.

2. Click the Preview tab if the its window is not visible.
3. Click Print Document.
Note: If you are not using Site Manager’s built-in preview, you’ll need to use your

specified browser’s print function.
See also:
•

“Previewing Using Other Browsers”

•

“Printing a List of the Site Contents”

Manipulating Files
Site Manager provides you with a number of revision control, editing, and validation
functions. Learn about:
•

“Selecting Files and Directories”

•

“Moving Files With Drag-and-Drop”

•

“Getting Info on a File”

•

“Checking Files Into and Out of the Source Repository”
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•

“Checking in New Files”

•

“Checking Out Older Versions of Files”

•

“Locking and Unlocking Files”

•

“Renaming Files or Directories”

•

“Removing Files”

•

“Editing Files”

•

“Creating and Editing Document Templates”

•

“Validating Files”

•

“Finding and Replacing Text”

Selecting Files and Directories

The Site Display pane in Site Manager functions in much the same way as your desktop’s
Directory View. You can select files or directories, or sweep-select multiple combinations
of files and/or directories.
To select a single file or directory, move the mouse cursor to the icon and click the left
mouse button.
To select multiple items (this is also known as a “sweep-select”):
1.

Place your cursor just to the right of the first file you want to select.

2. Click the left mouse button and drag the cursor to the last file you want to select.
See also:
•

“Site Display Pane”

•

“Selecting Nodes and Subtrees”

Note: Site Manager doesn’t display empty directories or directories that contain only

version control information.
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Moving Files With Drag-and-Drop

You can move files from one directory to another in Site View by using the desktop
drag-and-drop functionality:
1.

Select the file you want to move.

2. Click and hold the left mouse button.
3. Drag the file to the icon of the directory in which you want it to appear.
4. Release the right mouse button.
Site Manager automatically updates relative hyperlinks when you move a document.
Getting Info on a File

To display the source control history or link information for a selected document, choose
Selected > Revision Info or Selected > Link Info.
Note: You can get information on only one file at a time. If you have multiple files
selected, information appears for only the selected file listed first in the Site View.

Also see:
•

“Link Info Panel”

•

“Revision Info Panel”

•

“Selecting Files and Directories”

Checking Files Into and Out of the Source Repository

The source repository for Site Manager exists on the Site Manager server. You check files
out from the server for editing, and these files are placed in your work area (the default
is $HOME/sitemgr_wa) on the client machine (your system). When you check the files
back in, they are copied from your work area back to the server system.
To check files into or out of the source repository:
1.

Select the file or files to be checked in or out. (See “Selecting Files and Directories”
for information on how to select files.)

2. Click the Check In or Check Out button. You can also choose Selected > Check
In/Out in the menu bar.

25

Chapter 3: Using Site Manager

By default, the file that is checked out is the most recently checked-in version of the file.
To check out an earlier version of your file, see “Checking Out Older Versions of Files.”
To check in a new file that has been created outside of Site Manager, or to create a space
for a new file to edit in the source repository, see “Checking in New Files.”
Site Manager creates a source archive in a directory on the server system called RCS for
each directory in the document_root tree. Files are retrieved from the designated WWW
site, locked, and written to the work area on your system, preserving the directory
structure from which it came. Site Manager tracks where this file is placed.
Note:

•

If you move (or remove) this file to a different location, that information will be lost,
and subsequent edit operations may not be available from within Site Manager. The
file may still be in a locked state. To unlock a file, select it and choose Selected >
Unlock Document.

•

Empty directories, or directories that contain only version control information but
not HTML, VRML, graphics, or other kinds of files, are not displayed in Site
Manager.

Checking in New Files

To check in a new file (a file that has been created outside of Site Manager):
1.

Select a directory in the Site View in which you want the file to reside.

2. Choose Selected > New Document > From Existing Local File.
3. In the “Check In Dialog,” enter a filename in the Local Filename and Publish To text
fields, or click the Browse... button and use the file manager to select a filename.
4. Click OK.
To create a new document based on a Site Manager template:
1.

Select a directory in the Site View in which you want the file to reside.

2. Choose Selected > New Document > Create Copy from Template.
3. In the “Copy Prompt Dialog,” replace doc_new.html with a more appropriate
filename and check an appropriate radio dial.
4. Click OK.
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See also “Creating and Editing Document Templates.”
Checking Out Older Versions of Files

You can use the Revision Info panel to check out older versions of your Web pages from
the source tree. To check out a particular version:
1.

Select the file that you want to check out a version of. (See “Selecting Files and
Directories” for information on how to select files.)

2. Click the Revision Info tab. You can also choose Selected > Revision Info from the
menu bar.
3. In the Revision Info panel, click the version of the file that you want to check out.
Click the Preview or Show Differences buttons to help you determine which version of
the file is the one you want. Show Differences displays the differences between the
selected version and the latest version of the file.
4. Click the Get Copy... button. A confirmation dialog pops up. If it lists the version of
the file you want to check out, click OK.
Locking and Unlocking Files

If you are using version control, this feature automatically locks and unlocks files when
you check them in and out from the server. You may want to manually lock or unlock a
file in the following circumstances:
•

You’re not using version control and you don’t want other people in your
workgroup to make changes to a particular file you’re working on.

•

You are using version control, but you need to override the locking scheme.

To lock or unlock a file:
1.

Select the file or files to be locked or unlocked. (See “Selecting Files and Directories”
for information on how to select files.)

2. Choose Selected > Lock Documents or Selected > Unlock Documents from the
menu.
Also see “About Version Control.”
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Renaming Files or Directories

To rename a file or directory:
1.

Select the file or directory to be renamed. See “Selecting Files and Directories.”

2. Choose Selected > Rename. The file that you selected is highlighted and displayed
with its full pathname.
3. Enter the new filename and press Enter. A dialog comes up, asking for
confirmation. If the new name is correct, press OK. If not, press Cancel.
Note: You can rename only one file or directory at a time.
Removing Files

To remove a file or files from your source tree:
1.

Select the file or files to be removed. (See “Selecting Files and Directories” for
information on how to select files.)

2. Click the Remove button. You can also choose Selected > Remove in the menu bar.
Note: If you are using version control (RCS), you can recover files that you have

accidently removed. When a directory is removed, all files other than the RCS files are
deleted, and that directory no longer appears in Site Manager. You can still recover the
files in that directory through dirview or a UNIX shell at a later time.
Editing Files

To edit your HTML files:
1.

Select the file or files to be edited. (See “Selecting Files and Directories” for
information on how to select files.)

2. Click the Edit button. You can also choose Selected > Edit in the menu bar.
Site Manager automatically checks out and locks a file when you are editing it. For
information on locking, see “Locking and Unlocking Files.”
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Site Manager uses Cosmo Create as your default HTML editor. (Cosmo Create is a
graphical WYSIWYG HTML editor that is part of your installation package; see the
documentation on Cosmo Create for more information.) If you want to use a different
editor, change the editor option in Options > Preferences. (See “Changing Site View
Preferences” for more information.)
Creating and Editing Document Templates

When you choose New Document > Create Copy From Template, Site Manager creates
a new document based on a default HTML template that is found on the Site Manager
Server. See also “Checking in New Files.”
If you have administrator privileges on the Site Manager server, you can change the
HTML template or create new templates for other document types (like VRML or text,
for example).
To edit the HTML template:
Site Manager creates a file named smtemp.html in the directory /var/www/htdocs/.sitemgr/
the first time a Site Manager client requests the New Document > Create Copy From
Template command.
Open the file /var/www/htdocs/.sitemgr/smtemp.html in your preferred HTML or text editor
and save the changes to the same filename.
If the file doesn’t exist yet (because no one has used the Create Copy From Template
command), just create a new HTML file named smtemp.html. Site Manager will use this
file and not overwrite it with a default file the first time someone requests Create Copy
From Template.
To create a new document template:
1.

Create a template for the document type in your preferred editor. For example, you
might use Cosmo Worlds to create a VRML world with some basic elements that
make up your VRML template.

2. Save this file to /var/www/htdocs/.sitemgr/smtemp.xxx. (replace the .xxx extension with
the extension for your document, as in .wrl for a VRML file, .txt for a text file, and so
on.
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3. You should notify users in your Site Manager client group that additional templates
besides smtemp.html are available. The dialog for New Document > Create Copy
From Template only displays smtemp.html, so users must know the file extensions
for additional templates to type into the path and filename text box.
Note: Your Web server may not use /var/www/htdocs as its document root (the directory
at the top of your document tree). Be sure to substitute the appropriate pathname if
necessary. For example, you might be using /usr/local/etc/httpd/htdocs instead.
Validating Files

Use Validate when you want to check the links in your Web page, verify that all the
references to inline graphics are correct, or check to make sure that the page contains only
valid HTML or VRML.
To validate your Web pages:
1.

Select the file or files to be validated. (See “Selecting Files and Directories” for
information on how to select files.)

2. Click the Validate button. You can also choose Selected > Validate in the menu bar.
The files that failed to be successfully validated are displayed in the validation results
list. Clicking an item in the list will display details about why that file couldn’t be
validated.
By default, only the document and media references are validated. To change what is
validated, just select or deselect the appropriate checkbox. (For details on the Validate
panel, see the “Validate Panel” reference card.)
Finding and Replacing Text

Site Manager lets you find a replace text in one or several selected files. To use Find and
Replace:
1.

In the Site View, select the files or directories in which you want to change a word or
line of text.

2. Choose Selected > Find and Replace.
3. Enter the text you want to find and replace, then click Perform Update. For a full
description of the text fields and buttons in the dialog, see “Find and Replace Text
Dialog.”
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Previewing
Site Manager allows you to preview your Web documents. You can preview either
through the built-in preview area, located in the Site Action pane, or by using a browser
of your choice. Take a look at these sections:
•

“Previewing a Web Page”

•

“Previewing Using Other Browsers”

If you are running Site Manager from behind a local network firewall and want to be able
to follow links external to your site in the preview window, you need to run Site Manager
from the command line with the -web option. Enter the following command:
% /usr/sbin/sitemgr -web

Previewing a Web Page

You can preview your Web pages in either the Site Action pane or in a separate browser.
To preview your Web page:
1.

Select the Web page you wish to preview. (See “Selecting Files and Directories” for
information on how to select files.)

2. Click the Preview tab. You can also choose Selected > Preview in the menu bar.
By default, the Web page is displayed in the Preview window. If you want to view the
page in a separate browser, click the Preview checkbox and designate the browser of your
choice in the text field.
Note: Plug-ins do not appear in the Preview window. See “Plug-ins Don’t Appear in

Preview” for a work around.
Previewing Using Other Browsers

By default, when you preview documents, they are shown in the display area of the
preview panel. If you instead wish to preview your Web page in an external browser
(Netscape, for example), follow these steps:
1.

Click the Preview tab.
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2. Click the Preview checkbox. If you wish to use a browser other than Netscape (the
default when the checkbox is clicked), enter it in the User Browser text field. You
must enter the name of the command that launches the browser (netscape), not the
name of the browser (Netscape Navigator), in the text field.
3. Double-click the file you want to preview. You can also choose Selected > Preview
in the menu bar.

Changing Site View Preferences
You can change your default work area, HTML, VRML, or image editor by modifying the
appropriate entry in the Preferences dialog. To change a preference:
1.

Choose Options > Preferences... to launch the Preferences dialog.

2. In the dialog, modify the preferences you want to change. For example, if you
want to change your default HTML editor from Cosmo Create to jot, delete
cosmocreate and enter jot in the HTML Editor text field.
3. Click OK. Your new preferences are applied.
Use the Default button to reset the preferences to their original default values.
Tip: By default, plug-ins do not appear in the Site View when you preview documents.

See “Plug-ins Don’t Appear in Preview” for details.

Exiting Site View
To exit Site View, choose Session > Exit from the Site View menu bar. This operation
closes Site Manger entirely. If Link View is also open when you exit Site View, it will close
as well.
Note: Site Manager keeps track of your current state when you quit the program. When

you restart Site Manager:
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•

The last site that you were viewing when you quit appears.

•

The panel that you last used is active. (For example, the Preview panel.)

•

The Link View appears if you had it open when you quit.

Using the Link View

Using the Link View
The Link View displays your Web site as documents and the links between them in 3D
hyperbolic space. The structure is shown as a hierarchy starting from a root node (usually
the site’s top-level index.html file). For a description of the nodes, see “About the Node
Types.”
To launch the link view, choose Views > Link View of Site... in the menu bar.
You can use the link view for any of the following tasks:
•

“Moving Around in the Link View”

•

“Displaying Different Link Types”

•

“Selecting Nodes and Subtrees”

•

“Changing Link View Preferences”

•

“Exiting Link View”

Moving Around in the Link View
You can navigate in the Link View window a number of ways:
•

To center the view on a particular node, click that node. That node is selected and
moved to center of the view. All of the ancestors of the node appear on its left, while
its descendents are on the right. Usually the node will move to the center with an
animated transition. You may occasionally see a jump instead of an animation when
looking at a large structure.

•

To move along a link, click the link (the line connecting two nodes) with the left
mouse button. The selected node does not change, but the exact spot where you
clicked moves to the center of the sphere.

•

To rotate the entire structure around the selected node, hold down the middle
mouse button and drag in the Link View window. While there is no way to reset just
the rotation changes you’ve made to the view, you can choose Views > Reload to
return the view to the way it looked when you first launched Link View.

•

To move the entire structure freely without changing the selection, hold down the
left mouse button and drag in the Link View window. If the view becomes
distorted, you may need to move a node into view by clicking it with the left mouse
button.
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•

To return the root node to the center of the view, click the Center button.

•

To return to the default view (in other words, the same view that was displayed
when Link View was first launched), choose View > Reload.
The difference between Center and Reload is that Center only moves the root node to
the center of the sphere. Reload, on the other hand, returns you to ground zero. All
incoming and outgoing links are hidden, and the root node is reset to the top level
of the Web site. The root node is also moved to the center of the sphere.
If you find yourself in a situation where nodes have been dragged out of sight, or
the view is distorted, the best bet is to click the Center button.

Displaying Different Link Types
You can view three different link types in the Link View. (For a description, see “About
the Link Types.”) By default, the Link View displays only the Main links. To view other
types of links:
1.

Select a node. See “Selecting Files and Directories.”

2. Choose Selected > Indirect Links > Outgoing or Incoming

Selecting Nodes and Subtrees
To select a single node, click it. Selected nodes appear yellow.
You can select multiple nodes in the Link View in two ways:
•

Select a single node, then Shift-click to select additional nodes.

•

Select a single node, then choose Select Subtree from the Selected menu or the right
mouse button menu.

(See “Selecting Files and Directories” for details on how to sweep-select in the Site View.)
To deselect all nodes, click the background in the Link View or the Site View.
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Selections made in the Link View affect the display in the Site View and vice versa. Notice
that:
•

Selected nodes in the Link View and their corresponding files in the Site View
appear yellow.

•

Selecting a single node in the Link View moves that node and its corresponding file
in Site View to the center of each view.

•

If you select multiple nodes, this repositioning does not take place.

Selecting a group of items that are near each other in one view often results in selections
that are widely separated in the other view. This disparity occurs because the hyperlink
structure which is used to create the tree in the Link View can be very different from the
directory structure that is used to organize the folders in the Site View. Each organization
shows certain aspects of your site and hides others, so you can switch between them to
get the best view for your needs at any given time.

Changing Link View Preferences
Choose Options > Preferences from the Link View menu bar to change the following:
•

Turn Other Media on or off. By default, the Link View displays only HTML nodes.
Clicking the Other Media checkbox will show all the nodes (in other words, all
non-HTML mime types).

•

Turn External Site Links on or off. By default, links to sites external to your current
site are not displayed. Click this checkbox to display external site links. An entire
external site is represented as a single, white node.

•

Turn Orphans on or off. Orphans are documents that cannot be directly reached
from the root node. By default, these documents are not displayed. Click this
checkbox to display orphans as additional subtrees beneath the topmost node.

•

Turn the sphere on or off. By default, the Link View draws the sphere “at infinity,”
which encloses the space in which the structure can move, so that you can orient
yourself more easily. As you grow accustomed to the 3D hyperbolic space, you may
wish to turn off the sphere to see the structure itself without visual clutter. Turn off
the sphere by deselecting the Sphere checkbox.

•

Change the background color. There are three background colors available: black
(the default), grey, and white. Choose the one that you prefer by clicking the
appropriate radio button.
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•

Change the text labels attached to the nodes. Nodes may have attached text labels
which contain the URL for that node. See “Display Controls” for details on how to
control which nodes have text labels. The short form, which is the default, truncates
the URL so that only the last part after the rightmost slash is shown. The long form
is the full URL path. You can choose which form to use by clicking the appropriate
radio button. In both cases the URL is relative to the document root. Site Manager
doesn’t include the initial part of the URL that designates the site name because this
root URL is the same for all URLs at your site and appears in the title of the Link
View window.

Click the Apply button to apply your changes to the Link View. Click the Defaults button
to return the options to their default values.
Tip: If you’re familiar with editing X resources, you can change the default aspect ratio

for the sphere in the Link View. By default, the sphere retains its shape when you resize
the window. If you want the sphere to distort (become oval-shaped) as you resize the
Link View window, you need to change keepAspect to True. In general, the preferred
way of setting up or changing X resources is to specify them in a local .Xdefaults file. This
would typically be done by following these steps:
1.

Edit $HOME/.Xdefaults (or create this file if it doesn’t already exist).

2. Add the line SiteMgr*keepAspect: True
3. Save the file and exit.
4. Restart Site Manager if you had it open.
Also see the X(1) man pages.

Exiting Link View
To exit the Link View, choose Session > Exit from the Link View menu bar. Exiting Link
View does not end the current Site Manager session; to do so, you must exit Site View.
See “Exiting Site View” for further information.

Other Help Topics
For a complete list of help topics, both task-based and reference, take a look at the index
available through the Help menu in the menu bar. Choose Help > Index, and you will see
a new window with all the help topics listed.
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4.Site Manager Reference

This chapter provides all the reference information related to Site Manager. It contains
the following sections:
•

“Site View”

•

“Link View”

•

“Keys and Shortcuts”

•

“Troubleshooting and Advanced Tips”

Site View
The Site Manager Site View contains the following items:
•

“Menu Bar,” which contains the various menus (Session, Selected, Views, Options,
and Help).

•

“Site Display Pane,” which displays information about the site in icon-based form.

•

“Site Controls,” which allow you to manipulate how the Site display shows the
information.

•

“Site Action Pane,” which allows you to perform actions on the Web pages on your
site.

•

“Site View Dialogs,” which provides information about the various dialogs
available through the Site View (such as the Preferences dialog).

Menu Bar
The menu bar contains the following menus:
•

“Session Menu”

•

“Selected Menu”
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•

“Arrange Menu”

•

“Views Menu”

•

“Options Menu”

•

“Help Menu”

Session Menu

•

Quick Find/Search For launches the Quick Find dialog, which allows you to find a
particular document. See “Quick Find Dialog” for more information.

•

Show WorkArea displays the contents of your work area in a directory view. (Your
work area is the directory where the files you have checked out of the source tree
are placed while you work on them.)

•

The Print menu lets you choose between two options. Print Visible Site Outline,
prints an indented directory view of the information currently being displayed in
the Site View. Print Entire Site Outline prints an indented directory view of the
entire site. This is an expanded list of all directories including their files and
sub-directories.

•

Exit quits Site Manager.

Selected Menu

The Selected menu contains the following items:
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•

Preview allows you to preview the currently selected Web page. You can preview in
either the Preview panel of the Site Action pane or in a separate browser window.
You can also get this information by clicking the Preview tab in the Action pane.

•

Revision Info allows you to display the source control history, path, and other
information related to the selected Web page’s revision history. You can also get this
information by clicking the Revision Info tab in the Action pane.

•

Link Info allows you to display the incoming and outgoing link information related
to the selected Web page. You can also get this information by clicking the Link Info
tab in the Action pane.

•

Validate allows you to check the links in your Web page, verify that all the
references to inline graphics are correct, and make sure that the page contains only
valid HTML. You can also get this information by clicking the Validate tab in the
Action pane.

Site View

•

Statistics generates and displays statistics about your Web site. The statistics are
based on the information in one of the following logs: access (the default), error,
agent, and referrer. (For information about the log files, see “Log File
Descriptions.”) You can also get this information by clicking the Statistics tab in the
Action pane.

•

Check Out allows you to check the selected file out of the source repository. The file
browser is launched to let you choose where to put the working copy of your file.

•

Check In allows you to check the selected file in to the source repository.

•

Edit allows you to edit the selected file. The default HTML editor is Cosmo Create,
the VRML editor is Cosmo Worlds, the image editor is Image Works, and the text
editor is jot; if you want to use a different editor, you can define it in the Preferences
panel.

•

Make Copy launches the Site Manager “Copy Prompt Dialog,” which allows you to
make a copy of the current file to a new filename. The default is filename_new.html.

•

Remove allows you to change the name of a Web page. You can remove single files,
or sweep-select in the Site Display area and remove multiple files.
When a directory is removed, all files other than the RCS files are deleted, and that
directory no longer appears in Site Manager. This allows you to recover the files in
that directory through dirview or a UNIX shell at a later time if need be.

•

Rename allows you to change the name of a file. You can change the name of only
one file at a time.
You cannot change the name of a directory with Site Manager.

•

Find and Replace finds and replaces specified text in the files you selected in the
Site View.

•

Find in Work Area opens the work area directory that contains a file selected in the
Site View. A file will be in your work area only if you have checked it out or copied
it into your work area.

•

Lock Document(s) locks the current document so that other users cannot modify it.

•

Unlock Document(s) unlocks the current document.

•

New Document From Existing Local File lets you check in a new document (for
example, if you have created a document outside of Site Manager that you want to
include in the Site Manager database). Create Copy from Template lets you create a
new document based on a template that is kept on the Site Manager server. See
“Creating and Editing Document Templates.” See also “Checking in New Files.”
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•

New Directory lets you name and create a new directory. The new directory
appears within a directory you select in the Site View. If you have a file selected
instead of a directory, then the new directory is placed within the same directory as
the selected file.

The items on the Selected menu are also available through the right mouse button.
Arrange Menu

This menu contains the following items:
•

By Name lists files and directories in the Site View by name.

•

By Date lists files and directories in the Site View by date.

•

By Size lists files and directories in the Site View by size.

•

By Type lists files and directories in the Site View by type (those with the same
filename extension are grouped together; for example, .html, .wrl, .pl, and so on).

Views Menu

•

Link View of Site launches the Link View, which shows your Web documents and
the links between them in 3D hyperbolic space. The structure is shown as a
hierarchy starting from a root node (usually the site’s top-level index.html file).

•

Update Site Information launches the “Site Manager Initialization and Update
Dialogs,” which allows you to perform a number of site-related administration
functions, such as turning revision control on or off, in conjunction with updating
your Site Manager database. (You need to update the database when changes are
made outside of Site Manager on your site, such as new files being created, files
being deleted, and so on through the UNIX shell.)

•

Initialize (New) Site sets up a new database at the specified URL. (The URL must
be that of a web site server running Site Manager server software.) See also
“Initializing the Site Database.”

Options Menu

The Options menu contains the Preferences dialog, which lets you change application
defaults such as the default HTML editor and the default image editor. See “Preferences
Dialog” for details.
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Help Menu

The Help menu contains the following items:
•

Click for Help is also known as context-sensitive help. When selected, changes the
cursor to a question mark. Place the question mark over the part of the interface on
which you need information and click; the help topic for that item is launched.

•

Overview launches the Site Manager overview help topic.

•

Getting Started provides information on how to get up and running with Site
Manager as quickly as possible

•

Tutorial shows you a quick walkthrough of the tasks you can perform with Site
Manager.

•

How To provides you with information on how to perform all the critical tasks in
Site Manager.

•

Reference provides all the reference information for Site Manger; information on
each button, widget, panel, and dialog. This information is also available through
Help > Click for Help.

•

Keys & Shortcuts launches a help card that displays the keyboard shortcuts for Site
Manager.

•

Product Information launches a dialog that contains the copyright and version
information.

Site Controls
The controls available for selecting and changing the site to which Site Manager is
pointing are these:
•

Drop Pocket: Dropping a Web jumper into the site location drop pocket causes that
site to be listed in the location text field. Similarly, you can drag the icon out of the
drop pocket and put it on your desktop for future use.

•

Site Location: Displays the location of the site at which Site Manager is currently
pointing. Enter the URL of a site in this field to view it through Site Manager. (The
site must have a Site Manager server software and you must have initialized a
database before you can view the site. See “Setting Up Your Site Manager Server”
and “Initializing the Site Database.”)
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•

Recycle: This button with circular arrows, to the right of the URL text field lets you
view the history of the sites that you previously viewed through Site Manager and
select one to load.

•

Load Web Site: If users have made changes to the site that you are currently
viewing, or if you enter a new site in the location text field, you can display the new
information in the display area by clicking this button.

Site Display Pane
This topic includes the following sections:
•

“Site Display Area and Controls”

•

“Action Buttons”

•

“Icon Descriptions”

Site Display Area and Controls

•

The Site Display area is the area in which all the files and directories available on
your site are displayed. The information is displayed in a dirview-like manner; that
is, the icons, filenames, and associated information are displayed graphically.

•

The thumb wheel allows you adjust the size of the information in the display area.
Click and drag up to increase the size, click and drag down to decrease.

•

The small square below the thumb wheel resets the size of the information to the
original default value.

•

The down arrow button opens up and displays the contents of all the directories on
the current level. For example, if you are viewing the top level of your Web site and
it contains only directories (for example, the directories of all the users at your Web
site), clicking this button displays all the directories and files inside those
directories.

•

The up arrow button closes all the currently open directories.

Action Buttons

A number of frequently used functions are available through the action buttons at the
bottom of the Display pane. Clicking these buttons performs the appropriate action and
updates the display in the Site Action pane.
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For clarity, the labels on the buttons change depending on whether the site has version
control enabled or disabled. (For further information on the issues surrounding version
control, see “About Version Control.”) Because the default is to have version control
enabled, that button label is listed first.
The available buttons are these:
•

Check Out/Get Documents allows you to check the selected file out of the source
repository. The file browser is launched to let you choose where to put the working
copy of your file.

•

Check In/Publish allows you to check the selected file in to the source repository.

•

Edit allows you to edit the selected file. The default HTML editor is Cosmo Create,
the VRML editor is Cosmo Worlds, the image editor is Image Works, and the text
editor is jot; if you want to use a different editor, you can define it in Options >
Preferences.

•

Remove allows you to remove a Web page. You can remove single files, or
sweep-select in the Site Display area and remove multiple files.
Note: When a directory is removed, all files other than the RCS files are deleted, and

that directory no longer appears in Site Manager. If you’re using version control, you
can still recover the files in that directory through dirview or a UNIX shell.
Icon Descriptions

In addition to the standard file icons, the Site Display pane uses the icons listed in
Table 4-1 to describe the status of files.
Table 4-1
Icon

Icon Descriptions
Name

Description

Locked File This icon, which resembles a lock, appears next to files that are
currently locked. Locked files cannot be modified by anyone other than
the person who locked the file. See “Locking and Unlocking Files” for
further information.
Invalid File This icon, which resembles the international symbol for “No,”
indicates that the file is invalid in some way—it may contain incorrect
HTML or broken links, for example. Click the Validate tab to generate a
list that indicates where the file is invalid. See “Validating Files” for
more info.
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Site Action Pane
The Site Action pane is a tabbed deck that provides you with access to five different
panels: the “Preview Panel,” “Revision Info Panel,” “Link Info Panel,” “Validate Panel,”
and “Statistics Panel.” Each panel allows you get information on and manipulate the
Web pages of your site in a particular way.
All the panels contain a drop pocket containing the selected Web page, and the path of
that Web page. Dragging an icon and dropping it into the drop pocket of a particular
panel causes that panel’s function to be run on that particular Web page. For example, if
you drop a file into the pocket of the Revision Info panel, you will see the revision
information for that Web page.
Preview Panel

The Preview panel in the Site Action pane displays a preview version of your selected
Web page. It contains the following items:
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•

Preview: If checked, previews the selected Web page in a separate window using
the browser listed in the text field. If unchecked, previews the Web page in the
display area of the preview panel.

•

Use Local Copy: If checked, the local copy of Site Manager is previewed. (A local
copy of the files is one that you have in your workarea, a file that you have either
checked out or are editing.)

•

Use https: The display area of the preview panel doesn’t currently support the
viewing of documents via the secure server protocol. Clicking this checkbox
automatically specifies another browser like Netscape to preview selected files.
(Type the name of the browser you want to use in the “Use browser” text box.)

•

Navigation Control buttons: If you follow links from the previewed Web page, you
can step back and forth through your navigation history with the back and forward
buttons (just like in Netscape Navigator). The Reload button (the button with the
circular arrow) updates the information displayed in the preview area (use this
button if you have made any changes to the file you are previewing). The Stop
button (red circle) cancels the load for the current Web page.

•

Print Document: Click this to print the document shown in the Preview window.

•

Quickstart Document: Displays the Site Manager Quickstart document—the
document that appears when you first launch Site Manager—in the display area.

•

Display Area: The area in which the selected Web page is displayed.

Site View

Revision Info Panel

The Revision Info panel in the Site Action pane displays the source control history for the
selected file. It contains the following items:
•

Source History displays the version history of the selected file. You can check out
an older version of the file by clicking the version you want and then clicking the
Check Out... button. Clicking the Preview button brings up the preview panel with
the selected version of the file displayed. Clicking the Show Diff button brings up a
dialog that displays the differences between the selected version and the latest
version of the file.

•

Get Copy allows you to check the selected file out of the source repository. The file
browser is launched to let you choose where to put the working copy of your file.

•

Show Differences displays the differences between the selected and most recent
versions of the file in gdiff. (For more information on the gdiff graphical file
difference viewing tool, see the gdiff(1) man page.)

•

Preview allows you to preview the currently selected Web page. You can preview in
either the Preview panel of the Site Action pane, or in a separate browser window.
You can also get this information by clicking the Preview tab in the Action pane or
choosing Selected > Preview from the menu bar.

Link Info Panel

The Link Info panel in the Site Action pane displays source control history and link
information for the selected file. It contains the following items:
•

Incoming Links displays the list of inbound links for the selected file.

•

Outgoing Links displays the list of outbound links for the selected file.

See “About the Link Types” for an explanation of link types.
Validate Panel

The Validate panel in the Site Action pane displays the results of a validation: broken
links, incorrect HTML or VRML encoding, and so on. It contains the following items:
•

Local Site Links causes Site Manager to validate the links to documents that exist
on the local site, and any inline graphics referenced by the Web pages.
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•

External Site References causes Site Manager to validate the links to Web pages
that exist on remote sites.

•

HTML/VRML Encoding causes Site Manager to verify that the HTML or VRML is
valid for the selected Web pages.

•

Select To Show Detail displays any files that failed to be successfully validated.
Click a particular item to get details on why that file failed to validate.

•

Document Validation Detail displays the reasons why a particular file failed
validation. The broken links and invalid HTML are displayed in this list.

•

Edit launches the specified editor for a selected file (for example, Cosmo Create
opens for editing an HTML file). Change the default editors in Options >
Preferences.

Statistics Panel

The Statistics panel in the Site Action pane displays a number of statistics related to your
site. You can generate statistics based on any of the following log files: access, error,
agent, referrer. (See “Log File Descriptions” for a description of these log files.)
The panel contains the following items:
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•

Access Logs allows you to select which log file to be used to generate the statistics.
The default is the access log file.

•

Update generates the statistics.

•

Options button launches the “Statistics Options Dialog,” which allows you to
control the date range over which the statistics are displayed, and whether they are
displayed in a static or animated fashion.

•

Color in Link View displays an overview of the log data where each node is
colored according to the number of hits it received instead of the default coloring
according to MIME type. Nodes with many hits are red, and those with few hits are
gray. This coloring shows the aggregate hits over a period of time.

•

Animate in Linkview causes the statistics to be dynamically displayed in the Link
View. See “Statistics Visualization” for more information.

Site View

Log File Descriptions

The statistics that Site Manager allows you to look at are based on four log files that are
generated by a Web site server. These log files are:
•

Access log records each request made to the server by other clients and browsers.
The access log files contain the hostname or IP address of the client, the date and
time, the document requested, the success or failure status of the request, and the
number of bytes sent over the wire in response to the request. Access logs are used
to count hits and bytes, to see what documents are most requested, and to see who
is accessing the server.

•

Agent log records which browsers are accessing the server. You can use the agent
log files to tune the content for a particular audience based on the browser software
or operating system.

•

Error log records various server errors. The server log files contain date and time
stamps in addition to English text error messages. Error logs are used to fix
configuration problems, broken server programs, and so on.

•

Referrer log records the URLs (both local and remote) that contain links to
documents on the server. Each entry contains a pair of URLs, the URL that has just
been requested, and the URL that “referred” a user to it. Referrer logs are used to
track the URLs that point to your own URLs.

Site View Dialogs
In addition to the two main views (“Site View” and “Link View”) of Site Manager, the
following dialogs are also available:
•

“Quick Find Dialog”

•

“Find and Replace Text Dialog”

•

“Check In Dialog”

•

“Copy Prompt Dialog”

•

“Site Manager Initialization and Update Dialogs”

•

“Statistics Options Dialog”

•

“Statistics Play Dialog”

•

“Preferences Dialog”
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Quick Find Dialog

Choose Session > Quick Find to search the Web site for a particular file. The Quick Find
dialog contains the following items:
•

Find Document: Enter the name (or a part of the name) of the document you are
trying to find in this field.

•

Search: Starts the search.

•

Clear: Clears the Find Document text field, allowing you to enter a new filename.

•

Close: Closes the dialog.

•

Results display area: All the files that match the filename in the Find Document text
field are displayed in this area. Double-clicking an item will select it in “Site View”
and “Link View.”

Find and Replace Text Dialog

Choose Selected > Find and Replace to see this dialog, which contains the following
items:
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•

Change string: Type the name of the text string you want to replace

•

To string: Type the new text that will replace the text you indicated in Change
string.

•

Using options: Exact Match replaces all instances of the exact text you typed in
Change string and to string. Pattern Match replaces all instances of the text you
type, ignoring case. For example, if you want to replace all instances of
TARGET=”_top” with TARGET=”sidebar”, but you know that some files refer to
Target or target instead of TARGET, you would use Pattern Match.

•

List box: All the files you selected in the Site View appear here. These are the files on
which you want Find and Replace to work its magic.

•

Find in Site View: When you click a file in the list box, then click Find in Site, the
Site View display automatically scrolls so you can see the corresponding file. You
might use this feature when you want to double-check a selected file’s contents in
the Preview window.

•

Remove from List: Select a file in the list box, then click this button to remove the
selection from the list of files to be included in the Find and Replace.

•

Restore List: Click this button if you accidently remove files from the list box.

Site View

•

Save List: Saves the current list of files that appear in the list box. You can use the
saved list as a reference so that you know which files you changed. Or, you can save
the list so you can perform the modifications yourself, at a later time, rather than
have Site Manager perform the operation.

•

Perform Update: Click this button once you’re satisfied with the entries you’ve
made in the Find and Replace dialog.

•

Cancel Update: Click this button to exit Find and Replace without making any
changes.

Note: If you leave the Find and Replace dialog open, then switch to the Site View and

select new files, the list box doesn’t automatically update. You need to close the Find and
Replace dialog and open it again (by choosing Selected > Find and Replace) to update the
list.
Check In Dialog

When you attempt to check a file back in to your source tree (choose Selected > Check
In), the Check In dialog comes up to verify information about your file and allow you to
include comments with that version of the file. The dialog contains the following items:
•

Local Filename: The full pathname of the file in your workarea. Click the Browse...
button to use the file browser to select a filename.

•

Publish To: The name of the published version of the file. (In other words, the name
of the file as it will be viewed by people surfing in to the Web server.)

•

Remove Local File: If checked, the copy of the file in your local workarea is
removed after the file is successfully checked in to the source repository. It is
recommended that you leave this unchecked; backup copies of the file are not
created, and so it would be easy to accidentally remove files you meant to keep.

•

Notification: The email address of the person(s) notified when the file is checked in.
You can leave this field blank if you don’t want to use this feature.

•

Comments: Enter any comments associated with this version of the file in the
Comments area. You can leave this field blank if you don’t have any comments.

•

OK: Applies the displayed options and dismisses the dialog.

•

Cancel: Cancels the current operation.

Note: Site Manager attempts to automatically fill in the correct information in the Local

Filename and Publish To text fields.
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Copy Prompt Dialog

The Copy Prompt appears in the following instances:
•

When you want to make a copy of a selected file (choose Selected > Make Copy).
The dialog contains a text field in which you enter the name you want the new file
to have. The default filename is filename_new.html, where filename is the name of the
file you selected to copy.

•

When you want to create a new document based on a template (choose Selected >
New Document > Create Copy From Template. The default filename is
doc_new.html.

The Copy Prompt dialog has the following options:
•

Make Copy Only makes a new document based on the file you selected to copy (as
in Selected > Make Copy) or on an HTML template found on the Site Manager
server (as in Selected > New Document > Create Copy From Template). Make Copy
places the copy in the same directory as the selected file. Create Copy From
Template places the new file in the selected directory.

•

Make Copy And Get Document/Check Out does the same thing as Make Copy
and also places the new file in your work area for later editing. This process also
locks the document so no one else can edit the file while it is in your work area.

•

Make Copy And Edit does the same thing as Make Copy And Get
Document/Check Out and also opens the file in the default editor.

See also:
•

“Checking in New Files”

•

“Creating and Editing Document Templates”

Site Manager Initialization and Update Dialogs

The database initialization dialog pops up when you choose Views > Initialize New Site.
A similar dialog appears when you update the database (choose Views > Update Site
Information).
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•

Site Manager Server/Location: The location of the Site Manager server.

•

Server/Location: The location of the Web server.

Site View

These two fields will be different only if you are administering a Web server that is
not the same system as your Site Manager server (for example, in the case that the
server is on a different system, or you have several servers with different port
number on the same system). This is usually the case when you wish to have a more
secure environment.
In either case, the document root location is the same.
If a sub-site is specified (a directory), then both the Site Manager Server/Location
and the Server/Location need to match and reflect that directory. For example:
Site Manager Server/Location: http://www.foo.com:6949/my_subdir
Server/Location: http://www.foo.com/my_subdir

•

Log File Directory: The directory in which the HTTP server log files are stored.

•

Directories to Exclude From Processing: Allows you to prevent Site Manager from
including certain directories when it updates the database. For example, you should
exclude any directories that exist outside your Web site and are referenced by
symbolic links within your Web site. Type the directory names you want to exclude,
separating each with a semi-colon.
By default, the following directories are excluded:
doc_root/Demos
doc_root/OutOfBox
doc_root/SoftWindows
doc_root/SysSetup
doc_root/SurfZone
doc_root/SysTour
doc_root/WhatsNew
doc_root/demos
doc_root/ij
doc_root/infosearch
doc_root/junction
doc_root/library
doc_root/o2start
doc_root/root
doc_root/sysmgr
doc_root/webdist
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These directories represent typical Silicon Graphics software, which you may have
installed on your system. By excluding these and other directories not directly
referenced by your Web site, you get a more accurate picture of the Web site. More
importantly, excluding directories not in the Web site avoids accidental deletion or
modification of the files in these areas and speeds up Site Manager processing.
•

“Home”-type Pages allows you to enter the names of Web pages that Site Manager
considers home pages. The defaults are index.html and home.html.

•

Email Results To allows you to designate the user to whom email is sent when the
database build has been successfully completed.

•

Use Version Control. If checked, enables version control through the RCS revision
control system on the selected site.

•

Update Fields Only updates the configuration file containing the above
information (Server location, Log file directory, and so on)

•

Update Database updates the database—this action can take a while, so be patient;
Clear clears all the information from the text fields

•

Cancel cancels the initialization and dismisses the dialog.

For first time initialization, the dialog contains a different set of buttons:
•

Initialize Database causes the database initialization process to begin (you will
receive email when the process is complete).

•

Clear clears all the information from the text fields.

•

Cancel cancels the initialization and dismisses the dialog; Help launches this help
topic.

Statistics Options Dialog

This dialog allows you to control the date range over which the statistics are displayed.
To see the dialog, click the Options button in the Statistics panel. The dialog contains the
following options:
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•

Begin Date: The start date for the statistics operations. Enter a date in the text field
or move the slider to select a start date. The list is generated from the access logs.

•

End Date: The end date for the statistics operations. Enter a date in the text field or
move the slider to select an end date. The list is generated from the access logs.

•

OK applies the displayed options and dismisses the dialog.

•

Defaults resets all the fields to their original default values.

Site View

•

Cancel cancels the current operation.

•

Help launches the help card for the dialog.

Statistics Play Dialog

This dialog lets you choose how the Statistics option in the Site View will display in the
Link View. To see the dialog, click Animate in Linkview in the Statistics panel.
•

View follows traffic: Each node that is hit will automatically move to the center of
the sphere so that you can see where the activity is occurring.

•

Persistent trails: Each path between a source and destination node stays
highlighted in yellow instead of returning to the default link color. These trails form
a visual record of past activity.

Preferences Dialog

The Preferences dialog allows you to change such Site Manager defaults as the HTML
editor and the image editor. To see the dialog, choose Options > Preferences.
•

HTML Editor: Allows you to select which HTML editor is launched when you click
the Edit button with an HTML file selected. The default is Cosmo Create.

•

VRML Editor: Allows you to select which VRML editor is launched when you click
the Edit button with a VRML file selected. The default is Cosmo Worlds.

•

Image Editor: Allows you to select which image editor is launched when you click
the Edit button with an image file selected. The default is Image Works.

•

Text Editor: Allows you to select which text editor is launched when you check out
and/or edit a document of MIME type “text/*” but not “text/html,” or if the file is
a CGI script. (For example, an image map file.) The default is jot.

•

Current Base Workarea: Allows you to select the directory in which your files
reside when you check them out of the source repository. The default is
$HOME/sitemgr_wa.

•

Show Workarea: Displays the contents of your workarea in dirview.

•

Prompt for Location to Place Files: When this option is checked, a dialog appears
each time you check files out to ask you where you want to place the files.

•

Side-by-Side Orientation: When checked, shows “Site Display Pane” and “Site
Action Pane” side by side. The default shows the display pane on top and the action
pane below.
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•

Automatically Load Last Site When Started: When checked, launching Site
Manager loads the last site you viewed before you last exited the program.

•

Select Server(s) to Remove from the History List: Displays a history list of servers
that you’ve loaded in Site Manager. Click a server’s name to select it for removal.

•

Remove Server(s): Allows you to remove entries from the Server History List.

•

OK applies the displayed options and dismisses the dialog.

•

Defaults resets all the fields to their original default values.

•

Cancel cancels the current operation.

•

Help launches the help card for the dialog.

Link View
The Link View window (Figure 1-2) displays the hyperlinked structure of your Web site,
which is how a visitor to your site will experience it. This may look quite different from
the directory structure of the server’s filesystem that you see in Site View.
You can navigate through the three-dimensional link view and choose which Web pages
and links to display. The color of the nodes that represent Web documents tells you their
file type, and the color of the links shows whether they’re coming into or going out of a
document.
The Link View shows the site in a special kind of 3D space called “hyperbolic space,”
where the documents and links move so that you can see a great deal of context
surrounding the document that’s the current focus of your attention. Figure 1-2 shows
the Link View window looking onto a small Web site.
For details on the link view, see the following sections:
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•

“About the Node Types”

•

“About the Link Types”

•

“Menu Bar”

•

“Display Area”

•

“Display Controls”

Link View

About the Node Types
The Link View considers Web documents (such as HTML pages, images, MPEGs, or
VRML files) as nodes, which are drawn as cubes in the 3D scene. Link view contains the
following types of nodes:
•

A parent node is a document containing hyperlinks that lead to its child nodes.

•

A leaf node is a document with no children.

The base color of a node denotes its MIME type (as specified on the server). For details
on the node colors, look at the legend at the bottom of the link view.
Selected nodes are always highlighted in yellow. Nodes are temporarily highlighted in
green as the mouse pointer moves over them.

About the Link Types
The Site Manager Link View allows you to display three different types of links:
•

Main (Incoming and Outgoing): Always drawn. Link from a child node to its main
parent. The Link View uses both the directory structure (as found in the URL) and
the hyperlink structure of the site to determine which node is the main parent. For
example, a file /bar/baz.htm might be the child of two nodes: /bar/index.html and
/non/sense/other.html. Link View uses the former one for the main parent.

•

Indirect (Incoming and Outgoing): Drawn on demand. An outgoing link is a link
from the selected node to a node that is not its own child (as defined above). For
instance, a page that has an index of the entire site is likely to have many outgoing
links. An Incoming link is a link to the selected node from a node that is not its main
parent (as defined above). For instance, a logo image is likely to have many
incoming links.

You can tell the direction of a link by the coloring. Red indicates an incoming link, while
blue indicates an outgoing link.
Links from image maps (both embedded and external map files) are treated as if they
exist in the HTML file itself.
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Menu Bar
The Link View menu bar contains the following menus:
•

“File Menu”

•

“Selected Menu”

•

“Views Menu”

•

“Options Menu”

File Menu

The Link View File menu contains the following options:
•

Open History lets you open a previously saved Link View file. When Link View is
running from a saved file instead of being driven directly from the Site View, much
of the Site View functionality is unavailable. The reopened file may look different
from the original file if you have changed the Link View Preferences since saving.

•

Save History lets you save the current configuration and 3D position of the Link
View structure to a file.

•

Save Image As lets you save a Silicon Graphics format (RGB) image of the current
link view window.

•

Close closes the Link View.

Selected Menu

The Indirect Links menu allows you to display or hide the different indirect links for the
selected node. If an option is grayed out, that option either does not exist for that node
or has already been selected. (See “About the Link Types,” for a discussion of the
different link types available in the Link View.) The available selections are:
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•

Outgoing > Show Links: Allows you to display the outgoing links from the current
node.

•

Outgoing > Hide Links: Allows you to hide the outgoing links from the current
node.

•

Incoming > Show Links: Allows you to display the incoming links from the current
node.

•

Incoming > Hide Links: Allows you to hide the incoming links from the current
node.

Link View

Other menus include:
•

Select Subtree: Selects all visible nodes in the subtree beneath the currently selected
node.

•

Preview: Same as Preview in Site View. Allows you to preview the currently
selected Web page. You can preview in either the Preview panel of the Site Action
pane, or in a separate browser window.

•

Revision Info: Same as Revision Info in Site View. Allows you to display the source
control history information related to the selected Web page.

•

Link Info: Same as Revision Info in Site View. Allows you to display the incoming
and outgoing link information related to the selected Web page.

•

Validate: Same as Validate in Site View. Allows you to check the links in your Web
page, verify that all the references to inline graphics are correct, and make sure that
the page contains only valid HTML or VRML.

•

Set as Root Node: Reloads the tree using the selected node as the root node for the
tree.

The items on the Selected menu are also available through the right mouse button.
Note: If you have selected multiple nodes, only the Validate and Indirect Links rolling

menus are available.
Views Menu

The Views menu in the Link View contains the following items:
•

Center repositions the current root node to the center of the sphere.

•

Reset Color reverts the Link View to its original color scheme (after selecting
Statistics > Color in Link View; see “Statistics Visualization”).

•

Reload reverts to the start-up view you see when you open Link View for the first
time; turns off all non-main links, reverts to the default expand or contract levels
and the default root node. The default root node is repositioned to the center of the
sphere.
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Options Menu

The Options menu lets you to launch the Preferences dialog, which contains the
following items:
•

Other Media allows you to display links to other media (movie files, for example).

•

External Site Links allows you to display external sites. An entire external site is
represented as a single, white node.

•

Orphans allows you to display orphan sites, which are not directly accessible from
the root node. Orphans are drawn as additional subtrees beneath the topmost node.
There may be outgoing links from orphan nodes to the main tree, but there will not
be any incoming links.

•

The Sphere turns the orientation sphere in the Link View on and off.

•

Background Color lets you select the Link View’s background color. The default is
black.

•

Text Labels lets you choose whether short or long text labels should be displayed
with nodes.

•

Apply applies the displayed options and dismisses the dialog.

•

Defaults resets all the fields to their original default values.

•

Cancel cancels the current operation.

•

Help launches “Changing Link View Preferences.”

Display Area
The Link View display shows your site’s nodes arranged in a 3D hyperbolic globe. At
startup, the base Web page for your site (in general, the main index.html file in the main
Web directory, /var/www/htdocs) is located in the center. You can move around the site by
either clicking a particular node or clicking and dragging the entire structure.
The node legend at the bottom of the display tells you what the various node colors mean
(standard HTML Web pages are in cyan, images are purple, and so on).
The Link View display (the color schemes, the links themselves) changes when you click
Visualize in Link View in the statistics panel. For details on the changes, see “Statistics
Visualization.”
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Link View

Statistics Visualization

Select a file and click the Statistics tab. When you click Animate in Linkview, the Link View
appears (if it is not already open) and changes in the following ways:
•

All nodes in the Link View are recolored as gray, to indicate that they are “cold” (no
one has accessed that node).

•

As hits occur, the nodes gradually change color to red to indicate that they are “hot”
(lots of hits).

•

The link paths are highlighted to show that a link has been followed from one node
to another.

Statistical information displayed in the Link View is taken from the access logs. Some
configuration work may need to be done to the server for the information to be displayed
properly. See the section on “Log Analysis via Site Manager” in Chapter 2 of the release
notes for details.
If you click Color in Linkview, the information from the access log is collected and the
nodes are recolored as described above, but the action is not dynamically animated in the
Link View.
Note: Click Reset Color in the Link View to return its color scheme to the original setting.

See also:
•

“Statistics Panel”

•

“Statistics Play Dialog”

•

“Generating and Viewing Statistics About Your Web Site”

Mouse Button Controls

You can use the buttons on the mouse in the Link View display area for the following:
•

Left mouse click: Move node under mouse to center and select it.

•

Shift-left mouse click: Select node, can be used for multiple selections. Also use to
deselect one file in a multiple selection.

•

Left mouse drag: Translate the structure.
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•

Middle mouse drag: Rotate the structure around the center of the view.

•

Right mouse click: Provides you with the Selected menu for actions on selected
node(s).

Display Controls
The bottom of the link view contains a number of controls:
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•

The legend at the bottom left portion of the Link View describes how the view is
coloring nodes and link paths.

•

Generations lets you choose how much of the tree structure to see at once. You can
limit the number of generations shown above and below the current center node in
order to focus your attention on a small part of the structure without being
distracted by the rest. The part that is drawn will change as you move through the
structure since the center node changes dynamically. The default is All, which
draws as many generations as possible.

•

Label Region lets you to choose how many nodes are drawn with text labels. When
too many labels are drawn, the display is cluttered and hard to read. When too few
labels are drawn, you can’t see which node represents which document. The right
balance depends on the characteristics of the site that you are inspecting and your
preference. The slider controls how large the node must appear onscreen before a
label is drawn. Choosing a low value will draw labels for only the largest nodes,
while a high value will draw labels even for small nodes on the outskirts of the
sphere. Choosing the lowest value, 0%, will turn off label drawing.

•

Center repositions the current root node to the middle of the globe.

•

Reset Color resets the colors back to the Link View defaults after you have used
statistics visualization (see “Generating and Viewing Statistics About Your Web
Site”).

•

Close dismisses the link view.

Keys and Shortcuts

Keys and Shortcuts
The keyboard shortcuts for Site Manager are show in Table 4-2. In the table, LV indicates
that the shortcut is used only in the Link View.
Table 4-2

Keys and Shortcuts

Key

Action

Ctrl-C

Make a copy of the selected node

Ctrl-E

Open selected node for editing

Ctrl-H

Get link info on selected node

Ctrl-I

Get revision info on selected node

Ctrl-K

Check out current node

Shift-Ctrl-K

Check in current node

Ctrl-L

Launch link view of site

Ctrl-N

Create a new directory

Ctrl-O (LV)

Open history

Ctrl-P

Print directory view of site

Ctrl-Q

Exit Site Manager

Ctrl-R (LV)

Preview selected node

Ctrl-S

Launch Search/Quick Find tool

Ctrl-S (LV)

Save history

Ctrl-V

Validate selected node

Ctrl-W (LV)

Close Link View

Shift-F1

Enable click-for-help
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Troubleshooting and Advanced Tips
This section contains the following topics:
•

“Avoiding Problems When Upgrading Site Manager”

•

“Troubleshooting Initialization and Setup”

•

“Version Control Doesn’t Work”

•

“Problems With Directories and Files”

•

“Problems With Preview”

•

“Problems in the Link View”

•

“Important Notes for the Site Administrator”

Avoiding Problems When Upgrading Site Manager
When you upgrade from an earlier version of Site Manager, make sure you perform the
following tasks:
1.

If you are the system administrator, upgrade new Site Manager software on the
system which acts as the Site Manager server. Make sure you include both
sitemgr.sw.base and sitemgr.sw.server in the upgrade, along with sitemgr.sw.client.

2. All users in the workgroup must update the Web site database that was previously
built by the Site Manager initialization process. When users first attempt to load the
particular Web site, Site Manager prompts them to re-initialize the site database. See
also “Updating the Site Database.”

Troubleshooting Initialization and Setup
This section includes the following topics:

62

•

“Avoiding Problems During Setup”

•

“Initializing Database Seems to Take Too Long”

•

“Entire Web Site Doesn’t Appear in Site Manager”

•

“General Tips”

Troubleshooting and Advanced Tips

Avoiding Problems During Setup

Make sure you read “Setting Up Your Site Manager Server” for detailed information on
preparing your server for a software install. Some troubleshooting issues include:
•

Did you correctly set up a secure environment for your server by referring to the
Site Manager release notes and your Web server documentation?

•

Did you install both the base and server software?

•

If your site is large (over 25,000-30,000 documents and servable objects), did you
correctly partition your site?

Initializing Database Seems to Take Too Long

The initial database creation step may take some time, proportional to the number of
documents at the top level of your directory tree. If your directory tree contains over
25,000-30,000 documents, Site Manager may take so long that it appears to stall on
initialization.
Try the following to increase the speed of the initialization:
•

If your site is very large, you should partition your Web site into sub-sections. See
“Partitioning a Large Site” for details.

•

Run the Site Manager client on sub-directories (sub-sites) within your document
tree. See “Initializing the Site Database.”

•

Make sure you have excluded directories that are not part of your Web site. For
example, you might have some temporary storage directories that include symbolic
links to users’ home directories. Type the directories you want to exclude in the
Directories to Exclude From Processing text box in the “Site Manager Initialization
and Update Dialogs.”

Also see “Database Initialization Stopped or Aborted.”
Database Initialization Stopped or Aborted

If you need to stop the initialization process before it is complete, log in as root (su) and
type /etc/killall smdbf.cgi at the prompt. Note that you should usually let the
initialization process continue until it is done.
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If the initialization process was somehow aborted, remove the following files before
trying to initialize the database again:
•

document_root/.sitemgr/sm.init

•

document_root/.sitemgr/smdb.*

If you need to completely re-initialize your database, you can run the following
command from a shell (where document_root could be /var/www/htdocs, for example):
# /usr/sitemgr/bin/smdbf.cgi document_root

If this process is somehow aborted, the file document_root/.sitemgr/sm.init must be
removed before smdbf.cgi can be executed again.
This function can also be performed from the Site Manager client. See “Initializing the
Site Database.”
You should update the database if documents on your site are changed without going
through the Site Manager client. For example, editing or removing documents directly
within the document root. Site Manager should detect the modifications made within
your document root and prompt you for an update. See also “Updating the Site
Database.”
General Tips

If you are running a separate HTTP server instance for utilizing Site Manager (see
Installation Information in Chapter 2 of the release notes), make sure you differentiate
between the Site Manager Server/Location and the Server/Location in the Site Manager
Initialization dialog.
The value specified for Server/Location should be the server and port that people
normally use to view your site. For example, the two entries may look like:
SiteMgr Server/Location: http://www.foo.com:6949/subsiteXYZ
Server/Location: http://www.foo.com/subsiteXYZ

If Site Manager is being run through the same HTTP server instance that people normally
use to view your site, then the entries should be identical.
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When initializing the database, Site Manager only picks up documents and directories
that are found off the document root for the HTTP server instance you have specified.
Documents and directories can be in the form of symbolic links (which are automatically
followed), found somewhere within the document root. Anything outside of the
document root will not be picked up if there is no symbolic link to it from within the
document root.
In particular, user documents with URLs of the form
http://www.foo.com/~jsmith/foo.html will not be found unless there is a symbolic link
from within the document root to the user’s Unix directory (default location
~jsmith/public_html).
See also:
•

“Initializing the Site Database”

•

“Site Manager Initialization and Update Dialogs”

Entire Web Site Doesn’t Appear in Site Manager

If your entire Web site (under the top level of the document directory tree) is not showing
up in Site Manager, check the following:
•

Make sure you correctly initialized the database. For steps on this process, see
“Initializing the Site Database.” For troubleshooting information, see “General
Tips.”

•

Check to see if the missing directories are excluded from processing. Look at the
Directories to Exclude From Processing text box in the Site Manager Initialization
dialog. See “Site Manager Initialization and Update Dialogs” for a full list of
directories that Site Manager excludes by default.
Note: Due to statistics processing and speed issues, we recommend that you do not

remove entries unless absolutely necessary.
•

Make sure the file permissions on your Site Manager server are correct. See the
paragraph on file permissions in “Important Notes for the Site Administrator.”

65

Chapter 4: Site Manager Reference

Version Control Doesn’t Work
Here are some common problems that cause version control to work incorrectly or not at
all:
•

You didn’t install Revision Control System (RCS) software (eoe.sw.rcs). On IRIX
6.2 systems, you can install that subsystem from your IRIX 6.2 part 1 of 2 CD. On
IRIX 6.3/4/5 systems, you can install it from your IRIX 6.3/4/5 CD.

•

Site Manager is looking for RCS in the wrong place. By default, Site Manager
looks for the existence of a Revision Control System (RCS) Utility program in
/usr/sbin/rcs. If you have installed the RCS binaries in a different location, you
should create the following symbolic links:

•

# ln -s

<your_location>/rcs /usr/sbin/rcs

# ln -s

<your_location>/ci /usr/sbin/ci

# ln -s

<your_location>/co /usr/sbin/co

# ln -s

<your_location>/rcsmerge /usr/sbin/rcsmerge

# ln -s

<your_location>/rcsdiff /usr/sbin/rcsdiff

# ln -s

<your_location>/rlog /usr/sbin/rlog

Your Site Manager server has the wrong file permissions. See the paragraph on file
permissions in “Important Notes for the Site Administrator.”

Other version control issues:
•

If Version Control is turned off, you will lose the ability to track multiple versions of
HTML, VRML and text files (and also apply revision comments to them), as well as
apply locks to documents.

•

Image files and other binary objects are not placed under version control at this
time.

•

If Version Control is turned on, RCS subdirectories will be created in every directory
of your site if they do not already exist. As a result, the time stamp of every
directory in your site will be set to the time at which you initialize the database.
Whenever you update the database, files that were changed outside of Site Manager
will be checked in and the time stamp of directories in which they reside will be
reset.

See also the bulleted item Version control thinks a removed file still exists in “Problems With
Directories and Files.”
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Problems With Directories and Files
Here are some common problems you may see when working with directories and files:
•

Image Maps don’t appear or don’t work right. Because Site Manager doesn’t
acknowledge image map files referenced within an HTML document, we
recommend that you embed your image map information within your document,
as outlined in the HTML 3.0 specification (utilize the <MAP> tag).

•

Directory isn’t removed. When you select a directory and choose Selected >
Remove in the Site View, Site Manager removes the files in the directory, but not the
directory itself. You (or the Site Manager administrator) need to manually remove
the directory from the Site Manager server using a directory view or shell window.

•

Directory doesn’t appear in the Site View. Site Manager does not display empty
directories to the end-user. So an empty directory that exists on the server will not
appear in the Site View. Any new directories you create using the Selected > New
Directory command will appear in the Site View, but not on the server until they’re
populated. If you create a new directory in Site Manager (using Selected > New
Directory) with the same name as an empty directory that already exists under your
document root, and populate it with documents, Site Manager places the new files
in the existing directory.

•

Files don’t appear in the Site View. If you have version control turned “on” and
your Web server is running under a user id that can’t write to the directories under
your document root, then some (or possibly all) of your HTML files will not be
published by Site Manager. The result? The files don’t appear in the Site View.
Solutions to this problem include turning off version control or changing your file
permissions. See the paragraph on file permissions in “Important Notes for the Site
Administrator.”

•

Version control thinks a removed file still exists. You might see the error message
“Document Does Not Exist” or “No such file or directory” if you or someone else
manually removes a file on the site server (for example, using the rm command). If
this happens, you need to update your database. See “Updating the Site Database.”

•

You accidentally deleted a file that was under version control. When you remove a
file by choosing Selected > Remove from the Site View menu, Site Manager does not
delete the RCS history file. Site Manager behaves this way to provide a “safety-net”
in case you accidently deleted a file and need to recover it. The site administrator
can recover the file through the RCS command set. See RCS(1) for more
information.
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•

Spell checking doesn’t work. If you wish to enable the spell checking feature for
the Validation module, you will need to install eoe.sw.spell (the Spell Utilities), if
this subsystem is not already installed on the server machine.

Problems With Preview
Preview has a number of “quirks.” The general workaround is to specify that Site
Manager previews documents not using the built-in Preview. See “Previewing Using
Other Browsers.”
You should use an alternate browser in the following cases:
•

Your document contains Java applets.

•

You need to display a document using a secure channel (the "HTTPS" protocol).

•

Your document contains or consists solely of a filetype that relies on a plug-in for
viewing. See “Plug-ins Don’t Appear in Preview” for another workaround that
involves editing X resources.

The built-in Previewer may also have trouble with loading certain images. If clicking the
reload (circular arrow) button does not cause these images to load, you may want to
examine how the <IMG> tags are specified. In the case where the attribute "SGI_SRC" is
set, it must appear before the attribute "SRC" (which designates the HTTP path to the
image file).
If Preview always defers to another browser, even after you have deselected the
Preview/Using checkbox, make sure that “Use https” is also deselected.
Plug-ins Don’t Appear in Preview

Preview doesn’t display plug-ins by default. If you want to view media that requires a
plug-in, click the Preview/Use browser button in the “Preview Panel.” When you
double-click a file, the specified browser displays the content.
Tip: If you are familiar with editing X resources, you can specify that Preview use

plug-ins. In general, the preferred way of setting up or changing X resources is to specify
them in a local .Xdefaults file. This would typically be done by following these steps:
1.

Edit $HOME/.Xdefaults (or create this file if it doesn’t already exist).

2. Add the line SiteMgr*plugins_enabled: True
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3. Save the file and exit.
4. Restart Site Manager if you had it open.
Also see the X(1) man pages.

Problems in the Link View
If nothing happens in the Link View window when you select the Animate in Linkview
button, try the following solutions:
•

The documents which are being hit may be far enough from the current viewpoint
that you cannot see them flash. Try enabling the View follows traffic checkbox in the
StatsPlay popup window.

•

The documents which are being hit may be turned off in the Link View display. Try
turning on the Display checkboxes for Other Media, External Site Links, and
Orphans on the Link View Preferences panel, which can be found under the
Options menu item.

•

The Link View window may be showing only a part of the structure of your site.
This could happen if you previously re-rooted the tree shown in Link View with the
Set As Root Node menu item. Try selecting the Reload item under the View menu in
the Link View window to see the whole structure.

Important Notes for the Site Administrator
The best way to troubleshoot end-user problems is to avoid them entirely. Here you’ll
find out how to avoid conflicts with existing software and other tips.
Conflicts with Netscape FastTrack Personal Server. Site Manager can get into a “hung”
state if the Site Manager Server Extensions (sitemgr.sw.server) are used in conjunction
with a Netscape FastTrack Personal Server, version 2.0P (ns_fasttrack) or earlier. In
earlier versions of this server there were problems handling CGI (Common Gateway
Interface) processes which could cause this situation. The workaround is to upgrade to
(at least) version 2.01 of ns_fasttrack. Version 2.01 can be found on the IRIX 6.5
Applications CD, or on the IRIX Applications CD (for IRIX 6.2, 6.3 and 6.4) which was
released in August of 1997.
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Using Site Manager with OutBox. Sites making use of the OutBox Personal Web Site
Tools (outbox.sw.*) for maintaining content may want to also use Site Manager. Note that
Site Manager could be used in place of the OutBox Tools; however, utilizing both tools is
possible. When you use Site Manager with OutBox, files published, removed, or updated
through the OutBox need to be “recognized” by the Site Manager database. To make that
happen, the Site Manager database needs to be updated so that it reflects the changes
made to the site. In Site Manager’s Site View, choose Views > Update Site Information,
follow the instructions on the dialog, and click Update Database. See also “Updating the
Site Database.”
Site Manager and firewalls. Administering a site (or following links from the Preview
window) through a firewall situation (utilizing a SOCKS host, for instance) requires the
use of the -webprefs (or -web) command-line option when starting up the Site Manager
client:
% /usr/sbin/sitemgr -webprefs

See sitemgr(1) for more information on all command-line options.
File permissions. The Site Manager server processes are “owned” by the same user ID
as your HTTP server. If you are using Site Manager to add or remove documents from
your document root directory (or from areas of your document root), that user ID must
be able to perform that function. In order to avoid file access problems within Site
Manager, you may need to run your HTTP server (or another HTTP server instance)
under a user ID that can perform such functions in your document root. Some possible
methods are outlined below. Also see the following man pages for more information:
ls(1), chmod(1), chown(1), passwd(4).
Here are some methods you can use to avoid permissions problems:
•
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Run the server under an appropriate user ID. For example, if your HTTP server
instance is running under a privileged user ID, such as “root,” then Site Manager
should have no problem writing or reading files found under your document root.
You may need to consider creating a user ID with the appropriate capabilities. To
get your HTTP server instance to utilize (run under) a new user ID, stop your
server, change the user setting, and then restart the server. If you are using a
Netscape server, use the Administration Server to change the User in the System
Settings section, or edit the magnus.conf file. If you are using an NCSA or Apache
server, edit the User and Group settings in the httpd.conf file. We strongly advise you
to consider establishing a secure environment when using Site Manager. For
instructions on setting up a secure server for Site Manager, see the section on
“Security and SiteMgr” in Chapter 2 of the release notes.
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•

Check ownership and permissions modes of all files. The files and directories you
want to maintain (write or publish to) under Site Manager should be areas that can
be properly accessed by the user ID for which your HTTP server instance (used by
Site Manager) is running. You may need to modify these permissions using
standard IRIX commands. See see the following man pages for more information:
ls(1), chmod(1), chown(1), passwd(4).

•

Run a separate Site Manager server. Alternatively, you can run a separate HTTP
server instance (on a unique port number) whose sole purpose is to provide access
to the Site Manager CGI scripts. This server will most likely run as root and use the
same document root directory as the existing HTTP document server. In addition,
you can apply strict access control to the second server that guards the use of Site
Manager but does not effect the primary document server.
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Tell Us About This Manual
As a user of Silicon Graphics products, you can help us to better understand your needs
and to improve the quality of our documentation.
Any information that you provide will be useful. Here is a list of suggested topics:
•

General impression of the document

•

Omission of material that you expected to find

•

Technical errors

•

Relevance of the material to the job you had to do

•

Quality of the printing and binding

Please send the title and part number of the document with your comments. The part
number for this document is 007-3320-002.
Thank you!

Three Ways to Reach Us
•

To send your comments by electronic mail, use either of these addresses:
–

On the Internet: techpubs@sgi.com

–

For UUCP mail (through any backbone site): [your_site]!sgi!techpubs

•

To fax your comments (or annotated copies of manual pages), use this
fax number: 650-932-0801

•

To send your comments by traditional mail, use this address:
Technical Publications
Silicon Graphics, Inc.
2011 North Shoreline Boulevard, M/S 535
Mountain View, California 94043-1389

