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Introduction

This guide explains how to install and remove the OCTANE Personal Video board in an
OCTANE workstation. Below is an overview of the contents of this guide:
•

The introduction provides additional information about hardware resources,
products, and support.

•

Chapter 1, “Installing the OCTANE Personal Video Board,” provides instructions
for installing the OCTANE Personal Video board in an OCTANE workstation.

•

Chapter 2, “Using the Digital Media Software,”provides information on setting up
the Personal Video board using the Video Panel, recording video to the hard disk,
and using the O2Cam digital video camera.

•

Chapter 3, “Removing the OCTANE Personal Video Board,”provides instructions
for this task.

•

Chapter 4, “Troubleshooting,” provides troubleshooting information.

•

Appendix A, “Framelocking,” provides Personal Video board framelocking
information.

•

Appendix B, “Identifying the Personal Video Board and Graphics Boards,” provides
illustrations of the OCTANE Personal Video board, and the OCTANE/SI,
OCTANE/SI with texture memory option board, OCTANE/SSI, and
OCTANE/MXI graphics boards.

•

Appendix C, “Care and Cleaning of the XIO Compression Connector,” provides
instructions on the care and cleaning of the XIO compression connector.

•

Appendix D, “O2Cam Technical Specifications,” provides technical specifications
for the O2Cam video camera.

Read this guide once all the way through before you start to work. You will become
familiar with the OCTANE system and the parts with which you will be working. If you
find an unfamiliar term, check the glossary on page 83.
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It’s always a good idea to back up your system before installing a new board. If you have
not backed up your system recently, do so now. For instructions on backing up your
system, see the online Personal System Administration Guide.

Additional Hardware Information
OCTANE Hardware Central is an online resource that provides access to hardware movies
and other information previously found only in your printed owner’s guide, such as port
pinout information, user tips, environmental information, and so on. To access it:
1.

Choose Toolchest > Selected > File QuickFind.

2. When the window appears, type insight and press Enter.
3. When the IRIS InSight bookshelf appears, choose OCTANE Hardware Central from
the SGI EndUser bookshelf.
Or, access it through your Web browser. In the location window, type
file:/usr/share/Insight/library/SGI_bookshelves/SGI_EndUser/books/
Octane_HWCntl/index.html and press Enter.

OCTANE Hardware Movies show OCTANE option boards being installed and removed.
The hardware movies are found in OCTANE Hardware Central.

Hardware Configurations
A listing of available configurations (upgrades and options) is available on the Web. In
the location window, type http://www.sgi.com/Products/hardware/desktop/
products/configurator/configurator.html

Technical Publications Library
A copy of this manual, as well as other Silicon Graphics technical publications, is found
in the Technical Publications Library. To access this library, open your Web browser and
enter http://techpubs.sgi.com/library/

xii
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Software and System Administration Information
For complete information on installing software, see the online Personal System
Administration Guide. You can find it by choosing Toolchest > Help > Online Books. For
more advanced information, see the online IRIX Admin: Software Installation & Licensing
Guide. For system administration information, see the SGI_Admin section of the online
bookshelf.

Product Support
The OCTANE workstation is designed so that you can maintain and repair the
workstation without the help of a trained technician. Contact your Silicon Graphics
subsidiary or authorized distributor for information about product support.
Silicon Graphics, Inc., provides a comprehensive range of product support for its
products. If you are in North America and would like support for your Silicon Graphics
supported products, contact the Technical Assistance Center at 1-800-800-4SGI or your
authorized service provider. If you are outside North America, contact the Silicon
Graphics subsidiary or authorized distributor in your country.

Reader Comments
If you have comments about the technical accuracy, content, or organization of this
document, please tell us. Be sure to include the title and document number of the manual
with your comments. (Online, the document number is located in the frontmatter of the
manual. In printed manuals, the document number can be found on the back cover.)
You can contact us in any of the following ways:
•

Send e-mail to the following address:
techpubs@sgi.com

•

Use the Feedback option on the Technical Publications Library World Wide Web
page:
http://techpubs.sgi.com
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•

Contact your customer service representative and ask that an incident be filed in the
SGI incident tracking system

•

Send mail to the following address:
Technical Publications
SGI
1600 Amphitheater Pkwy., M/S 535
Mountain View, California 94043-1351

•

Send a fax to the attention of “Technical Publications” at +1 650 932 0801.

We value your comments and will respond to them promptly.

xiv

Chapter 1

1. Installing the OCTANE Personal Video Board

This chapter covers installing and removing the OCTANE Personal Video
option board in your OCTANE workstation.
The following topics are covered in this chapter:
•

“Installing a New Version of the IRIX Operating System” on page 2

•

“OCTANE Personal Video Board Package Components” on page 3

•

“Preparing the Workstation” on page 4

•

“Removing the XIO Module” on page 7

•

“About the XIO Module” on page 13

•

“Attaching the OCTANE Personal Video Board to the XIO Module” on page 13

•

“Installing the Cable Guard” on page 19

•

“Replacing the XIO Module” on page 24

•

“Placing a Regulatory Label” on page 34

About the OCTANE Personal Video Board
The OCTANE Personal Video option provides high-quality video input and output,
industry standard formats, and real time video processing through all of its ports.
You can send and receive analog video (either composite or s-video), receive video from
the O2Cam digital camera, and connect component digital video in/out from any serial
CCIR 601/SMPTE-259M compliant device. Use a third-party adapter to convert the
digital video port to CCIR 601. The digital video port provides both input and output
data flow.
The OCTANE Personal Video board is compatible with NTSC (525-line) and PAL
(625-line) television broadcast standards. It provides a single video output channel
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simultaneously in composite analog, S-video, and digital (via the digital port) interfaces.
A single video input channel can be selected from composite analog, S-video, and digital
(via the digital port) interfaces. In addition, the digital interface supports the O2Cam
digital camera.
The OCTANE Personal Video board also provides a reference sync (genlock) input.
The OCTANE Personal Video board translates the high-resolution graphics output to
digital video formats with arbitrary scaling including full-screen capture. The resultant
digital video can be captured into system memory and directed to the OCTANE Personal
Video board’s video output interfaces.

Installing a New Version of the IRIX Operating System
Before shutting down your system and installing the Personal Video board, be sure you
have the same version of the IRIX operating system installed on your system that ships
with this board. Install the operating system that came with your board before installing
the hardware.

Installing the Software
Read any flier and release notes before installing the Personal Video software that came
with your shipment. The notes in the CD booklet provide detailed information for
reading the release notes and installing the software.
To review release notes, choose Toolchest > Help > Release Notes. Release notes are
available here after the software has been installed.
To display ASCII text in an IRIX shell, at the prompt, enter cdrelnotes.

2

OCTANE Personal Video Board Package Components

OCTANE Personal Video Board Package Components
Compression connector cap

Documentation
Cable guard

Octane Personal Video Option board
O2Cam
Audio cable
BNC/RCA adapters

Screwdriver

Digital Media CD

Figure 1-1

Long screw and spacer

Wrist strap

Checking the OCTANE Personal Video Shipment

It’s a good idea to check your shipment when you receive it. You should receive the
supplies shown in Figure 1-1.
You will also need:
•

An XIO compression connector cap to protect the graphics board or option board’s
compression connectors when the XIO module is out of the workstation. (Caps
came with the OCTANE workstation for use on the graphics board’s compression
connectors.)

•

A blank panel, if you are removing the OCTANE Personal Video board and are not
replacing it. (A blank panel came with the workstation and was in the slot filled by
the OCTANE Personal Video board.)
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Preparing the Workstation
This section contains instructions on installing the OCTANE Personal Video board.
Installing an OCTANE Personal Video board requires following a series of steps that lead
up to the board installation, through the steps that complete the task. These detailed
steps begin on the following page.

1

2

Power button

Power cord

3
Figure 1-2

1.

Power button

Powering Off the OCTANE Workstation

Open the cover and push the power button to power off the OCTANE workstation.

2. Unplug the power cord.
3. Push the power button on the monitor to power it off. Wait five minutes.
4. Face the rear of the workstation.

Warning: The heat sinks on the XIO boards become very hot. Wait 5 minutes
after powering off the OCTANE workstation before you remove the XIO module.
Test before touching any of the XIO boards.

4

Preparing the Workstation

Graphics board

To monitor

XIO module

Figure 1-3

Removing the Monitor Cable

5. Remove the monitor cable or other cables from the XIO module. (For illustration
purposes, only the monitor cable is shown in Figure 1-3.)
The XIO module can be thought of as a tray to which the XIO graphics boards and option
boards are attached.
Note: The XIO module is always installed with the graphics board toward the top of the

workstation. The graphics board appears, in Figure 1-3, in the upper left quadrant of the
XIO module.
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Attaching the Wrist Strap

1

Unroll

2

3

Figure 1-4

Attaching the Wrist Strap

Caution: The components inside the OCTANE workstation are extremely sensitive to
static electricity; you must wear the wrist strap while replacing parts inside the
workstation.
To attach the wrist strap, follow these steps:
1.

Unwrap the first two folds of the band.

2. Wrap the exposed adhesive side firmly around your wrist and unroll the rest of the
band and peel the liner from the copper foil at the opposite end.
3. Attach the copper foil to a convenient and exposed electrical ground, such as a
metal part of the OCTANE workstation.
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Removing the XIO Module

Removing the XIO Module
Before removing the XIO module, you must unplug and power off the OCTANE
workstation, wait five minutes after powering off the workstation to allow the heat sinks
to cool, and attach the wrist strap. If you have not already done this, go to “Preparing the
Workstation” on page 4 and follow the instructions through attaching the wrist strap.
Then return here.

Bristled pad

Figure 1-5

Identifying the Compression Connector

When you remove the XIO module, the compression connectors on the back of the XIO
module (XIO boards) are accessible and easily damaged. All XIO graphics boards have
compression connectors, and most XIO option boards do. The OCTANE Personal Video
board does.
Caution: The compression connectors on each XIO board are very delicate and easily
damaged. Do not touch or bump the gold, bristled pad. For more information on care
and cleaning of compression connectors, see the OCTANE Workstation Owner’s Guide.
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Figure 1-6

Removing the XIO Module Screws

Warning: The heat sinks on the XIO boards become very hot. Wait 5 minutes after
powering off the OCTANE workstation before you remove the XIO module. Test
before touching any of the XIO boards.
The XIO module is the holding mechanism for XIO graphics or XIO option boards and
holds up to four boards. It can be thought of as a tray to which boards are attached.
1.

8

Loosen the two captive screws in the XIO module handles until the handles move
free from the workstation.

Removing the XIO Module

Figure 1-7

Removing the XIO Module

2. Grasp the handles and pull until the XIO module protrudes a two inches from the
chassis.
The handles and the XIO module move out about two inches before the I/O panels
move.
3. Support the bottom of the XIO module with your hand as you pull.

9

Chapter 1: Installing the OCTANE Personal Video Board

XIO module

Figure 1-8

Supporting the XIO Module

4. Grasp the XIO module along its length, and support the module and XIO boards as
you remove them from the chassis.

10

Removing the XIO Module

Blank panel

SI graphics board

Slot D
UP

Slot A
I/O panel
XIO module

Figure 1-9

Placing the XIO Module on Its Side

The handles protrude from beneath the XIO boards when the XIO module is out of
the chassis. When protruding, the identification slots for the XIO boards (D and A, B
and C) are visible. Slots B and C are on the opposite side of the XIO module from
slots D and A.
Note: Do not push on the handle area after you have removed the XIO module. The

XIO module locks to the workstation only if the handle area is protruding.
5. Place the XIO module on a flat, antistatic surface. An empty antistatic bag on your
desk works well.
Note: Figure 1-9 above shows an OCTANE/SI graphics board in slot A and a blank

panel in slot D. OCTANE/SSI or /MXI graphics boards are twice the width of the
OCTANE/SI board and reside in slots D and A, although these boards connect to the
workstation through the single compression connector on the slot A side of the board.
See Appendix A for illustrations of different graphics boards and the OCTANE Personal
Video board.
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Caution: Do not touch

Figure 1-10

Placing a Protective Cap on the XIO Compression Connector

6. Place a cap on the XIO graphics board compression connector.
Note: The cap prevents damage to the gold (front) surface when the XIO boards are

removed from OCTANE. These caps are placed on any XIO compression connector
as soon as the XIO module is removed from the chassis, and then removed before
placing the XIO module back in the chassis.
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About the XIO Module
The XIO module is the holding mechanism for XIO graphics or XIO option boards and
holds up to four boards. It can be thought of as a tray to which boards are attached. The
four quadrants of the XIO module are slots A, B, C, and D. Slots D and A are on one side,
Slots B and C on the other. A graphics board, option board, or blank panel attaches to
each slot on the XIO module.
•

The XIO module must be placed so that the graphics board in slot A is in the upper
left corner, or the graphics board may overheat and be damaged.

•

The graphics board is always in slot A or slot A and (covering) slot D.

•

Option boards occupy slots B and C and possibly D.

•

Place the OCTANE Personal Video board only in slot B.

•

Graphics and option boards may be linked by flex cables.

•

Protective blank panels must be placed in unused slots.

•

A baffle must be attached to two side-by-side blank panels to ensure proper air flow.

•

The XIO compression connector is always covered by a protective cap when an XIO
board is out of the OCTANE workstation.

•

Extra caps for the compression connectors are shipped with the workstation.

Attaching the OCTANE Personal Video Board to the XIO Module
Attaching the OCTANE Personal Video board is a lengthy process. Here is a quick
overview of the preliminary steps.
Before installing the OCTANE Personal Video board, you must follow a series of steps
detailed in the preceding sections of this chapter, beginning at “About the OCTANE
Personal Video Board” on page 1. If you have not already done so, go to “Preparing the
Workstation” on page 4 and follow the instructions through removing the XIO module.
If you have already removed the XIO module, go to step 1 on page 14. (Be sure you also
read “About the XIO Module” on page 13 before beginning your task.)
Caution: Do not touch the gold (front) surface of the XIO compression connector.
Touching it could damage the connector. Place a protective cap on the XIO compression
connector, to prevent damage when the XIO boards are removed from the OCTANE
workstation. See Appendix C, “Care and Cleaning of the XIO Compression Connector.”
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Removing the Blank Panel or Option Board

Blank panel

C

C

B

Slot C

B
Baffle

Figure 1-11

1.

Slot B

Identifying the Baffle and Blank Panels

Turn the XIO module so that slots B and C are facing you. Select your next step from
Table 1-1.

Table 1-1

Choosing the Next Instruction

If You Have...

Go to...

An option board in slot B

The option board installation guide for
instructions on removing the board

A blank panel in slot B and an option board Step 3
in slot C
Blank panels in slots B and C
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Step 2

Attaching the OCTANE Personal Video Board to the XIO Module

Blank Panel

C
Slot C

B
Baffle

Figure 1-12

Slot B

Removing the Baffle

2. Remove the baffle attached to the two blank panels:
■

Using a Phillips screwdriver, remove the four screws holding the baffle to the
two blank panels.

■

Remove the baffle.

■

Replace the two screws into the blank panel in slot C.

3. Remove the remaining screws from the blank panel in slot B.
4. Remove the blank panel. Keep it in case you remove an option board. A blank panel
or board must be in place in each slot on the XIO module.
5. Keep the baffle. The baffle must be in place over two blank panels to ensure proper
air flow.
Note: The baffle is never used with an option board, only with two side-by-side

blank panels.
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Screws

Long screw
Spacer

C

Graphics board
Slot C

B

Slot B

Figure 1-13

Attaching the OCTANE Personal Video Board to the XIO Module

6. Place the OCTANE Personal Video board in slot B on the XIO module, aligning the
holes in the board to the standoffs on the XIO module. (Do not remove the cap on
the compression connector at this time.)
7. Insert and tighten the three shorter screws through the Personal Video board and
into the standoffs on the XIO module. See Figure 1-13.
8. Insert the long screw into the spacer, through the hole on the Personal Video board,
and into the standoff on the XIO module.
Caution: Do not install the baffle. The baffle is used only with two side-by-side blank
panels. You may damage the option board if you try to install a baffle on it.
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Attaching the Flex Cables

C

B

A

Graphics board
UP

C

BA

Release levers

Figure 1-14

1.

Attaching the Flex Cables From the OCTANE Personal Video board to the
Graphics Board

Turn over the XIO module so that you are facing the graphics board in slot A or A
and D.

2. Attach the flex cables from the OCTANE Personal Video board in slot B to the
graphics board in slot A.
■

Attach the connector with the shortest flex cable (from the OCTANE personal
Video board) to connector A on the graphics board. Press down on the middle
of the connector to ensure proper seating.

■

Lay the middle flex cable through the release levers of connector A, then attach
the connector. Press down on the middle of the connector to seat it.
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C

B

A

Graphics board
UP

C

BA

Release levers

Figure 1-15
■
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Attaching the Flex Cables to the Graphics Board

Lay the longest flex cable through the release levers of connectors A and B.
Attach the connector and press down on the middle of the connector to seat it.

Installing the Cable Guard

Installing the Cable Guard
This section describes how to install the cable guard on the OCTANE Personal Video
board.

Graphics board

Personal Video board
C

B

A

UP

Spacer

Flex cables

I/O panels

Figure 1-16

Identifying Parts for the Cable Guard Installation

The cable guard protects the flex cables from being scratched or caught on the chassis
when the XIO module is inserted or removed from the workstation.
The cable guard slides under the I/O panels and attaches beneath the screw on the
graphics board, and behind the spacer on the Personal Video board.
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Graphics board
Personal Video board
UP

Screw
A

Flex cables

Figure 1-17

1.

20

Removing the Screw From the Graphics Board

Remove the screw from the graphics board, as shown in Figure 1-17.

Installing the Cable Guard

Graphics board

Personal Video board
A

B

Cable guard

Figure 1-18

A

Sliding the Cable Guard Under the I/O Panels

2. Slide the two prongs under the I/O panels.
3. Push the cable guard toward the flex cables, laying the top hook on the top of the
graphics board. Continue placing pressure on the flex cables.
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Graphics board
Personal Video board
Top of graphics board
A

Spacer
Cable guard

Figure 1-19

Sliding the Cable Guard Behind the Standoff

4. Press down on the center hole of the cable guard and slide it toward the back of the
XIO module until its half-hook rests behind the spacer on the Personal Video board.

22

Installing the Cable Guard

Graphics board
Personal Video board
Screw
UP
A

Cable guard

Figure 1-20

Attaching the Screw to Anchor the Cable Guard to the Graphics Board

5. Place the screw from the graphics board through the hook on the cable guard and
the graphics board, and into the standoff on the XIO module.
Note: If you receive a screw with the cable guard, use this longer screw instead of

the screw you just removed from the graphics board.
You have finished installing the flex cables and cable guard.
6. Remove the caps from all XIO compression connectors. Keep the caps to protect the
compression connector should you ever remove the Personal Video board or any
other board.
See “Replacing the XIO Module” on page 24 for instructions on replacing the XIO
module.
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Replacing the XIO Module

XIO module

XIO module

Slot A
Graphics board
OCTANE/SSI
or /MXI

Slot A
Graphics board
OCTANE/SI

Slot B
Octane Personal Video
option board

OCTANE SI/SI

Figure 1-21

Slot B
Octane Personal Video
option board

Slot C

Slot C

Slot D

Slot D

OCTANE SSI or MXI/SI

Installing Slots A and D Toward the Interior of the OCTANE Workstation

Caution: The XIO module must be replaced with the graphics board toward the interior
of the workstation to prevent overheating and damage to the boards. If the XIO module
with the OCTANE/SSI or OCTANE/MXI graphics board is inserted incorrectly, a
notifier appears during power on telling you to insert the XIO module with the graphics
boards toward the interior of the workstation, and power-on stops. Power off the system
and correctly insert the XIO module, as shown in Figure 1-21.
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Graphics board,
upper left

Lower
left

Personal Video
board, upper right

Lower
right

XIO module

Figure 1-22

Placing the XIO Module Into the Workstation

Location matters.
1.

Place the XIO module in the workstation with the boards oriented as shown in
Figure 1-22.

2. Slide the XIO module into guides on the top and bottom of the workstation.
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Graphics board,
upper left

Lower
left

Personal Video
board, upper right

Lower
right

XIO module

Figure 1-23

Replacing the XIO Module

3. Before you insert the XIO module, make sure the handle portion protrudes in a
locked position from the I/O panels, as shown in Figure 1-23.
If the handles are flush with the I/O panels, the XIO module will stop during
insertion. Pull out the handles until the sliding portion of the XIO module looks like
that shown in Figure 1-23, and then continue inserting the XIO module into the
chassis.
4. Use the handles to push the XIO module firmly into a locked position. You may
need to use some force.
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Octane Personal
Video board

Figure 1-24

Replacing the XIO Module Screws

Note: The I/O panels are not completely flush with each other or the chassis; there

is some slight variation in the depth of the individual boards.
5. Tighten the screws in the handles so that the XIO module is attached to the chassis.
6. Remove the wrist strap.
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Octane Personal
Video board

To monitor

Figure 1-25

Replacing the Monitor Cable

7. Reattach the monitor cable to the I/O connector.
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Digital Video (Camera)
Mic Thru
Video In

S-video
Composite
Ref In

S-video

Video Out

Composite

Figure 1-26

Identifying the Personal Video Ports

8. Attach any cables to the appropriate port on the OCTANE Personal Video board.
See Table 1-2 for information on where to go from here.
Table 1-2

Information on the Next Step

To Do This...

Go Here...

Attach the O2Cam

“Attaching the O2Cam Digital
Camera” on page 30

Power on the OCTANE workstation

“Powering On the OCTANE
Workstation” on page 32

Set up the Personal Video board using Chapter 2, “Using the Digital Media
the Video Panel
Software”
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Attaching the O2Cam Digital Camera

Microphone
port

Mic Thru

Figure 1-27

Attaching the Audio Cable

Setting up the O2Cam requires attaching the audio and camera cables.
1.

30

Attach the audio cable to the Mic Thru port on the Personal Video board, and the
microphone port on the system module.

Attaching the O2Cam Digital Camera

Digital Video
(camera)

Figure 1-28

Attaching the O2Cam to the Digital Video Connector

2. Attach the O2Cam to the digital video (camera) connector.
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Powering On the OCTANE Workstation

2

1

Power button

Power cord

3
Figure 1-29

1.

Power button

Powering On the OCTANE Workstation

Plug the power cord into an electrical outlet.

2. Push the power button on the front of the OCTANE workstation.
3. Push the power button on your monitor.

Verifying the Hardware Installation
To verify that the Personal Video board is recognized by the system, verify the hardware
installation.
1.

Open a UNIX shell and type: hinv

2. Look for a line similar to this: Personal Video: unit 1, revision 1.0
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Verifying the Hardware Installation

3. If you do not see this line, go to Chapter 3, and follow the instructions for powering
off the OCTANE workstation and removing the XIO module. Then follow the
installation instructions in Chapter 1 to be sure the Personal Video board was
properly installed.
4. Run hinv again. If your Personal Video board is not recognized, call your authorized
service provider.

Table 1-3

The Next Step

To Do This...

Go Here...

Place a regulatory label

“Placing a Regulatory Label” on page 34

Set up the Personal Video board using Chapter 2, Using the Digital Media Software on
the Video Panel
page 35
Instructions on using the O2Cam

“Using the O2Cam Video Camera” on page 45
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Placing a Regulatory Label
Model/CMN number
Lockbar

Fan
System label

System module

Microphone
XIO module

Speakers/headphone

XIO boards
(graphics and
communications)

Speaker power
Analog line level audio

R

L

Monitor

Coaxial digital audio in/out
In Out

Optical digital audio - in

Serial number

Optical digital audio - out
Stereo view
SCSI
PCI module
Ethernet
Parallel
Mouse
Keyboard
2

1

Power supply

Serial ports

Power cord

Figure 1-30

Rear View of the OCTANE Workstation

If you received a system upgrade label, place it on the system label (top of workstation).
1.

Face the back of the OCTANE workstation. The system label (containing the model
and CMN number) is located at the top center of the back of the workstation.

2. Place the label over the VCCI and CISPR 22 information.
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2. Using the Digital Media Software

After installing the Digital Media software, the OCTANE Personal Video board, and
attaching any video equipment, access the Video Panel to set up for a video source. The
Video Panel displays the capabilities of the video devices installed on your workstation
and lets you adjust various settings for these devices. If you have not installed the Digital
Media software and the Personal Video board, see Chapter 1.
Note: The instructions in this section are based on current operating system software. If

you have upgraded to a subsequent operating system, some of the instructions may no
longer be valid. If this is the case, check the latest information by using the online Digital
Media Tools Guide and the help menus on the Video Panel and digital media tools. Also
check the Technical Publications Library for the latest version of this book over the Web
at http://techpubs.sgi.com/library/.
For information about digital media software for programming, refer to the online IRIS
Digital Media Programming Guide.
The following topics are covered in this chapter:
•

“Setting Up for a Video Source” on page 36

•

“Equipment You May Need” on page 39

•

“Synchronizing to House Sync” on page 40

•

“Using Video Commands From a UNIX Shell” on page 40

•

“Using the O2Cam Video Camera” on page 45
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Setting Up for a Video Source
The Video Panel is accessed from the Toolchest, or a UNIX shell.
You can access the Video Panel from the Toolchest:
1.

To access the Video Panel, choose Toolchest > Find > Media Tools > Video Panel.
Double-click the Video Panel icon in the Media Tools Icon Catalog. Drag the icon to
the desktop for frequent usage.

2. To access the Video Panel from the Toolchest, choose Find > Icon Catalog > Media
Tools > videopanel. Drag the videopanel icon to the desktop for frequent usage.
To access the Video Panel from a UNIX shell:
1.

Open a shell by clicking the Console icon or choose Toolchest > Desktop > UNIX
Shell.

2. Enter at the prompt:
/usr/sbin/vcp

The Video Panel appears (Figure 2-1).
Note: For additional information about the Video Panel, use the Help menu.
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Setting Up for a Video Source

.

Figure 2-1

Video Panel

3. Under the Device(s) section of the Video panel, select the Default In setting that
matches your input channel. This choice becomes your Default In setting.
■

The choices for Default In are Digital, Camera, and Analog.

■

The only Default Out setting is Video Out.
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4. Select the Sync setting:
■

If you have genlock source, choose Genlock.

■

If you don’t have a genlock source, choose Internal.

5. Select the Genlock Source setting: Reference Input, Digital, Ksync, Composite,
Analog, or Y/C Analog.
■

Choose Reference Input if you have a supplied genlocking reference to the
Reference In BNC port. Make sure that you also choose Genlock in the Sync
option.

■

If you don’t have a genlocking reference but to need genlock the Personal Video
board, you can select other signals to act as the Reference. From Genlock
Source, choose Digital, Ksync, Composite Analog, or Y/C Analog.

The Input(s) section of the Video Panel allows you to select the timing appropriate to
your application.
6. Choose one of the Inputs: Digital In, Camera In, Analog In, or Screen Source.
7. Each input section has a Timing dialog box. Choose the appropriate timing:
■

For non-square pixel purposes choose the CCIR timing: CCIR-601 525 for
NTSC, CCIR-601 625 for PAL.

■

For square pixel purposes choose the Sq. Pixel timing: Sq. Pixel 525, or Sq. Pixel
625.

8. Analog Input has a second category, Format. Choose Composite or Y/C depending
on which jack you have used. If Camera or Digital are selected under the Device(s)
> Default In section of the Video Panel, you need select nothing in the Analog
Inputs section. The timing that shows in Analog Input(s) is not significant.
9. Your timing selections from Digital In, Camera In, and Analog In may all be
different, depending on your purpose. However, when you are capturing from the
screen, your selection must match whatever timing you have chosen for Video Out.
10. Under the Output(s) section of the Video Panel, the timing you choose must be the
same as your choice under Inputs(s) > Screen Source > Timing.
11. When you have finished changing the settings, open the File menu and choose Save
Current Setting.
12. Exit from the program.
You are finished setting up the OCTANE Personal Video board.
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See the online Digital Media Tools Guide, Appendix A, for more information about the
Video Panel. A list of topics covered in this guide is provided in Table 2-1 below.
Topics Covered in this Guide

Table 2-1
Chapter

Title

Chapter

Title

Chapter

Title

1

Media Recorder

7

CD Player

13

Sound Editor

2

Media Convert

8

DAT Player

A

Video Panel

3

Movie Maker

9

CD Manager

B

Audio Panel

4

Media Player

10

DAT Manager

C

General MIDI
Sound Sets and
Percussion Maps

5

Sound Track

11

MIDI Keyboard

6

Sound Player

12

Synthesizer Panel

Equipment You May Need
To record video input and save it to your hard disk, you need a few additional items that
are not included in your Personal Video shipment. Here are some items you may need:
For professional (serial digital I/O) video:
•

A professional-quality, serial digital interface (SDI) VCR.

•

One or two cables with BNC connectors on each end.

•

An adapter for the digital video connector.

For consumer video:
•

One or two audio cables with 3.5 mm stereo jack connectors on each end.

•

A VCR, camcorder, or other video source with composite or S-video outputs.

•

An s-video or composite video cable.

•

An RCA to BNC adapter for composite video cables (two are included with the
Personal Video board shipment).
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Synchronizing to House Sync
House sync is a timing signal generated to synchronize video equipment in a studio
environment. The OCTANE Personal Video board can be synchronized to a house sync
source.
Connect the house sync signal to the Ref In connector on the Personal Video board. Make
adjustments on the Video Panel to acknowledge the house sync signal. Refer to “Setting
Up for a Video Source” on page 36 or the Video Panel’s online Help.

Using Video Commands From a UNIX Shell
From a UNIX shell, you can use the video tools listed below. Each of these tools has man
pages that can be accessed from the UNIX shell or the Toolchest > Help > Man Pages.
Videoin and videoout have a graphical user interface and are in the Media Tools Icon
Catalog accessible through the Toolchest.
videoin

Displays video input in a window on the graphics screen

videoout

Sends graphics from a portion of the screen to a video output port

vintovout

Receives video input and sends it to a device attached to the output
port

vidtomem

Saves single frames from video input to disk

memtovid

Sends single frames from disk to an output port

Use the tools with the -v flag to select inputs. (All outputs are active on the Personal
Video board.) For example, to display input from Video In or Digital Video and output it
to digital, use the command vintovout -v 1. The defaults are always analog in and analog
out.
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Recording Video Input to the Hard Disk
You can use the OCTANE Personal Video board to record video input from a VCR and
save it to your hard disk, or to display video on your OCTANE graphics monitor. The
Video Panel shown in Figure 2-1 shows the settings for a VCR.
Topics covered in this section are
•

“Connecting a VCR to the OCTANE Workstation” on page 42

•

“Adjusting Video and Audio Parameters” on page 43

•

“Saving to a Hard Disk and Displaying Video” on page 44

•

“Editing Video and Audio Clips” on page 45

•

“Playing the Movie” on page 45

•

“Using the O2Cam Video Camera and Media Recorder” on page 48
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Connecting a VCR to the OCTANE Workstation
Digital Video (Camera)
Mic Thru
Video In

S-video
Composite
Ref In

S-video

Video Out

Composite

Figure 2-2

Personal Video I/O Panel

Follow these steps to connect the VCR to the OCTANE workstation. (You can also use a
camcorder in place of a VCR.) Should you need BNC/RCA adapters, two ship with the
Personal Video board.
1.

Attach one end of the video cable to the Video In connector on the Personal Video
board.

2. Attach the other end of the video cable to the (analog) Video Out connector on the
VCR.
For Stereo Connections:

Do This:

If the VCR has stereo audio
output.

Attach the RCA cables to the Analog Line In
Left (white) port, and to the Analog Right
(red) port on OCTANE.
Attach the other end of the Left (white) RCA
cable to the Left (white) output, and the
other end of the Right (red) cable to the Right
(red) output on the VCR.
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For a Mono Connection:

Do This:

If the VCR has only mono
out.

If the VCR has only mono out, use a Y adapter to run
the mono output to both Analog Line In Left and
Right inputs.
If you choose to use only one input, the Left is
generally preferable.

3. Set up the VCR using the Video Panel. The example shown in Figure 2-1 on page 37
shows the settings for a VCR.

Adjusting Video and Audio Parameters
Use the Video and Audio Panels to adjust video and audio parameters when you record
or save to your hard disk. Both panels have online Help that describes how to use them.
•

To open the Video Panel, from the Toolchest choose Find > Control Panels and
double click the Video Panel icon. Or, type vcp in a UNIX shell.

•

To open the Audio Panel, from the Toolchest choose Desktop > Control Audio and
double-click the audiopanel icon. Or, type apanel in a UNIX shell.
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Figure 2-3

Audio Panel

Saving to a Hard Disk and Displaying Video
Note: The instructions in this section are based on current operating system software. If

you have upgraded to a subsequent operating system, some of the instructions may no
longer be valid. If this is the case, check the latest information by using the online Digital
Media Tools Guide and the help menus on the Video Panel and digital media tools. Also
check the Technical Publications Library for the latest version of this book over the Web
at http://techpubs.sgi.com/library/.
To save to the OCTANE hard disk and display video, follow these steps:
1.

From the Toolchest choose Find > Control Panels and double-click the videopanel
icon. Or type vcp in a UNIX shell. The Video Panel appears.

2. Choose the appropriate Input source.
3. To start Media Recorder, double-click the camera icon on the desktop. Or, from the
Toolchest, choose Find > Media Tools > and double-click the mediarecorder icon.
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4. For information on using Media Recorder, refer to the Media Recorder online help.

Editing Video and Audio Clips
Once you have recorded the videos, you can use Movie Maker to cut and past the video
and audio clips to make a movie.
1.

From the Toolchest, choose Find > Media Tools > and double-click the moviemaker
icon. Movie Maker opens, and the Movie Setup dialog box appears.

2. Use the Movie Maker online Help for information on editing.

Playing the Movie
To play your movie to the graphics screen, or to send it to video out, use Media Player.
Note: Make sure you have installed the patch software from the CD before using Media

Player.
1.

From a UNIX shell, enter
setenv MV_TRY_VIDEO 1

2. From the Toolchest, choose Find > Media Tools > mediaplayer icon.
3. Open Media Player by double-clicking the icon.
4. From the File menu, choose Open and select your movie file.
5. Use Media Player’s online Help if you need additional information.

Using the O2Cam Video Camera
This section provides you with information about the O2Cam features and provides
introductory instructions on using it with the Media Recorder software.
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Record button Lens cover

Focus ring

Tilt
hinge

LED activity
indicator

Figure 2-4

•

O2Cam Camera Features

Use the illustration above to familiarize yourself with the O2Cam’s features.

Figure 2-5
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Directional
microphone

Speaking Toward the Front of the O2Cam Camera

•

The camera has a built-in microphone that points in the same direction as the lens.

•

When recording audio, speak toward the front of the camera (not toward the
microphone opening on the side).

Using the O2Cam Video Camera

Figure 2-6

•

If you wish, position the camera on your monitor.

Figure 2-7

•

Placing the O2Cam Camera on the Monitor

Attaching the O2Cam to the Presenter 1280 Flat Panel Monitor

Attach the camera to the Presenter 1280 flat panel monitor by sliding the tab into the
slot at the top of the Presenter flat panel monitor.
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Using the O2Cam Video Camera and Media Recorder
Before using the O2Cam camera, access the Video Panel, and choose Devices > Default
In > Camera. See “Setting Up for a Video Source” on page 36 for instructions on accessing
the Video Panel.
If you connected the O2Cam camera before turning on the workstation, you see a camera
icon on your desktop. Double clicking the camera icon opens Media Recorder. Media
Recorder allows you to record and preview video, snapshots, and audio from the
desktop. You can also open Media Recorder from the Toolchest > Media Tools. Double
click the icon to open Media Recorder.

Figure 2-8
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Media Recorder Window

Using the O2Cam Video Camera

1.

Double click the desktop camera icon to open Media Recorder.
The Media Recorder window appears. See Figure 2-8.

The three icons in the lower left corner of the screen allow you to make a movie, record
audio, and take a snapshot.
2. Click the appropriate icon for your task.
Taking a Snapshot

To take a snapshot:
1.

Open the lens cover on the camera.

2. From the Media Recorder panel, click the Image menu button (the button with the
face) to reveal a menu. Then choose Image from Connected Source > OCTANE
Personal Video Hardware.
3. Position the subject in the Media Recorder viewing area, and focus the camera.
The viewing area reflects the image that will be captured.

Figure 2-9

Control Buttons

4. Click the Record button (the button with the red dot in the lower right portion of the
Media Recorder panel) to take the picture.
If the Clip Bin is displayed (Options menu > Show Clip Bin), the image file name
appears in the Clip Bin as soon as the snapshot has been taken.
5. To view the image, select the image file name, then click the Play button. (the one
with the green triangle). To preview other images, first select the Stop button, then
the image, then the Play button.
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Making a Movie

To make a movie using Media Recorder, see the online Digital Media Tools Guide
Chapter 1, Media Recorder. To access this book, from the Toolchest, choose Help > Online
Books > SGI EndUser > Digital Media Tools Guide.
Recording Audio

To record audio using the O2Cam camera, be sure you have the audio cable connected
between the Personal Video board and the OCTANE system module. To record audio
using the Silicon Graphics supplied microphone, or another monophonic electret
microphone, connect it to the microphone port on the system module. (See Figure 1-30
on page 34 for the location of the microphone port.)
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Figure 2-10

Using the Audio Panel

To record audio using the line inputs or digital inputs, connect your audio source directly
to the line-in or digital inputs. (See Figure 1-30 on page 34 for the location of line-in,
coaxial, and optical digital inputs.)
Once you have connected your audio device to the OCTANE workstation, you can
configure your audio input using the Audio Panel.
From the Toolchest > Desktop > choose Control Audio. The Audio Panel appears. Select
the Analog In panel by clicking the left mouse button on it. (A red line appears around
the panel when it is selected.) From the Selected menu, choose Input sources >
Microphone or Line In.
Use the online Digital Media Tools Guide for information on recording audio. It is found
by choosing Toolchest > Help > Online Books > SGI EndUser > Digital Media Tools Guide.
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Technical Specifications
Technical specifications for the O2Cam camera are in Appendix D, “O2Cam Technical
Specifications,” page 35.
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3. Removing the OCTANE Personal Video Board

This chapter provides detailed information on removing the OCTANE Personal Video
board.
The following topics are included in this chapter:
•

“Removing the Cable Guard and Flex Cables” on page 55

•

“Detaching the OCTANE Personal Video Board From the XIO Module” on page 61

•

“Placing an Option Board or Blank Panel in Slot B” on page 62

•

“Product Support” on page 65

•

“Returning Parts” on page 65
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Follow the directions in this chapter to remove the OCTANE Personal Video board and
to install another board or blank panel in its place.
Blank panel

Graphics board
Cap

Slot D
UP

Slot A

Cable guard
I/O panel

XIO module

Figure 3-1

1.

Orienting the XIO Module and Graphics Board

Go to Chapter 1, “Preparing the Workstation” on page 4, and follow the directions
through removing the XIO module. Be sure you have placed caps on the XIO
compression connectors of the graphics, Personal Video, and any other XIO board.
Then return to this section, and begin with step 2.

2. Position the XIO module so that slots D and A are facing you.
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Removing the Cable Guard and Flex Cables

Graphics board
Personal Video board
Screw
UP
A

Cable guard

Figure 3-2

1.

Removing the Cable Guard

Remove the cable guard by removing the screw that holds it to the graphics board
and XIO module.
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Graphics board
Personal Video board
A

Spacer
Cable guard

I/O panels

Figure 3-3

Sliding the Cable Guard Toward the I/O Panels

2. Press down on the middle of the cable guard and slide it beneath the I/O panels.
This action releases the cable guard half-hook from behind the spacer on the
Personal Video board. You feel pressure from the flex cables.
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Graphics board

Personal Video board
A

A

Cable guard

Figure 3-4

B

Sliding the Cable Guard From Beneath the I/O Panels

3. Slide the cable guard off the XIO module and boards.
■

Pull the cable guard away from the XIO module so that the hook and half-hook
are free.

■

Slide the cable guard out from under the edges of the I/O panels.

4. Keep the cable guard. Use it whenever you are connecting an option board to the
graphics board with flex cables.
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Graphics board

Personal Video board
UP

Screw
A

Flex cables

Figure 3-5

Replacing the Screw Holding the Graphics Board to the XIO Module

5. Replace the screw through the graphics board into the standoff on the XIO module.
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Push levers down individually
to release connectors

A
Board

B

C
Cable connector

Figure 3-6

B

A

Releasing the Flex Cables From the Graphics Board

6. Detach the flex cables from the graphics board beginning with the cable labeled C.
7. Press down on one release lever on the end of the flex cable, then on the other.
Note: Pressing both release levers at the same time usually results in the connector

remaining seated.
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Graphics board
UP

C

BA

I/O panel

Figure 3-7

Removing the Flex Cables

8. Pull up on the connector until it releases.
9. Remove flex cable B, then flex cable A, following the instructions in steps 6 and 7.
10. Turn the XIO module over.
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Detaching the OCTANE Personal Video Board From the XIO Module
Screws

C

Long screw
Spacer
Graphics board

Slot C

B

Slot B

Figure 3-8

Removing the OCTANE Personal Video board

If you have not already done so, go to “Removing the Cable Guard and Flex Cables” on
page 55 and follow these steps before removing the Personal Video board.
1.

Remove the four screws holding the Personal Video board to slot B of the XIO
module.
Note: The spacer used to hold the cable guard comes off with the screws.

2. Lift the Personal Video board from the XIO module. Place it on an antistatic bag on a
clean, dry, surface such as your desktop.
Note: Do not try to remove the flex cables from the Personal Video board. They are

permanently attached.

61

Chapter 3: Removing the OCTANE Personal Video Board

Placing an Option Board or Blank Panel in Slot B
After you have removed the OCTANE Personal Video board, choose your next step from
Table 3-1.
Table 3-1

Choosing the Next Instruction

To Do This...

Go To...

Installing a new Personal Video board

Chapter 1, “Attaching the OCTANE
Personal Video Board to the XIO
Module” on page 13

Installing a different option board

The installation guide for that option
board

Installing a blank panel

Step 1 on page 63

A blank panel must be installed in slot B of the XIO module if no option board is installed
in that slot. If a blank panel is also in slot C, a baffle must be placed over both blank panels
to allow proper airflow in the workstation.
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Screws

Blank panels

C

B

Figure 3-9

1.

Placing a Blank Panel in Slot B

Place the blank panel on the standoffs in slot B.

2. Use two short screws to attach the outside edge of the blank panel to the XIO
module if you have two blank panels side-by-side. You will install a baffle across
them in a later step.
3. If you are not installing a baffle because you have an option board beside the blank
panel, use four short screws to install the blank panel to the XIO module. Use an M3
x 8 mm screw for the fourth hole, if you cannot find the fourth short screw that
came with the blank panel.
Caution: Do not use the long screw that comes with the spacer to attach a blank
panel to the XIO module. It will damage the XIO module standoffs.
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Baffle

Blank panel

C

Slot C

B

Figure 3-10

Slot B

Placing the Baffle Over Two Blank Panels

4. If you have a blank panel in slot C, place a baffle over both blank panels.
■

Remove the two inside screws from the blank panel in slot C.

■

Place the baffle across the two blank panels.

■

Insert and tighten the four screws that hold the baffle to the blank panels and
XIO module.

Caution: You must replace the baffle for cooling purposes when you install two
side-by-side blank panels. The baffle is used only with two side-by-side blank
panels.
5. Use the packing material and box in which you received your replacement part to
return any part to your authorized service representative..
6. Remove any compression connector caps from boards attached to the XIO module.
7. Go to “Replacing the XIO Module” on page 24.
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Product Support
Silicon Graphics, Inc. provides a comprehensive range of product support for its
products. If you are in North America and would like support for your Silicon Graphics
supported products, contact the Technical Assistance Center at 1-800-800-4SGI or your
authorized service provider. If you are outside North America, contact the Silicon
Graphics subsidiary or authorized distributor in your country.

Returning Parts
To return any part, use the packaging materials and box that came with your replacement
part.
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4. Troubleshooting

This chapter contains information on what to do if you experience problems with your
system or installation. Each section describes a problem and provides instructions on
how to solve the problem. Product support information is at the end of this chapter.

Accessing hinv
Using the hinv command accesses information about the number of channels and their
configurations that exist in an OCTANE workstation with a Personal Video board
installed.
The listing provided by hinv includes the following information:
•

the confirmation (or lack) of the presence of an OCTANE Personal Video board

•

the recognition of a video format successfully loaded into the system

Follow these steps to use hinv:
1.

Go to the Toolchest.

2. Open a shell: choose Desktop > UNIX Shell.
3. On the command line, type hinv
4. Look for a line similar to this: Personal Video: unit 1, revision 1.0
5. If you do not see this line, go to Chapter 3, “Removing the OCTANE Personal Video
Board”, and follow the instructions for powering off the OCTANE workstation and
removing the XIO module. Then follow the installation instructions in Chapter 1,
“Installing the OCTANE Personal Video Board” to be sure the Personal Video board
was properly installed.
6. Run hinv again. If your Personal Video board is not recognized, call your authorized
service provider.
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Checking Connections and Installation
Use the following troubleshooting checklist to solve an installation problem:
•

The power cables are connected to the workstation and the monitor.

•

The camera or other cable connector at the chassis I/O panel is seated and the
thumb screws are tightened.

•

The audio cable is connected to both the system module and Personal Video board
when using the O2Cam camera.

•

Any video cables are completely seated.

•

The OCTANE Personal Video board and graphics board are properly seated in the
chassis. Follow instructions in Chapter 1 for opening the chassis, reinstalling the
XIO module, and powering on the workstation.

•

The flex cable connections to the graphics board are completely seated. Follow the
directions in Chapter 1 from powering off the workstation to connecting the flex
cables from the OCTANE Personal Video board to the graphics board. Then follow
the instructions to seat the flex cables through powering on the workstation.

•

The XIO module is seated and the I/O panel on the OCTANE Personal Video board
is relatively flush with the chassis. If not, follow the instructions in Chapter 1 from
powering off the workstation through removing the XIO module, and see if an XIO
compression connector cap is on any XIO compression connector. If so, remove the
cap, and follow the instructions in Chapter 1 for replacing the XIO module.

•

The graphics boards are inserted toward the interior of the workstation.

•

The appropriate operating system and software have been installed. See the
software CD and release notes that came with your shipment.

•

The monitor is appropriate for your OCTANE workstation.

Product Support
Silicon Graphics, Inc. provides a comprehensive product support and maintenance
program for its products. If you are in North America and would like support for your
Silicon Graphics supported products, contact the Technical Assistance Center at
1-800-800-4SGI or your authorized service provider. If you are outside North America,
contact the Silicon Graphics subsidiary or authorized distributor in your country.
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A. Framelocking

In order to smoothly record graphics from a graphics monitor, the video and graphics
signals must be synchronized by framelocking the video and graphics. Framelocking
eliminates tearing and motion artifacts that occur if the video and graphics signals are
not synchronized. Framelocking is the term given to the software command which
causes a workstation to write to the graphics screen at a specified time interval, causing
screen graphics to be synchronous with throughput from a video source.
To lock graphics to video, enter a command in the UNIX shell for the video standard you
are using:
•

For the PAL standard, type the command
setmon -Fe 1280x1024_49

•

For the NTSC standard, type the command
setmon -Fe 1280x1024_59

If you are running double-buffered 32-bit RGBA format on OCTANE/SI or
OCTANE/SSI, the timing table values are as follows:
/usr/gfx/setmon -x 1280x1024_72_32db for 72Hz
/usr/gfx/setmon -x 1280x1024_60_32db for 60Hz
/usr/gfx/setmon -x 1280x1024_50_32db for 50Hz

After saving the format, re-initialize the graphics system with the new mode by typing:
/usr/gfx/gfxinit

To enable framelocked, double-buffered 32-bit RGBA format on OCTANE/SSI, type
/usr/gfx/setmon -x <timing table>
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For example,
/usr/gfx/setmon -x 1280x1024_59_32db for 60Hz
/usr/gfx/setmon -x 1280x1024_49_32db for 50Hz

1.

To reinitialize the graphics system with the double-buffered mode, type:
/usr/gfx/gfxinit

2. Type the following command for framelocking:
/usr/gfx/setmon -Fe 1280x1024_59_32db,

or
/usr/gfx/setmon -Fe 1280x1024_49_32db

For framelocking for OCTANE/SI, see the information below:
•

To select the head with the video connection, which is determined by the pipe
number, see the reference (man) pages of setmon for detailed information.

•

To select the head that has video connected, type:
/usr/gfx/setmon -p <pipe number> -Fe <timing table>

or
/usr/gfx/setmon -p <pipe number> -Fe <timing table>
For Example,
/usr/gfx/setmon -p 0 -Fe 1280x1024_59_32db for 60Hz
/usr/gfx/setmon -p 0 -Fe 1280x1024_49_32db for 50Hz
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B. Identifying the Personal Video Board and Graphics
Boards

This appendix provides illustrations of the OCTANE Personal Video board and graphics
boards:
•

“OCTANE Personal Video Option Board” on page 72

•

“OCTANE/SI Graphics Board” on page 73

•

“OCTANE/SI With Texture Memory Option Board” on page 74

•

“OCTANE/SSI Graphics Board” on page 75

•

“OCTANE/MXI Graphics Board” on page 76
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OCTANE Personal Video Option Board

Figure B-1

72

OCTANE Personal Video Option Board

OCTANE/SI Graphics Board

OCTANE/SI Graphics Board
Cap on XIO compression
connector
Connectors for texture
memory board

Flex cable connectors

Figure B-2

OCTANE/SI Graphics Board
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OCTANE/SI With Texture Memory Option Board

Cap on XIO compression
connector

Connectors
beneath texture
memory board

Texture memory board

Figure B-3
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Flex cable connectors

OCTANE/SI With Texture Memory Option Board

OCTANE/SSI Graphics Board

OCTANE/SSI Graphics Board

Connectors for texture
memory boards

Cap on
XIO compression
connector

Flex cable connectors

Figure B-4

OCTANE/SSI Graphics Board
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OCTANE/MXI Graphics Board

Connectors for texture
memory boards
Cap on
XIO compression
connector

Texture memory boards

Flex cable connectors

Figure B-5
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OCTANE/MXI Graphics Board

Appendix C

C. Care and Cleaning of the XIO Compression Connector

This appendix provides information about the care and cleaning of the XIO compression
connectors. The OCTANE workstation uses compression connectors to connect several
modules and boards to the frontplane of the workstation.
A single compression connector is used in the OCTANE workstation in these locations:
•

on the back of the PCI module

•

on each XIO board on the XIO module

Two compression connectors are used on the system module.
The compression connector has 96 pads that enable passage of signals between the
system (via the frontplane) and the system module, PCI module, or XIO board.
The compression connector has two halves: One half is located on the frontplane of the
chassis; the other, on the system module, PCI module, or XIO board. Each pad on a
frontplane connector is a flat gold-plated surface. Each pad on the system module, PCI
module, or XIO board is composed of hundreds of tiny bristles (dendrites). When a
bristled pad is pressed into a gold-plated pad, a connection is created for one signal.

Bristled pad

Figure C-1

Identifying the Bristled Pad of the Compression Connector

The bristled pads may attract and hold dust, lint, grease, powder, and dirt. The presence
of these substances clogs or damages the bristles and prevents them from making proper
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contact with the gold-plated pads on the system’s frontplane. It is import to prevent this
from occurring.

Guidelines for Storing and Handling the Compression Connector
To avoid damaging a compression connector and to keep it in optimal working
condition, follow these guidelines whenever the board is not installed:
•

Do not wipe or touch the pads of the compression connector with anything (no
human fingers, no brushes, no cloth, no probes), except as specified in the cleaning
instructions. The bristles might be damaged.

•

Whenever the module or board is not in the chassis, put the protective cap over the
compression connector and put the module or board in an antistatic bag. Make sure
to close (fold over) the open end of the bag to minimize exposure to dust and
atmospheric gases.

•

Do not put anything (not even water) onto the pads, except as specified in the
cleaning instructions.

•

Before laying the board on a surface, make sure that the surface is free of dust, lint,
powder, metal filings, oil, water, and so on.

•

Do not blow dust, dirt, or powder anywhere near the board when it is outside its
protective bag.

Caution: Failure to follow these instructions can result in irreparable damage to the
surface of the connector’s pads, which may result in intermittent or complete failure of
the product.

Guidelines for Cleaning the Compression Connector
A compression connector should never need to be cleaned if you keep the protective
cover on whenever the module or board is not in the chassis. However, if the connector
becomes dirty, follow the instructions in this section for removing pollutants.
Note: Some pollutants can irreversibly damage (corrode or chemically alter) the pad

surfaces. Although cleaning may remove the pollutant, it does not repair damage
incurred by this contact.
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To remove pollutants, follow these instructions:
1.

Obtain a can of dry compressed air or inert gas. The Envi-ro-tech Duster 1671
product manufactured by TECHSPRAY (telephone 806-372-8523 in the USA) works
extremely well for this application.
Caution: Do not use a cleaning product that contains any of the following
ingredients: halogenated hydrocarbons, aromatic hydrocarbons, ethers, sulfur,
ketones, or solvents of any kind. These substances cause irreparable damage to the
connector’s surface.

2. Prepare the can for use, as instructed on the can. For example, if a tube is provided,
attach it to the can’s dispensing mechanism.

Figure C-2

Cleaning the XIO Compression Connector

3. Hold the can vertically.
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4. Place or hold the XIO board so that the rounded edge of the compression connector
faces up. Note that the rounded edge is completely closed, so that air cannot flow
into the connector, whereas the squared edge has an opening.
Caution: Spraying into the squared (open) edge of the connector can destroy it.
5. Position the XIO board at an angle to the can, so that the tip of the can’s applicator is
1 to 2 inches away from the first (topmost) row of pads. Do not allow the applicator
to touch the pads. When you spray, the air hits each pad and flows downward.
6. Start spraying. As you spray, move the spray along the length of the connector until
the entire length has been sprayed. Move down a few rows and again spray along
the entire length.
Note: Do not shake the can. Stop spraying if any visible material (for example, foam)

appears. This foam will blow away once you resume spraying just air.
7. Repeat until all the pads have been sprayed.
8. When you finish, cover the compression connector with its cap or immediately
install the board in an XIO slot.
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D. O2Cam Technical Specifications

Table D-1 below lists the technical specifications for the O2Cam video camera.
Table D-1

O2Cam Technical Specifications

O2Cam video camera part

Technical Specifications

Sensor

512 x 480 NTSC Color CCD, 1/3” format.

Standard lens

F2.0, 6 mm with M11 screw mount and built-in IR filter.

Output format

Outputs 640 x 480 Square Pixel NTSC frames @
29.97 Hz (780 x 525 total frame), as 422 YCrCb pixels with 1 byte
luminance followed by 1-byte chrominance, on a 24.5 MHz interface
clock.

Automatic Gain Control

Automatic Gain Control adjusts gain to achieve average output
brightness. AGC can be activated or overridden (via new gain value)
from workstation.

Shutter speeds

Selectable from 1/60 through 1/10,000 second.

Auto white balance

Software initializes camera at workstation power on and loads red
and blue balance, red and blue saturation, and gamma values that are
balanced for offices with or without windows, with incandescent
and/or fluorescent lights. User can make additional white balance
adjustments with the digital media software.

Gamma correction

Gamma factor of 0 or 255 can be loaded into camera by workstation at
any time.

Push button

The control button drives the GPIBIN line on the 68-pin connector.
While button is up, voltage is high; while button is down, voltage is
low.

Power requirements

1 W @ 5 V (200 mA), 1 W @ 12 V (80 mA), and 12 mW @ -12V (1 mA)
are provided by the workstation. These are maximum amounts
available to the camera; actual consumption should be lower.

LED indicator

On/off state is controlled by the workstation via I2C.
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Table D-1 (continued)
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O2Cam Technical Specifications

O2Cam video camera part

Technical Specifications

Workstation interface

DVCI uses 68-position 0.8 mm Champ connector on far end of
attached 8 ft cable. Video is transmitted at TTL levels, 1 byte wide plus
hsync and vsync. All camera parameters are accessed and controlled
by the workstation via I2C. Workstation provides 5 V power.

Focus adjustment

Focal distance from 3” to infinity with standard lens.

Microphone

Built-in directional microphone and preamp produces a monoaural,
single-ended line level signal.

Glossary

artifact
In video systems, an unnatural or artificial effect when the system reproduces an image.
bezel
The frame that holds the front cover and attaches to the front of the chassis.
B-Y signal
One of the color difference signals used on the NTSC and PAL systems derived by
subtracting luminance (Y) from the blue camera signal (B). The color mixture is close to
blue.
chassis
The metal framework of the workstation that contains its working parts.
choose
The action of pressing the left mouse button to bring up a popup menu, moving the
cursor to highlight the command that you want to run, and releasing the button.
composite video
A color encoding method or a video signal that contains all of the color, brightness, and
synchronizing information in one signal. The chief composite television standard signals
are NTSC, PAL, and SECAM. The OCTANE Digital Video board uses the NTSC and PAL
standards.
connector
The hardware at the end of a cable that fastens the cable to an outlet, port, or other
connector.
console
The window that appears as a stowed icon each time you log in; IRIX reports all status
and error messages to this window.
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cover
The molded plastic piece that fits over the chassis. The bezel and front cover attach to the
cover.
chrominance signal
The high-frequency portion of the video signal that is the color carrier.
framelocking
The software command that causes a workstation to write to the graphics screen at a
specified time interval, causing screen graphics to be synchronous with throughput from
a video source.
front cover
The pulldown door that allows you to access the power button and drives.
genlock
Synchronizing with another video signal serving as a master timing source. The master
timing source can be a composite video signal, a video signal with no active video (only
sync information), or, for video studio, a device called a house sync.
luminance
The video signal that describes the amount of light in each pixel.
NTSC
National Television Systems Committee. A color television standard used in North
America and parts of South America and Asia for timing format encoding all color,
brightness, and synchronizing information in one signal. The NTSC format uses 525
horizontal lines per frame, with two fields per frame of 262.5 lines each. Each field
refreshes at 60 Hz.
PAL
Phase Alternated by Line. A color-television timing standard used by most countries in
Europe, Australia, and parts of Asia. The PAL standard uses a total of 625 lines per frame,
with two fields per frame of 312.5 lines per frame. Each field refreshes at 50 Hz. See also
YIQ and YUV.
pull straps
The straps you pull to remove the graphics board set from the chassis.
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R-Y signal
A color difference signal obtained by subtracting the luminance signal from the red
camera signal. The color mixture is close to red.
SMPTE 259M
A standard delineating the serial transmission of 10-bit 4:2.2 component video signals or
4fsc NTSC composite digital signals. SMPTE 259M is a standard of the Society of Motion
Picture and Television Engineers. For more information on this standard, see
http://SMPTE.org.
S-Video, S-VHS
Video format in which the Y (luminance) and C (chrominance) portions of the signal are
kept separate. Also known as Y/C.
standoffs
Spacers that are used to stack and attach the graphics and video boards to each other.
texture mapping
The process of applying an image to a 3D object to add realism in the rendering.
Video Panel
A software control panel used for selecting video input; adjusting video signal levels and
timing characteristics; and selecting filtering, processing, and other options.
wrist strap
A flat cable that you wrap around your wrist and attach to a metal part of the workstation
whenever you work with internal components of the workstation. This prevents
electrical shocks to yourself and the components.
Y signal
The brightness of a video channel.
Y/C
Video format in which the Y (luminance) and C (chrominance) portions of the signal are
kept separate. Also known as s-video.
YIQ
The NTSC color system uses YIQ as its color space. Y stands for the image’s black and
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white portion (luminance component). The color portion is I and Q which behaves as a
color wash laid over the black and white components. See also YUV and PAL.
YUV
A color space (color component encoding format) used by the PAL video standard, in
which Y is the luminance signal, and U and V are the chrominance signals. The YUV
format derives colors from the RGB format. See also YIQ and PAL.
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A

D

adjusting video and audio, 43
Analog In, 38
attaching
flex cables, 17
audio, recording, 50

Devices
Default in, 37
Default Out, 37
Sync, 37
Digital In, 38
Digital Media Tools Guide, topics, 39
displaying video, 44

B
baffle
removing, 15
baffle, installing, 64
blank panel, 15
information, 13

E
editing audio clips, 45
editing video, 45

F
C
cable
monitor, 28
cable guard
installing, 19
removing, 55
Camera In, 38
cap
XIO compression connector, 23
CCIR-601 525, 625, 38

flex cables
attaching, 17
removing, 59
framelocking, 69

G
genlock input, 38
genlock reference, 38
Genlock Source setting, 38
graphics board
OCTANE/MXI, 76
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Index

OCTANE SI, 73
OCTANE/SI with texture memory option board,
74
OCTANE/SSI, 75

Outputs
Video Out, 38

P
H
house sync, 40

package components, 3
Personal Video board, removing, 53
Personal Video option board, 72
product support, xiii, 68

I
Inputs
Analog In, 38
Camera In, 38
Digital In, 38
Screen Source, 38
installing
software, 2
IRIX operating system, 2

M
making a movie, 50
Media Recorder, using, 48
monitor cable, 28
movie making, 50

O
O2Cam
features, 45
using, 48
OCTANE Hardware Central, xii
OCTANE Personal Video option board, 72
operating system, 2
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R
recording audio, 50
recording video, 41
regulatory label, 34
removing
cable guard, 55
flex cables, 59
Personal Video board, 53

S
saving to a hard disk, 44
SDI VCR, 42
slots
XIO module, 13
snapshot, taking, 49
software, installing, 2
spacer
installing, 16
removing, 61
Sq. Pixel modes 525, 625, 38
sync, 38
sync, house, 40

Index

T
taking a snapshot, 49

U
UNIX commands, video, 40

V
VCR, 42
video, recording, 41
video commands, UNIX, 40
video equipment, optional, 39
video panel, 36

W
wrist strap, 6

X
XIO boards
information, 13
XIO module
information, 13
slots, 13
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