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Introduction

This guide tells you how to install and use the IEEE 1394 PCI option board.
This manual contains the following chapters:
•

Chapter 1, “Installing the IEEE 1394 Option Board” explains where to find PCI
board installation instructions for your workstation, and describes how to verify the
board installation after installing the software. It also explains how to connect cables
once the board is in place.

•

Chapter 2, “Using the IEEE 1394 Utility Software” provides information on using
the IEEE 1394 Tree and DVLink utilities to capture and record video.

•

Chapter 3, “Technical Information and Product Support” contains technical
information and explains how to contact Silicon Graphics.

vii

Chapter 1

1. Installing the IEEE 1394 Option Board

This chapter explains where to find PCI board installation instructions for your
workstation and describes how to verify the board installation. It also explains how to
connect cables once the board is in place.
The following topics are covered:
•

“IEEE 1394 Option Package” on page 2

•

“Installing the IEEE 1394 Option Board in an O2 Workstation” on page 3

•

“Connecting the Cables” on page 3

•

“Installing the Software” on page 4

•

“Verifying the Hardware Installation” on page 4

•

“Connecting 1394 Digital Video Devices” on page 5
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The IEEE 1394 option board is a half-size PCI expansion board that provides three IEEE
1394 interface ports. One, two, or three of the ports may be used, and all ports have the
same functionality. You may install one IEEE 1394 board in the O2 chassis.

Figure 1-1

IEEE 1394 PCI Option Board

IEEE 1394 Option Package
Your package includes all of the items listed below. If anything is missing, contact your
sales representative.
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•

PCI IEEE 1394 option board

•

IEEE 1394 6-pin to 4-pin cable

•

IEEE 1394 6-pin to 6-pin cable

•

Antistatic wrist strap

•

IEEE 1394 Option Board Installation and User Guide (this manual)

•

Compact disc (CD-ROM)

Installing the IEEE 1394 Option Board in an O2 Workstation

Installing the IEEE 1394 Option Board in an O2 Workstation
In an O2 workstation, you install the PCI IEEE 1394 option board in the PCI module
located on the system module.
For instructions on how to install the board, see the section “Installing a PCI Board: R5000
Workstation” or “Installing a PCI Board: R10000 Workstation” in the O2 Workstation
Owner’s Guide. If you don’t have the printed owner’s guide handy, the information is also
online in the following locations:
•

IRIS InSight Library—From the Toolchest on your O2 workstation, choose
Help > Online Books > SGI EndUser > O2 Hardware Reference Guide. If the book was
removed from your system disk, you can reinstall it from the IRIX CD.

•

Silicon Graphics Technical Publications Library—If you have access to the Internet,
enter the following URL in your Web browser location window:
http://techpubs.sgi.com/library/.
Choose Catalogs > Hardware Catalog > and look in the O2 section for the
O2 Hardware Reference Guide.

After installing the board, go on to “Connecting the Cables” on page 3.

Connecting the Cables
You received two cables with your package—an IEEE 1394 6-pin to 4-pin cable and an
IEEE 1394 6-pin to 6-pin cable. Most IEEE 1394 video devices use a 4-pin connector, but
Silicon Graphics provides both types so you will always have the correct one.
1.

Examine the IEEE 1394 option board, and you will see three IEEE 1394 connectors.
All three are the 6-pin (large) style and all are equivalent; you may attach a
compatible IEEE 1394 device to any of them.

2. Examine the cables. One will have two 6-pin (large) ends, and the other will have a
6-pin end and a 4-pin (small) end. A 6-pin end is always used at the computer end
and fits into any of the three available IEEE 1394 connectors on the IEEE 1394 option
board.
3. Examine your IEEE 1394 compatible device. Many video devices have a 4-pin
connector. If so, use the 6-pin to 4-pin cable. If your device has a 6-pin connector, use
the other cable. Cables should connect from the computer (IEEE 1394 option board)
to an external device; don’t loop the cable back to the 02 because loopbacks are not
allowed by the standard.
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4. To verify that the system recognizes the new board, see “Verifying the Hardware
Installation” on page 4.

Figure 1-2

IEEE 1394 6-Pin to 4-Pin Cable

Installing the Software
After installing the board, install the PCI 1394 option software from the CD-ROM
included in the package. You can use Software Manager or Inst.
Note: The PCI 1394 option requires that the system be running IRIX 6.5.2 or later. For

instructions on installing IRIX 6.5.2, refer to the booklet that is included with the
operating system CD.

Verifying the Hardware Installation
Once you have installed the PCI option board and installed the software, verify that the
system recognizes the new hardware:
1.

Open a UNIX shell. At the prompt, enter
hinv

Look for a line similar to this:
IEEE 1394 High performance serial bus controller 0: Type: OHCI

2. If you do not see the listing, turn off the workstation and go over each step of the
installation instructions again. Make sure the board is fully seated in the slot.
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Connecting 1394 Digital Video Devices

Connecting 1394 Digital Video Devices
You can connect IEEE 1394 compatible devices to one, two, or three of the available
connectors on the IEEE 1394 option board.
The IEEE 1394 option board supports speeds of 100, 200, and 400 Megabits and may be
used with devices at any of these speeds.
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Chapter 2

2. Using the IEEE 1394 Utility Software

This chapter provides information about utility programs included on the CD-ROM
shipped with the IEEE 1394 option board. These utilities provide information about
attached IEEE 1394 peripheral devices and also permit you to transfer video and audio
information to and from attached IEEE 1394 Digital Video (DV) devices.
If you have not yet installed the software, do so now. Refer to “Installing the Software”
on page 4.

Using IEEE1394Tree to Display Bus Topology
Note: All software instructions included in this section are based on the IRIX 6.5.2

operating system. If you have upgraded to a subsequent operating system, some of the
instructions may no longer be valid. If this is the case, check the latest information by
using the online documentation that came with your new software.
To display all devices on the IEEE 1394 serial bus that are attached to an O2 workstation:
•

From a shell prompt, enter ieee1394tree

•

For more detailed information about attached devices, use the File menu option
Show All Node Attributes.

Figure 2-1

IEEE1394Tree
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Using DVLink with IEEE 1394 Video Devices
The DVLink utility allows you to communicate over the IEEE 1394 cable with video
devices such as cameras and decks. The utility provides a preview window, deck
controls, and the ability to record digital video (DV) to and from video devices.
DVLink provides a graphical user interface with simple controls.
To start the DVLink utility, from a shell prompt, enter dvlink.

Preview window

Preview window
channel number

Preview window
audio level button

Transport control buttons and
current transport time control
Duration window

In Point window

Out Point window

Record Video From
pulldown menu

Output channel
Filename area

Figure 2-2
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DVLink

Using DVLink with IEEE 1394 Video Devices

DVLink options and controls include:
•

Preview window. The preview window shows video as transmitted from the video
device. It is always active, and automatically switches between NTSC and PAL to
display the format of the received video.

•

Preview window channel number 0-63. If you have one video device, it will operate on
channel 63 by default and DVLink will automatically talk to it. If you have multiple
video devices attached to your IEEE 1394 option card that send video data over
different channels, you may select between them by changing the channel number
using the increase or decrease buttons. Also note that if you have multiple devices,
you may run multiple copies of DVLink with each previewing a particular channel.

•

Preview window audio level button. Click to adjust the audio level you hear from the
video source. Output goes to the default audio device. If the audio level is set to the
lowest setting, audio decoding is turned off, reducing the CPU load. The audio level
may also be set from the apanel utility.

•

Transport control buttons and current transport time control. The buttons control
attached video devices over the IEEE 1394 interface, and the current transport
position shows the tape location as reported by the video device over the IEEE 1394
interface. It is also possible to send an AVC Search command by typing the time
code into the tape transport position directly.

•

The In Point window. Used to specify the starting point for a capture from tape. The
time units are hours:minutes:seconds:frames.

•

The Out Point window. Used to specify the ending point for a capture from tape

•

The Duration window. Shows the duration for a capture or record operation. You may
use the In Point, Out Point, and Duration windows for input of any of these values,
with the others updated automatically.

•

The Record Video From pulldown menu. Allows you to choose one of the devices
currently plugged into the IEEE 1394 interface. Even with nothing attached to the
computer, you will see the O2 IEEE 1394 interface as one device. When you attach a
video device, you will have the option of choosing between the AVC Device and the
Phy ID device. If you have more than one video device attached, you may select the
one you want from this menu. Be sure to select an AVC device for proper operation.
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•

The Output/Input Channel. Defaults to 63 with one video device attached, and may
be changed using the increase or decrease buttons to select another video channel
number. Note that a device transmits video on one channel, and all other devices on
the bus can receive it if selected to that channel.
While in the Video to Disk record mode, you may change the Output channel of the
AVC device that is playing. This allows playing multiple VCRs at the same time
with preview or capture of particular channels by running multiple copies of
DVLink.
Likewise, while in the Video to Tape record mode you may set the Input channel of
the video device, that is, the channel on which the AVC device should listen for a
DV stream.
Note: The performance of Video to Disk and Video to Tape are heavily dependent

on the available system resources and system configuration. In the Video to Tape
record mode, pressing the record button sends the record command to the remote
VCR or camcorder. To record the video file onto the tape, press the play button before
or after the record button is pressed.
•

Filename area. Used to select a filename for Record Video to Disk, Frame to Disk and
Video to Tape. Recently used filenames may be recalled with the recall button to the
right of the filename.

The DVLink menus allow user control over various details of the capture and export
process.
You can eject a tape from an attached video device by using the Eject option under the
File menu. Note that some consumer devices may not implement the remote eject control
function. You may also exit from the DVLink program by using the Exit option under the
File menu.
You may clear (zero) all the timecode input fields by using the Clear All option under the
Edit menu.
Under the View menu you may launch several auxiliary utilities:
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•

The Device Tree program (ieee1394tree), which shows a graph of attached IEEE 1394
devices.

•

The Audio Panel (apanel), which is used to control audio devices such as selecting
default input and output interfaces and setting the audio output level.

•

The Movie Player utility (movieplayer), which is used to play back movie files.

Using DVLink with IEEE 1394 Video Devices

The View menu also contains a submenu to select time units. The choices include display
time as:
•

Timecode (hours, minutes, seconds, frames)

•

Count of frames

•

Seconds and fractions

Under Options you may select the type of record mode. There are four choices:
•

Video to Disk: Record from an attached video device to a computer disk file.

•

Frame to Disk: Record just one frame to a computer disk file from an attached video
device.

•

Video to Tape: Copy a computer video file to the tape in an attached video device.
The Convert to DV option remains grayed out until users specify a file to be
exported using the option Video to Tape and a movie file that is not in the DV
format. In this case, you will be prompted when trying to play the file that the file is
not DV and may then specify the Convert to DV option under the Options menu.

•

Link Channels: If selected, the preview and Output/Input channel of the attached
device are linked; that is, if one is changed the other changes too. The default is
unlinked, allowing preview on one channel while capturing or recording to another
channel.
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Chapter 3

3. Technical Information and Product Support

This chapter contains the following sections:
•

“IEEE 1394 Software Library Interfaces” on page 14

•

“IEEE 1394 Sample Source Code” on page 15

•

“Product Support” on page 15
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IEEE 1394 Software Library Interfaces
For man page documentation on the AVC video device interface library, install the IEEE
1394 Development Environment from the CD-ROM and enter man avc for summary
usage information. The available AVC interfaces (each with its own man page) include:
avc
avcGetUnitInputChannel
avcAcquireFrame
avcGetUnitOutputChannel
avcAllocateBandwidth
avcGetUnitPhyID
avcAllocateChannel
avcGetUnitUID
avcAvailableBandwidth
avcGetUnitVendorID
avcAvailableChannels
avcIntro avcClosePort
avcIsFrameValid
avcCommand
avcIsUnitAVC
avcFreeBandwidth
avcNewConfig
avcFreeChannel
avcNewFrame
avcFreeConfig
avcNewUnit
avcFreeUnit
avcOpenPort
avcGetBufferSize
avcReceiveFrame
avcGetChannel
avcReleaseFrame
avcGetConfig
avcSendFrame
avcGetDirection
avcSetBufferSize
avcGetFD
avcSetChannel
avcGetFrameData
avcSetConfig
avcGetFrameSize
avcSetFrameTiming
avcGetFrameTiming
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IEEE 1394 Sample Source Code

avcSetSpeed
avcGetGenerationNumber
avcSetUnitInputChannel
avcGetNumUnits
avcSetUnitOutputChannel
avcGetPortPhyID
avcGetSpeed

For man page documentation on the raw IEEE 1394 interface library, enter man raw1394.

IEEE 1394 Sample Source Code
For sample code using the programmatic interface libraries, see:
/usr/share/src/ieee1394/avc
/usr/share/src/ieee1394/raw

Each directory contains a Makefile and associated source code files.
For general use with video devices, use the avc functions. The raw interface library is
intended for experienced IEEE 1394 developers.

Product Support
Silicon Graphics provides a comprehensive range of product support for its products. If
you are in North America and would like support for your Silicon Graphics supported
products, contact the Technical Assistance Center at 1-800-800-4SGI or your authorized
service provider. If you are outside North America, contact the Silicon Graphics
subsidiary or authorized distributor in your country.
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Tell Us About This Manual
As a user of Silicon Graphics products, you can help us to better understand your needs
and to improve the quality of our documentation.
Any information that you provide will be useful. Here is a list of suggested topics:
•

General impression of the document

•

Omission of material that you expected to find

•

Technical errors

•

Relevance of the material to the job you had to do

•

Quality of the printing and binding

Please send the title and part number of the document with your comments. The part
number for this document is 007-3958-001.
Thank you!

Three Ways to Reach Us
•

To send your comments by electronic mail, use either of these addresses:
–

On the Internet: techpubs@sgi.com

–

For UUCP mail (through any backbone site): [your_site]!sgi!techpubs

•

To fax your comments (or annotated copies of manual pages), use this
fax number: 650-932-0801

•

To send your comments by traditional mail, use this address:
Technical Publications
Silicon Graphics, Inc.
2011 North Shoreline Boulevard, M/S 535
Mountain View, California 94043-1389

